summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-08-14 12:48:31 +0000
committerJeroen Roovers <jer@gentoo.org>2013-08-14 12:48:31 +0000
commitc288e4876e3d1d4fe55aa384749570cd2da97745 (patch)
tree3f6da99de3bf2884b32cb83414ab90c4f8689591 /net-analyzer/nfdump
parentRemove -l option to exec(1p) for POSIX conformance (e.g. dash, bug #473200). ... (diff)
downloadgentoo-2-c288e4876e3d1d4fe55aa384749570cd2da97745.tar.gz
gentoo-2-c288e4876e3d1d4fe55aa384749570cd2da97745.tar.bz2
gentoo-2-c288e4876e3d1d4fe55aa384749570cd2da97745.zip
Version bump (bug #481022 by Alexandr Tiurin).
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/nfdump')
-rw-r--r--net-analyzer/nfdump/ChangeLog8
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild (renamed from net-analyzer/nfdump/nfdump-1.6.8.ebuild)13
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.5.ebuild54
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.6.ebuild59
4 files changed, 13 insertions, 121 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index 79e617d8ccb5..aa3ffada5366 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nfdump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.34 2013/06/25 12:49:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.35 2013/08/14 12:48:31 jer Exp $
+
+*nfdump-1.6.10_p1 (14 Aug 2013)
+
+ 14 Aug 2013; Jeroen Roovers <jer@gentoo.org> -nfdump-1.6.5.ebuild,
+ -nfdump-1.6.6.ebuild, -nfdump-1.6.8.ebuild, +nfdump-1.6.10_p1.ebuild:
+ Version bump (bug #481022 by Alexandr Tiurin).
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> nfdump-1.6.9.ebuild:
Stable for amd64, wrt bug #470536
diff --git a/net-analyzer/nfdump/nfdump-1.6.8.ebuild b/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild
index 5f4b15d2be99..a32db5024c31 100644
--- a/net-analyzer/nfdump/nfdump-1.6.8.ebuild
+++ b/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.8.ebuild,v 1.2 2012/11/05 12:53:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild,v 1.1 2013/08/14 12:48:31 jer Exp $
-EAPI=4
+EAPI=5
inherit autotools eutils
MY_P="${P/_/}"
@@ -13,16 +13,14 @@ SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# Fails to build readpcap:
-# https://sourceforge.net/tracker/?func=detail&aid=2996582&group_id=119350&atid=683752
-IUSE="compat15 debug ftconv nfprofile nftrack sflow"
+IUSE="compat15 debug ftconv nfprofile nftrack readpcap sflow"
CDEPEND="
ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
nfprofile? ( net-analyzer/rrdtool )
nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
"
-# readpcap? ( net-libs/libpcap )"
DEPEND="
${CDEPEND}
sys-devel/flex
@@ -57,5 +55,6 @@ src_configure() {
$(use nftrack && echo --enable-nftrack) \
$(use_enable compat15) \
$(use_enable debug devel) \
+ $(use_enable readpcap) \
$(use_enable sflow)
}
diff --git a/net-analyzer/nfdump/nfdump-1.6.5.ebuild b/net-analyzer/nfdump/nfdump-1.6.5.ebuild
deleted file mode 100644
index e203d82be7e8..000000000000
--- a/net-analyzer/nfdump/nfdump-1.6.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.5.ebuild,v 1.4 2012/04/05 21:23:32 phajdan.jr Exp $
-
-EAPI=4
-inherit autotools eutils
-
-MY_P="${P/_/}"
-DESCRIPTION="A set of tools to collect and process netflow data"
-HOMEPAGE="http://nfdump.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# Fails to build readpcap:
-# https://sourceforge.net/tracker/?func=detail&aid=2996582&group_id=119350&atid=683752
-IUSE="compat15 debug ftconv nfprofile sflow"
-
-CDEPEND="
- ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
- nfprofile? ( net-analyzer/rrdtool )"
-# readpcap? ( net-libs/libpcap )"
-DEPEND="${CDEPEND}
- sys-devel/flex"
-RDEPEND=${CDEPEND}"
- dev-lang/perl"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- if use ftconv; then
- sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
- sed \
- -e 's:lib\(/ftlib.h\):include\1:' \
- -e 's:libft.a:libft.so:' \
- \-i configure.in || die
- fi
- sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
- eautoreconf
-}
-
-src_configure() {
- # --without-ftconf is not handled well #322201
- econf \
- $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
- $(use nfprofile && echo "--enable-nfprofile") \
- $(use_enable sflow) \
- $(use_enable debug devel) \
- $(use_enable compat15)
- # $(use_enable readpcap) \
-}
diff --git a/net-analyzer/nfdump/nfdump-1.6.6.ebuild b/net-analyzer/nfdump/nfdump-1.6.6.ebuild
deleted file mode 100644
index 8431e3b93557..000000000000
--- a/net-analyzer/nfdump/nfdump-1.6.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.6.ebuild,v 1.4 2012/10/31 16:53:49 ago Exp $
-
-EAPI=4
-inherit autotools eutils
-
-MY_P="${P/_/}"
-DESCRIPTION="A set of tools to collect and process netflow data"
-HOMEPAGE="http://nfdump.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# Fails to build readpcap:
-# https://sourceforge.net/tracker/?func=detail&aid=2996582&group_id=119350&atid=683752
-IUSE="compat15 debug ftconv nfprofile sflow"
-
-CDEPEND="
- ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
- nfprofile? ( net-analyzer/rrdtool )
-"
-# readpcap? ( net-libs/libpcap )"
-DEPEND="
- ${CDEPEND}
- sys-devel/flex
- virtual/yacc
-"
-RDEPEND="
- ${CDEPEND}
- dev-lang/perl"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- if use ftconv; then
- sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
- sed \
- -e 's:lib\(/ftlib.h\):include\1:' \
- -e 's:libft.a:libft.so:' \
- \-i configure.in || die
- fi
- sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
- eautoreconf
-}
-
-src_configure() {
- # --without-ftconf is not handled well #322201
- econf \
- $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
- $(use nfprofile && echo "--enable-nfprofile") \
- $(use_enable sflow) \
- $(use_enable debug devel) \
- $(use_enable compat15)
- # $(use_enable readpcap) \
-}