summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-05 10:08:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-05 10:08:09 +0000
commitccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784 (patch)
tree57921da938d2753668c896eca1bb303ebc2c3bf7 /net-analyzer/nethogs
parentx86 stable wrt #249491 (diff)
downloadgentoo-2-ccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784.tar.gz
gentoo-2-ccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784.tar.bz2
gentoo-2-ccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784.zip
Version bump with GCC 4.3 and GLIBC 2.8 patch.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'net-analyzer/nethogs')
-rw-r--r--net-analyzer/nethogs/ChangeLog10
-rw-r--r--net-analyzer/nethogs/files/nethogs-0.6.1_pre2-gcc43.patch34
-rw-r--r--net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild36
3 files changed, 78 insertions, 2 deletions
diff --git a/net-analyzer/nethogs/ChangeLog b/net-analyzer/nethogs/ChangeLog
index 90c48742197b..f0e83104b61e 100644
--- a/net-analyzer/nethogs/ChangeLog
+++ b/net-analyzer/nethogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nethogs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/ChangeLog,v 1.9 2007/04/12 17:59:22 welp Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/ChangeLog,v 1.10 2008/12/05 10:08:09 ssuominen Exp $
+
+*nethogs-0.6.1_pre2 (05 Dec 2008)
+
+ 05 Dec 2008; <ssuominen@gentoo.org> +files/nethogs-0.6.1_pre2-gcc43.patch,
+ +nethogs-0.6.1_pre2.ebuild:
+ Version bump with GCC 4.3 and GLIBC 2.8 patch.
12 Apr 2007; <welp@gentoo.org> nethogs-0.6.0.ebuild:
Stable on amd64
diff --git a/net-analyzer/nethogs/files/nethogs-0.6.1_pre2-gcc43.patch b/net-analyzer/nethogs/files/nethogs-0.6.1_pre2-gcc43.patch
new file mode 100644
index 000000000000..2f4423532ccf
--- /dev/null
+++ b/net-analyzer/nethogs/files/nethogs-0.6.1_pre2-gcc43.patch
@@ -0,0 +1,34 @@
+diff -ur nethogs.orig/cui.cpp nethogs/cui.cpp
+--- nethogs.orig/cui.cpp 2004-09-17 22:23:20.000000000 +0300
++++ nethogs/cui.cpp 2008-12-05 12:02:58.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <string>
+ #include <pwd.h>
+ #include <sys/types.h>
++#include <stdlib.h>
+
+ #include <ncurses.h>
+ #include "nethogs.h"
+diff -ur nethogs.orig/decpcap.c nethogs/decpcap.c
+--- nethogs.orig/decpcap.c 2004-09-18 15:23:38.000000000 +0300
++++ nethogs/decpcap.c 2008-12-05 12:04:46.000000000 +0200
+@@ -5,6 +5,7 @@
+ #include <netinet/tcp.h>
+ #include <pcap.h>
+ #include "decpcap.h"
++#include <string.h>
+
+ /* data container for callback-references */
+
+diff -ur nethogs.orig/inodeproc.cpp nethogs/inodeproc.cpp
+--- nethogs.orig/inodeproc.cpp 2004-09-14 19:14:23.000000000 +0300
++++ nethogs/inodeproc.cpp 2008-12-05 12:06:30.000000000 +0200
+@@ -11,6 +11,8 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+
++#include <limits.h>
++
+ struct proginfo
+ {
+ int pid;
diff --git a/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild b/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild
new file mode 100644
index 000000000000..a86056a0348c
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild,v 1.1 2008/12/05 10:08:09 ssuominen Exp $
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://nethogs.sf.net/"
+SRC_URI="http://${PN}.sourceforge.net/${P/_/-}.tar.gz"
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -e "s:-O2:${CFLAGS}:g" -e "s:g++:$(tc-getCXX):g" \
+ -e "s:gcc:$(tc-getCC):g" -i Makefile || die "sed failed."
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.8
+ dodoc Changelog DESIGN README
+}