summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-12 06:51:26 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-12 06:51:26 +0000
commit8ef224cd490f49c209696b36566de22314b56b10 (patch)
treeab1533d39c389a77313723de6733618f239d7980 /net-analyzer/nessus-libraries
parentRemoved RDEPEND=${DEPEND} (diff)
downloadgentoo-2-8ef224cd490f49c209696b36566de22314b56b10.tar.gz
gentoo-2-8ef224cd490f49c209696b36566de22314b56b10.tar.bz2
gentoo-2-8ef224cd490f49c209696b36566de22314b56b10.zip
Removed RDEPEND=${DEPEND}
Diffstat (limited to 'net-analyzer/nessus-libraries')
-rw-r--r--net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild33
1 files changed, 9 insertions, 24 deletions
diff --git a/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild b/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild
index 33e1d4b1d59a..0040526407ba 100644
--- a/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild
+++ b/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild
@@ -1,46 +1,31 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
-
-IUSE="ssl"
-
-S=${WORKDIR}/${PN}
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-1.2.6.ebuild,v 1.2 2002/11/12 06:47:01 vapier Exp $
DESCRIPTION="A remote security scanner for Linux (nessus-libraries)"
HOMEPAGE="http://www.nessus.org/"
SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
-RDEPEND=${DEPEND}
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc -sparc -sparc64"
+IUSE="ssl"
-src_compile() {
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf=""
use ssl && myconf="--with-ssl=/usr/lib" \
|| myconf="--without-ssl"
- econf \
- ${myconf} || die "configure failed"
-
-
+ econf ${myconf}
emake || die "emake failed"
-
}
src_install() {
-
- make \
- prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- mandir=${D}/usr/share/man \
- install || die "make install failed"
-
- cd ${S}
+ einstall
docinto nessus-libraries
dodoc README*
-
}