summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-02 17:59:12 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-02 17:59:12 +0000
commitcf92b28658e9360d2c80f7e905871f47c77ef7ce (patch)
tree1625cb0c86e5c4a8ce16554a83c062fe9febca47 /net-analyzer/nbaudit
parentFix bad patch after upstream review. (diff)
downloadgentoo-2-cf92b28658e9360d2c80f7e905871f47c77ef7ce.tar.gz
gentoo-2-cf92b28658e9360d2c80f7e905871f47c77ef7ce.tar.bz2
gentoo-2-cf92b28658e9360d2c80f7e905871f47c77ef7ce.zip
Respect CFLAGS (bug #240860). Respect LDFLAGS (bug #335528). Respect CC.
(Portage version: 2.2_rc72/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/nbaudit')
-rw-r--r--net-analyzer/nbaudit/ChangeLog9
-rw-r--r--net-analyzer/nbaudit/nbaudit-1.0-r2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-analyzer/nbaudit/ChangeLog b/net-analyzer/nbaudit/ChangeLog
index b7218f8c12e1..44ac1fb0911c 100644
--- a/net-analyzer/nbaudit/ChangeLog
+++ b/net-analyzer/nbaudit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nbaudit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbaudit/ChangeLog,v 1.15 2009/10/28 04:19:14 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbaudit/ChangeLog,v 1.16 2010/09/02 17:59:12 jer Exp $
+
+*nbaudit-1.0-r2 (02 Sep 2010)
+
+ 02 Sep 2010; Jeroen Roovers <jer@gentoo.org> +nbaudit-1.0-r2.ebuild:
+ Respect CFLAGS (bug #240860). Respect LDFLAGS (bug #335528). Respect CC.
28 Oct 2009; Robin H. Johnson <robbat2@gentoo.org> nbaudit-1.0-r1.ebuild:
Keyword for ~amd64.
diff --git a/net-analyzer/nbaudit/nbaudit-1.0-r2.ebuild b/net-analyzer/nbaudit/nbaudit-1.0-r2.ebuild
new file mode 100644
index 000000000000..dc86bedeb803
--- /dev/null
+++ b/net-analyzer/nbaudit/nbaudit-1.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbaudit/nbaudit-1.0-r2.ebuild,v 1.1 2010/09/02 17:59:12 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+# It is officially called nat10 but the name conflicts with other projects
+# so I'm following the *BSDs suggestion of calling it nbaudit
+
+MY_P=nat10
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="NetBIOS file sharing services scanner (nat10)"
+SRC_URI="http://www.tux.org/pub/security/secnet/tools/nat10/${MY_P}.tgz"
+HOMEPAGE="http://www.tux.org/pub/security/secnet/tools/nat10/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ sed -i Makefile \
+ -e 's:-lshadow::' \
+ -e 's|^CFLAGS = |CFLAGS +=|g' \
+ -e 's| $(CFLAGS) -o | $(LDFLAGS) &|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) all || die "make failed"
+}
+
+src_install () {
+ newbin nat nbaudit
+ newman nat.1 nbaudit.1
+ dodoc README COPYING
+}