summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-24 15:52:29 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-24 15:52:29 +0000
commit9ae1c45807f4fcdcc1296cfdbae782fcbc3b2e2a (patch)
treec617db3609dc145909415ddcf7d17d78afe0aa43 /net-analyzer/nagios-plugins
parentbump (Manifest recommit) (diff)
downloadgentoo-2-9ae1c45807f4fcdcc1296cfdbae782fcbc3b2e2a.tar.gz
gentoo-2-9ae1c45807f4fcdcc1296cfdbae782fcbc3b2e2a.tar.bz2
gentoo-2-9ae1c45807f4fcdcc1296cfdbae782fcbc3b2e2a.zip
added contrib plugins. closes #57429
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog6
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild13
2 files changed, 17 insertions, 2 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index e78d2b9e3879..14d0a843cbe1 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.21 2004/07/11 10:21:25 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.22 2004/07/24 15:52:29 eldad Exp $
+
+ 24 Jul 2004; Eldad Zack <eldad@gentoo.org> nagios-plugins-1.3.1-r1.ebuild:
+ Added contrib plugins to install. As a special case, insert check_nagios_db.pl
+ directly into libexec when emerge with db support. Closes #57429.
11 Jul 2004; Eldad Zack <eldad@gentoo.org> nagios-plugins-1.3.1-r1.ebuild:
marked x86 stable
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
index c742120baf4b..396709bc3a9f 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.4 2004/07/11 10:21:25 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.5 2004/07/24 15:52:29 eldad Exp $
inherit eutils
@@ -53,6 +53,15 @@ src_compile() {
src_install() {
dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
make DESTDIR=${D} install || die
+
+ if use mysql || use postgres; then
+ dodir /usr/nagios/libexec
+ exeinto /usr/nagios/libexec
+ doexe ${S}/contrib/check_nagios_db.pl
+ fi
+
+ dodir /usr/nagios/libexec/
+ mv ${S}/contrib ${D}/usr/nagios/libexec/contrib
}
pkg_preinst() {
@@ -63,4 +72,6 @@ pkg_postinst() {
einfo "This ebuild has a number of USE flags which determines what nagios is able to monitor."
einfo "Depending on what you want to monitor with nagios, some or all of these USE"
einfo "flags need to be set for nagios to function correctly."
+ echo ""
+ einfo "contrib plugins are installed into /usr/nagios/libexec/contrib"
}