summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-01-13 18:23:13 +0000
committerJeroen Roovers <jer@gentoo.org>2015-01-13 18:23:13 +0000
commit1a3161d3c31b19ddfda56d0c0eb01a4dbae5e51b (patch)
treebe1d0d46daf419d5a36808d29b5af78753bddcef /net-analyzer/ippl
parentversion bump (bug #530642) (diff)
downloadgentoo-2-1a3161d3c31b19ddfda56d0c0eb01a4dbae5e51b.tar.gz
gentoo-2-1a3161d3c31b19ddfda56d0c0eb01a4dbae5e51b.tar.bz2
gentoo-2-1a3161d3c31b19ddfda56d0c0eb01a4dbae5e51b.zip
Fix some format warnings (bug #536116).
(Portage version: 2.2.15/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/ippl')
-rw-r--r--net-analyzer/ippl/ChangeLog8
-rw-r--r--net-analyzer/ippl/files/ippl-1.4.14-format-warnings.patch20
-rw-r--r--net-analyzer/ippl/ippl-1.4.14-r5.ebuild (renamed from net-analyzer/ippl/ippl-1.4.14-r4.ebuild)10
3 files changed, 33 insertions, 5 deletions
diff --git a/net-analyzer/ippl/ChangeLog b/net-analyzer/ippl/ChangeLog
index b21b488ac8b8..e89f4567f82f 100644
--- a/net-analyzer/ippl/ChangeLog
+++ b/net-analyzer/ippl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ippl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.28 2015/01/09 13:49:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.29 2015/01/13 18:23:12 jer Exp $
+
+*ippl-1.4.14-r5 (13 Jan 2015)
+
+ 13 Jan 2015; Jeroen Roovers <jer@gentoo.org> -ippl-1.4.14-r4.ebuild,
+ +ippl-1.4.14-r5.ebuild, +files/ippl-1.4.14-format-warnings.patch:
+ Fix some format warnings (bug #536116).
09 Jan 2015; Agostino Sarubbo <ago@gentoo.org> ippl-1.4.14-r4.ebuild:
Stable for amd64, wrt bug #535526
diff --git a/net-analyzer/ippl/files/ippl-1.4.14-format-warnings.patch b/net-analyzer/ippl/files/ippl-1.4.14-format-warnings.patch
new file mode 100644
index 000000000000..db6cfcd7e1d0
--- /dev/null
+++ b/net-analyzer/ippl/files/ippl-1.4.14-format-warnings.patch
@@ -0,0 +1,20 @@
+--- a/Source/log.c
++++ b/Source/log.c
+@@ -147,7 +147,7 @@
+ }
+
+ if (repeats > 0) {
+- snprintf(date, 27, asctime(localtime(&last_repeat)));
++ snprintf(date, 27, "%s", asctime(localtime(&last_repeat)));
+ snprintf(repeat_message, 40, "last message repeated %d time(s)\n", repeats);
+ write(fd, date+4, strlen(date)-10);
+ write(fd, " ", 1);
+@@ -155,7 +155,7 @@
+ repeats = 0;
+ }
+
+- snprintf(date, 27, asctime(localtime(&current)));
++ snprintf(date, 27, "%s", asctime(localtime(&current)));
+ write(fd, date+4, strlen(date)-10);
+ write(fd, " ", 1);
+ write(fd, entry, (strlen(entry) < 1023) ? strlen(entry) : 1023 );
diff --git a/net-analyzer/ippl/ippl-1.4.14-r4.ebuild b/net-analyzer/ippl/ippl-1.4.14-r5.ebuild
index d242ada5af27..5ce919720454 100644
--- a/net-analyzer/ippl/ippl-1.4.14-r4.ebuild
+++ b/net-analyzer/ippl/ippl-1.4.14-r5.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ippl-1.4.14-r4.ebuild,v 1.2 2015/01/09 13:49:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ippl-1.4.14-r5.ebuild,v 1.1 2015/01/13 18:23:12 jer Exp $
EAPI=5
-
inherit eutils toolchain-funcs user
DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
@@ -13,7 +12,6 @@ SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~x86"
-IUSE=""
DEPEND="virtual/yacc
>=sys-devel/flex-2.5.4a-r4"
@@ -23,13 +21,17 @@ src_prepare() {
"${FILESDIR}"/ippl-1.4.14-noportresolve.patch \
"${FILESDIR}"/ippl-1.4.14-manpage.patch \
"${FILESDIR}"/ippl-1.4.14-privilege-drop.patch \
- "${FILESDIR}"/ippl-1.4.14-includes.patch
+ "${FILESDIR}"/ippl-1.4.14-includes.patch \
+ "${FILESDIR}"/ippl-1.4.14-format-warnings.patch
+
sed -i Source/Makefile.in \
-e 's|^LDFLAGS=|&@LDFLAGS@|g' \
|| die
+
sed -i Makefile.in \
-e 's|make |$(MAKE) |g' \
|| die
+
# fix for bug #351287
sed -i -e '/lex.yy.c/s/ippl.l/& y.tab.c/' Source/Makefile.in \
|| die