summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-18 03:32:15 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-18 03:32:15 +0000
commit436eb32ed6139fdc9dd29a26d55cd02c22871732 (patch)
treed188f97c3be1eb45cfe05e95f094f13646aa8a23 /net-analyzer/hydra
parentVersion bump. (diff)
downloadgentoo-2-436eb32ed6139fdc9dd29a26d55cd02c22871732.tar.gz
gentoo-2-436eb32ed6139fdc9dd29a26d55cd02c22871732.tar.bz2
gentoo-2-436eb32ed6139fdc9dd29a26d55cd02c22871732.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/ChangeLog7
-rw-r--r--net-analyzer/hydra/hydra-8.0.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/net-analyzer/hydra/ChangeLog b/net-analyzer/hydra/ChangeLog
index 6c05540998fd..e11495441a25 100644
--- a/net-analyzer/hydra/ChangeLog
+++ b/net-analyzer/hydra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/hydra
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.82 2014/01/11 12:22:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.83 2014/05/18 03:32:13 jer Exp $
+
+*hydra-8.0 (18 May 2014)
+
+ 18 May 2014; Jeroen Roovers <jer@gentoo.org> +hydra-8.0.ebuild:
+ Version bump.
*hydra-7.6 (11 Jan 2014)
diff --git a/net-analyzer/hydra/hydra-8.0.ebuild b/net-analyzer/hydra/hydra-8.0.ebuild
new file mode 100644
index 000000000000..561920654245
--- /dev/null
+++ b/net-analyzer/hydra/hydra-8.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/hydra-8.0.ebuild,v 1.1 2014/05/18 03:32:15 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="http://www.thc.org/thc-hydra/"
+SRC_URI="http://freeworld.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="firebird gtk idn mysql ncp oracle pcre postgres ssl subversion"
+
+RDEPEND="
+ dev-libs/openssl
+ sys-libs/ncurses
+ firebird? ( dev-db/firebird )
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+ idn? ( net-dns/libidn )
+ mysql? ( virtual/mysql )
+ ncp? ( net-fs/ncpfs )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql-base )
+ ssl? ( >=net-libs/libssh-0.4.0 )
+ subversion? ( dev-vcs/subversion )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # None of the settings in Makefile.unix are useful to us
+ : > Makefile.unix
+
+ sed -i \
+ -e 's:|| echo.*$::' \
+ -e '/\t-$(CC)/s:-::' \
+ -e '/^OPTS/{s|=|+=|;s| -O3||}' \
+ -e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
+ Makefile.am || die
+}
+
+src_configure() {
+ export OPTS="${CFLAGS}"
+
+ if ! use subversion; then
+ sed -i 's/-lsvn_client-1 -lapr-1 -laprutil-1 -lsvn_subr-1//;s/-DLIBSVN//' configure || die
+ fi
+
+ if ! use mysql; then
+ sed -i 's/-lmysqlclient//;s/-DLIBMYSQLCLIENT//' configure || die
+ fi
+
+ # Linking against libtinfo might be enough here but pkg-config --libs tinfo
+ # would require a USE=tinfo flag and recent linkers should drop libcurses
+ # as needed
+ sed -i \
+ -e 's|-lcurses|'"$( $(tc-getPKG_CONFIG) --libs ncurses)"'|g' \
+ configure || die
+
+ # Note: despite the naming convention, the top level script is not an
+ # autoconf-based script.
+ ./configure \
+ --prefix=/usr \
+ --nostrip \
+ $(use gtk && echo --disable-xhydra) \
+ || die
+
+ if use gtk ; then
+ cd hydra-gtk && \
+ econf
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake
+ use gtk && emake -C hydra-gtk
+}
+
+src_install() {
+ dobin hydra pw-inspector
+ use gtk && dobin hydra-gtk/src/xhydra
+ dodoc CHANGES README
+}