summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-05-07 14:45:54 +0000
committerJeroen Roovers <jer@gentoo.org>2013-05-07 14:45:54 +0000
commitef0ba6bf662a4de27ec80adf5797d2fe5c71aee6 (patch)
tree30c677f34011a3adf3179b0ded08fd408aa47602 /net-analyzer/httping
parentmigrate -> distutils-r1 (diff)
downloadgentoo-2-ef0ba6bf662a4de27ec80adf5797d2fe5c71aee6.tar.gz
gentoo-2-ef0ba6bf662a4de27ec80adf5797d2fe5c71aee6.tar.bz2
gentoo-2-ef0ba6bf662a4de27ec80adf5797d2fe5c71aee6.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-2.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 22f4a925d9d6..08a0553aa144 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.100 2013/05/01 11:15:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.101 2013/05/07 14:45:54 jer Exp $
+
+*httping-2.3 (07 May 2013)
+
+ 07 May 2013; Jeroen Roovers <jer@gentoo.org> +httping-2.3.ebuild:
+ Version bump.
01 May 2013; Jeroen Roovers <jer@gentoo.org> httping-1.5.5.ebuild,
httping-1.5.8.ebuild, httping-2.0.ebuild, httping-2.1.ebuild,
diff --git a/net-analyzer/httping/httping-2.3.ebuild b/net-analyzer/httping/httping-2.3.ebuild
new file mode 100644
index 000000000000..25867e06e7c2
--- /dev/null
+++ b/net-analyzer/httping/httping-2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.3.ebuild,v 1.1 2013/05/07 14:45:54 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug fftw ncurses ssl tfo"
+
+RDEPEND="
+ fftw? ( sci-libs/fftw:3.0 )
+ ncurses? ( >=sys-libs/ncurses-5 )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.1-flags.patch
+}
+
+src_configure() {
+ # not an autotools script
+ echo > makefile.inc || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ FW=$(usex fftw) \
+ DEBUG=$(usex debug) \
+ NC=$(usex ncurses) \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+}