summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-20 18:13:35 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-20 18:13:35 +0000
commit8fbc3f034821bca4b1e94882f8a07ad1c5330280 (patch)
tree7726d62666d40bdff9a7977816767fb1d480a454 /net-analyzer/httping
parentamd64, ppc64, x86 stable, wrt bug #462512 (diff)
downloadgentoo-2-8fbc3f034821bca4b1e94882f8a07ad1c5330280.tar.gz
gentoo-2-8fbc3f034821bca4b1e94882f8a07ad1c5330280.tar.bz2
gentoo-2-8fbc3f034821bca4b1e94882f8a07ad1c5330280.zip
Respect CFLAGS/LDFLAGS.
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog6
-rw-r--r--net-analyzer/httping/files/httping-2.0-flags.patch23
-rw-r--r--net-analyzer/httping/httping-1.6.ebuild43
-rw-r--r--net-analyzer/httping/httping-2.0.ebuild6
4 files changed, 31 insertions, 47 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 2f21df33c3c3..0150fe7b3d79 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.94 2013/03/20 18:11:23 vincent Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.95 2013/03/20 18:13:35 jer Exp $
+
+ 20 Mar 2013; Jeroen Roovers <jer@gentoo.org> +files/httping-2.0-flags.patch,
+ -httping-1.6.ebuild, httping-2.0.ebuild:
+ Respect CFLAGS/LDFLAGS.
20 Mar 2013; Vicente Olivert Riera <vincent@gentoo.org> httping-1.5.8.ebuild:
amd64, ppc64, x86 stable, wrt bug #462512
diff --git a/net-analyzer/httping/files/httping-2.0-flags.patch b/net-analyzer/httping/files/httping-2.0-flags.patch
new file mode 100644
index 000000000000..43f553c69668
--- /dev/null
+++ b/net-analyzer/httping/files/httping-2.0-flags.patch
@@ -0,0 +1,23 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,9 +18,8 @@
+
+ DEBUG=yes
+ WFLAGS=-Wall -W
+-OFLAGS=-O3
+ CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
+-LDFLAGS=-lm
++LDFLAGS+=-lm
+
+ PACKAGE=$(TARGET)-$(VERSION)
+ PREFIX=/usr
+@@ -60,8 +59,7 @@
+ endif
+
+ ifeq ($(DEBUG),yes)
+-CFLAGS+=-D_DEBUG -ggdb
+-LDFLAGS+=-g
++CFLAGS+=-D_DEBUG
+ endif
+
+ ifeq ($(ARM),yes)
diff --git a/net-analyzer/httping/httping-1.6.ebuild b/net-analyzer/httping/httping-1.6.ebuild
deleted file mode 100644
index 61d7f6b10a5e..000000000000
--- a/net-analyzer/httping/httping-1.6.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.6.ebuild,v 1.1 2013/03/20 17:06:56 jer Exp $
-
-EAPI=5
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="http protocol ping-like program"
-HOMEPAGE="http://www.vanheusden.com/httping/"
-SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug ssl tfo"
-
-RDEPEND="
- >=sys-libs/ncurses-5
- ssl? ( dev-libs/openssl )
-"
-DEPEND="${RDEPEND}"
-
-# This would bring in test? ( dev-util/cppcheck ) but unlike
-# upstream we should only care about compile/run time testing
-RESTRICT="test"
-
-src_prepare() {
- sed -i "/^OFLAGS/d" Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- SSL=$(usex ssl) \
- TFO=$(usex tfo) \
- DEBUG=$(usex debug)
-}
-
-src_install() {
- dobin httping
- doman httping.1
- dodoc readme.txt
-}
diff --git a/net-analyzer/httping/httping-2.0.ebuild b/net-analyzer/httping/httping-2.0.ebuild
index 8fd55e028f99..daebabc2dbc6 100644
--- a/net-analyzer/httping/httping-2.0.ebuild
+++ b/net-analyzer/httping/httping-2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.0.ebuild,v 1.1 2013/03/20 17:06:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.0.ebuild,v 1.2 2013/03/20 18:13:35 jer Exp $
EAPI=5
-inherit flag-o-matic toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="http protocol ping-like program"
HOMEPAGE="http://www.vanheusden.com/httping/"
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}"
RESTRICT="test"
src_prepare() {
- sed -i "/^OFLAGS/d" Makefile || die
+ epatch "${FILESDIR}"/${PN}-2.0-flags.patch
}
src_compile() {