summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-27 11:51:13 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-27 11:51:13 +0000
commitdd031d50f243fe72d905b3ddbc6740179a6ea342 (patch)
tree6286142105a39787807ad7ebc6e4e61ec98aa18d /net-analyzer/greenbone-security-assistant
parentBump to eapi4 and prune old mess. Do not build with werror. Fixes bug#260893. (diff)
downloadgentoo-2-dd031d50f243fe72d905b3ddbc6740179a6ea342.tar.gz
gentoo-2-dd031d50f243fe72d905b3ddbc6740179a6ea342.tar.bz2
gentoo-2-dd031d50f243fe72d905b3ddbc6740179a6ea342.zip
Do not build with werror. Use cmake-utils eclass properly. Fix header line in the initscript. Bug found in Sabayon.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/greenbone-security-assistant')
-rw-r--r--net-analyzer/greenbone-security-assistant/ChangeLog9
-rwxr-xr-xnet-analyzer/greenbone-security-assistant/files/gsad4
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild27
3 files changed, 27 insertions, 13 deletions
diff --git a/net-analyzer/greenbone-security-assistant/ChangeLog b/net-analyzer/greenbone-security-assistant/ChangeLog
index 57b78abb9793..9e79d4cfdb2d 100644
--- a/net-analyzer/greenbone-security-assistant/ChangeLog
+++ b/net-analyzer/greenbone-security-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/greenbone-security-assistant
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.1 2011/10/09 17:29:41 hanno Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.2 2012/03/27 11:51:13 scarabeus Exp $
+
+ 27 Mar 2012; Tomáš Chvátal <scarabeus@gentoo.org> files/gsad,
+ greenbone-security-assistant-2.0.1.ebuild:
+ Do not build with werror. Use cmake-utils eclass properly. Fix header line in
+ the initscript. Bug found in Sabayon.
*greenbone-security-assistant-2.0.1 (09 Oct 2011)
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad b/net-analyzer/greenbone-security-assistant/files/gsad
index 58c0030b22d1..d5877748a738 100755
--- a/net-analyzer/greenbone-security-assistant/files/gsad
+++ b/net-analyzer/greenbone-security-assistant/files/gsad
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/files/gsad,v 1.2 2012/03/27 11:51:13 scarabeus Exp $
depend() {
need net
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
index 65d2fd748de6..71af83976f8d 100644
--- a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild,v 1.1 2011/10/09 17:29:41 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild,v 1.2 2012/03/27 11:51:13 scarabeus Exp $
EAPI=4
@@ -9,6 +9,7 @@ inherit cmake-utils
DESCRIPTION="Greenbone Security Assistant for openvas"
HOMEPAGE="http://www.openvas.org/"
SRC_URI="http://wald.intevation.org/frs/download.php/857/${P}.tar.gz"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
@@ -18,19 +19,27 @@ RDEPEND=">=net-analyzer/openvas-libraries-4
dev-libs/libxslt
net-libs/libmicrohttpd"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/cmake"
+ dev-util/pkgconfig"
+
+DOCS="ChangeLog CHANGES README"
-# Workaround for upstream bug, it doesn't like out-of-tree builds.
-CMAKE_BUILD_DIR="${S}"
+CMAKE_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror::g' \
+ CMakeLists.txt || die
+}
src_configure() {
- local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ local mycmakeargs=(
+ "-DLOCALSTATEDIR=${EPREFIX}/var"
+ "-DSYSCONFDIR=${EPREFIX}/etc"
+ )
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
- dodoc ChangeLog CHANGES README || die "dodoc failed"
- doinitd "${FILESDIR}"/gsad || die
+ doinitd "${FILESDIR}"/gsad
}