summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-20 16:31:58 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-20 16:31:58 +0000
commit1b707ec79f1982d17a37ed65f2079a8c7530cc1c (patch)
tree28b2ba8a5333d9f59e3676200be78f24644bc288 /net-analyzer/dhcp_probe
parentamd64 stable, bug 306033 (diff)
downloadgentoo-2-1b707ec79f1982d17a37ed65f2079a8c7530cc1c.tar.gz
gentoo-2-1b707ec79f1982d17a37ed65f2079a8c7530cc1c.tar.bz2
gentoo-2-1b707ec79f1982d17a37ed65f2079a8c7530cc1c.zip
Use emake install. This incidentally installs the .cf man page in the correct location (bug #303919 comment #5). It also installs the executable in /usr/sbin.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/dhcp_probe')
-rw-r--r--net-analyzer/dhcp_probe/ChangeLog13
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r2.ebuild (renamed from net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r1.ebuild)12
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.0.ebuild42
-rw-r--r--net-analyzer/dhcp_probe/files/dhcp_probe.initd4
4 files changed, 18 insertions, 53 deletions
diff --git a/net-analyzer/dhcp_probe/ChangeLog b/net-analyzer/dhcp_probe/ChangeLog
index c837b136117a..4ede93dbc3cd 100644
--- a/net-analyzer/dhcp_probe/ChangeLog
+++ b/net-analyzer/dhcp_probe/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/dhcp_probe
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/ChangeLog,v 1.4 2009/11/19 17:34:00 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/ChangeLog,v 1.5 2010/02/20 16:31:57 jer Exp $
+
+*dhcp_probe-1.3.0-r2 (20 Feb 2010)
+
+ 20 Feb 2010; Jeroen Roovers <jer@gentoo.org> -dhcp_probe-1.3.0.ebuild,
+ -dhcp_probe-1.3.0-r1.ebuild, +dhcp_probe-1.3.0-r2.ebuild,
+ files/dhcp_probe.initd:
+ Use emake install. This incidentally installs the .cf man page in the
+ correct location (bug #303919 comment #5). It also installs the executable
+ in /usr/sbin.
*dhcp_probe-1.3.0-r1 (19 Nov 2009)
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r1.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r2.ebuild
index 60a97769b999..c59b6cb2b376 100644
--- a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r1.ebuild
+++ b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r1.ebuild,v 1.1 2009/11/19 17:34:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r2.ebuild,v 1.1 2010/02/20 16:31:57 jer Exp $
EAPI="2"
@@ -30,9 +30,11 @@ src_configure() {
}
src_install() {
+ emake install DESTDIR="${D}"
+
newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}
- dobin src/dhcp_probe "${FILESDIR}"/dhcp_probe_mail || die "dobin failed"
+
dodoc \
extras/dhcp_probe.cf.sample \
NEWS \
@@ -41,8 +43,4 @@ src_install() {
AUTHORS \
TODO \
|| die "dodoc failed"
- doman \
- doc/dhcp_probe.8 \
- doc/dhcp_probe.cf.5 \
- || die "doman failed"
}
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0.ebuild
deleted file mode 100644
index d3fb4bf55783..000000000000
--- a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/dhcp_probe-1.3.0.ebuild,v 1.2 2009/10/28 04:18:57 robbat2 Exp $
-
-EAPI="2"
-
-DESCRIPTION="dhcp_probe attempts to discover DHCP and BootP servers on a directly-attached Ethernet network"
-HOMEPAGE="http://www.net.princeton.edu/software/dhcp_probe/"
-SRC_URI="http://www.net.princeton.edu/software/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-DEPEND="
- net-libs/libpcap
- >=net-libs/libnet-1.1.2.1-r2
- "
-RDEPEND="${DEPEND}"
-
-src_configure() {
- STRIP=true econf || die "econf failed"
-}
-
-src_install() {
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
- dobin src/dhcp_probe "${FILESDIR}"/dhcp_probe_mail || die "dobin failed"
- dodoc \
- extras/dhcp_probe.cf.sample \
- NEWS \
- README \
- ChangeLog \
- AUTHORS \
- TODO \
- || die "dodoc failed"
- doman \
- doc/dhcp_probe.8 \
- doc/dhcp_probe.cf.5 \
- || die "doman failed"
-}
diff --git a/net-analyzer/dhcp_probe/files/dhcp_probe.initd b/net-analyzer/dhcp_probe/files/dhcp_probe.initd
index 4f13e5ba9d96..e150a48ba48d 100644
--- a/net-analyzer/dhcp_probe/files/dhcp_probe.initd
+++ b/net-analyzer/dhcp_probe/files/dhcp_probe.initd
@@ -1,11 +1,11 @@
#!/sbin/runscript
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/files/dhcp_probe.initd,v 1.1 2009/05/26 00:00:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcp_probe/files/dhcp_probe.initd,v 1.2 2010/02/20 16:31:58 jer Exp $
opts="reload"
-DHCP_PROBE_BINARY="/usr/bin/dhcp_probe"
+DHCP_PROBE_BINARY="/usr/sbin/dhcp_probe"
DHCP_PROBE_CONFIG="/etc/dhcp_probe.cf"
DHCP_PROBE_PIDFILE="/var/run/${SVCNAME}.pid"
DHCP_PROBE_INTERFACE="${SVCNAME#*.}"