summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-31 10:53:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-31 10:53:44 +0000
commite102d72ee722d3ab5a3a862b8be3cef17afe4786 (patch)
tree3e9fa70d82f62050b0f163f26411b26c6cdb921f /media-video
parentAdd ldap herd to metadata (diff)
downloadgentoo-2-e102d72ee722d3ab5a3a862b8be3cef17afe4786.tar.gz
gentoo-2-e102d72ee722d3ab5a3a862b8be3cef17afe4786.tar.bz2
gentoo-2-e102d72ee722d3ab5a3a862b8be3cef17afe4786.zip
add xcb useflag
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog5
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 1c40edeb60e9..0d05f30ac5a1 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.798 2014/10/11 13:09:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.799 2014/10/31 10:53:44 aballier Exp $
+
+ 31 Oct 2014; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
+ add xcb useflag
11 Oct 2014; Markus Meier <maekke@gentoo.org> ffmpeg-1.2.6-r1.ebuild:
arm stable, bug #512012
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 5f57b8ef964f..0e4f776238ed 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.173 2014/08/29 19:50:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.174 2014/10/31 10:53:44 aballier Exp $
EAPI="5"
@@ -46,7 +46,7 @@ IUSE="
jpeg2k ladspa libass libcaca libsoxr libv4l lzma modplug mp3 +network
openal opengl openssl opus oss pic pulseaudio quvi rtmp samba schroedinger
sdl speex ssh static-libs test theora threads truetype twolame v4l vaapi
- vdpau vorbis vpx wavpack webp X x264 x265 xvid +zlib zvbi
+ vdpau vorbis vpx wavpack webp X x264 x265 xcb xvid +zlib zvbi
"
ARM_CPU_FEATURES="armv5te armv6 armv6t2 neon armvfp:vfp"
@@ -150,6 +150,7 @@ RDEPEND="
>=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
>=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}]
)
+ xcb? ( x11-libs/libxcb[${MULTILIB_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
zvbi? ( >=media-libs/zvbi-0.2.35[${MULTILIB_USEDEP}] )
!media-video/qt-faststart
@@ -204,7 +205,7 @@ multilib_src_configure() {
local ffuse=(
bzip2:bzlib cpudetection:runtime-cpudetect debug doc
gnutls hardcoded-tables iconv lzma network openssl samba:libsmbclient
- sdl:ffplay vaapi vdpau X:xlib zlib
+ sdl:ffplay vaapi vdpau X:xlib xcb:libxcb xcb:libxcb-shm xcb:libxcb-xfixes zlib
)
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )