summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-29 09:54:11 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-29 09:54:11 +0000
commitbd5d3fa04b2af7e9338ec1c624615f6b60da6a55 (patch)
treea0b62cfaac3548f08dd4f5dbad08d8e91a0cfb0e /media-video
parentversion bump (diff)
downloadgentoo-2-bd5d3fa04b2af7e9338ec1c624615f6b60da6a55.tar.gz
gentoo-2-bd5d3fa04b2af7e9338ec1c624615f6b60da6a55.tar.bz2
gentoo-2-bd5d3fa04b2af7e9338ec1c624615f6b60da6a55.zip
patch to address missed header file in opencv, patch from upstream instigated by maintainer submitted via bug #554562
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog7
-rw-r--r--media-video/vlc/files/opencv-3.0.0.patch12
-rw-r--r--media-video/vlc/vlc-2.1.5-r1.ebuild5
-rw-r--r--media-video/vlc/vlc-2.2.1.ebuild5
4 files changed, 26 insertions, 3 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 343d132a1c41..90c19fd37eda 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.962 2015/07/24 15:53:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.963 2015/07/29 09:54:11 idella4 Exp $
+
+ 29 Jul 2015; Ian Delaney <idella4@gentoo.org> +files/opencv-3.0.0.patch,
+ vlc-2.1.5-r1.ebuild, vlc-2.2.1.ebuild:
+ patch to address missed header file in opencv, patch from upstream instigated
+ by maintainer submitted via bug #554562
24 Jul 2015; Anthony G. Basile <blueness@gentoo.org> vlc-2.2.1.ebuild:
Keyword ~ppc. Bug #548966.
diff --git a/media-video/vlc/files/opencv-3.0.0.patch b/media-video/vlc/files/opencv-3.0.0.patch
new file mode 100644
index 000000000000..b09b65154373
--- /dev/null
+++ b/media-video/vlc/files/opencv-3.0.0.patch
@@ -0,0 +1,12 @@
+http://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=b82416d7000a993b33e903095a590fe32212a85e
+diff --git a/modules/video_filter/opencv_example.cpp b/modules/video_filter/opencv_example.cpp
+index ae3af05..998f286 100644 (file)
+--- a/modules/video_filter/opencv_example.cpp
++++ b/modules/video_filter/opencv_example.cpp
+@@ -41,6 +41,8 @@
+
+ #include <opencv2/core/core_c.h>
+ #include <opencv2/core/core.hpp>
++#include <opencv2/imgproc/imgproc_c.h>
++#include <opencv2/imgproc/imgproc.hpp>
+ #include <opencv2/objdetect/objdetect.hpp>
diff --git a/media-video/vlc/vlc-2.1.5-r1.ebuild b/media-video/vlc/vlc-2.1.5-r1.ebuild
index 38d4607a5c6c..089d21890834 100644
--- a/media-video/vlc/vlc-2.1.5-r1.ebuild
+++ b/media-video/vlc/vlc-2.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.5-r1.ebuild,v 1.9 2015/03/01 09:31:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.5-r1.ebuild,v 1.10 2015/07/29 09:54:11 idella4 Exp $
EAPI="5"
@@ -249,6 +249,9 @@ src_prepare() {
# Fix bug #541654
epatch "${FILESDIR}"/${PN}-2.1-mem_undefined_functions.patch
+ # Add missed header imgproc_c.h, imgproc.hpp, bug #554562
+ epatch "${FILESDIR}"/opencv-3.0.0.patch
+
# Disable avcodec checks when avcodec is not used.
if ! use avcodec; then
sed -i 's/^#if LIBAVCODEC_VERSION_CHECK(.*)$/#if 0/' modules/codec/avcodec/fourcc.c || die
diff --git a/media-video/vlc/vlc-2.2.1.ebuild b/media-video/vlc/vlc-2.2.1.ebuild
index 0526d2dec888..4242841b06c7 100644
--- a/media-video/vlc/vlc-2.2.1.ebuild
+++ b/media-video/vlc/vlc-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.2.1.ebuild,v 1.12 2015/07/24 15:53:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.2.1.ebuild,v 1.13 2015/07/29 09:54:11 idella4 Exp $
EAPI="5"
@@ -268,6 +268,9 @@ src_prepare() {
# Bug #541678
epatch "${FILESDIR}"/qt4-select.patch
+ # Add missed header imgproc_c.h, imgproc.hpp, bug #554562
+ epatch "${FILESDIR}"/opencv-3.0.0.patch
+
# Don't use --started-from-file when not using dbus.
if ! use dbus ; then
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die