summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-17 00:39:59 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-17 00:39:59 +0000
commit6fa2e7ab47d3be18f56ccb250f231af8f85bbc43 (patch)
tree49ba68a7fc371ea62eefc8784be2f4b420eb973d /media-video
parentFix build with external ffmpeg #526992 by Manuel Rüger. (diff)
downloadgentoo-2-6fa2e7ab47d3be18f56ccb250f231af8f85bbc43.tar.gz
gentoo-2-6fa2e7ab47d3be18f56ccb250f231af8f85bbc43.tar.bz2
gentoo-2-6fa2e7ab47d3be18f56ccb250f231af8f85bbc43.zip
Fix by Alexandre Rostovtsev for building with newer boost #527658 by Diego Elio Pettenò.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cclive/ChangeLog9
-rw-r--r--media-video/cclive/cclive-0.9.3-r1.ebuild10
-rw-r--r--media-video/cclive/files/cclive-0.9.3-iostream.patch80
3 files changed, 95 insertions, 4 deletions
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index adc9be4a9f13..58feebcb47f4 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.71 2014/07/27 17:02:24 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.72 2015/02/17 00:39:59 vapier Exp $
+
+ 17 Feb 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/cclive-0.9.3-iostream.patch, cclive-0.9.3-r1.ebuild:
+ Fix by Alexandre Rostovtsev for building with newer boost #527658 by Diego
+ Elio Pettenò.
27 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> -cclive-0.7.12.ebuild,
-cclive-0.7.13.ebuild, -cclive-0.7.15.ebuild, -cclive-0.7.16.ebuild,
diff --git a/media-video/cclive/cclive-0.9.3-r1.ebuild b/media-video/cclive/cclive-0.9.3-r1.ebuild
index 9324e6bc3dfd..6991b6f6f1e7 100644
--- a/media-video/cclive/cclive-0.9.3-r1.ebuild
+++ b/media-video/cclive/cclive-0.9.3-r1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.9.3-r1.ebuild,v 1.5 2014/02/23 16:09:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.9.3-r1.ebuild,v 1.6 2015/02/17 00:39:59 vapier Exp $
EAPI=5
+inherit eutils
+
DESCRIPTION="Command line tool for extracting videos from various websites"
HOMEPAGE="http://cclive.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PV:0:3}/${P}.tar.xz"
@@ -22,6 +24,10 @@ DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-iostream.patch #527658
+}
+
src_configure() {
econf --disable-ccl
}
diff --git a/media-video/cclive/files/cclive-0.9.3-iostream.patch b/media-video/cclive/files/cclive-0.9.3-iostream.patch
new file mode 100644
index 000000000000..f7bfd074919f
--- /dev/null
+++ b/media-video/cclive/files/cclive-0.9.3-iostream.patch
@@ -0,0 +1,80 @@
+https://github.com/legatvs/cclive/pull/2
+
+From dcaed542d002cbf857e0bca1fa12f8ab501c419a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Fri, 26 Dec 2014 13:49:36 -0500
+Subject: [PATCH] Add explicit <iostream> includes, fixes build with Boost 1.56
+
+See https://bugs.gentoo.org/show_bug.cgi?id=527658 and
+https://bugs.gentoo.org/show_bug.cgi?id=533506
+---
+ src/cc/error.h | 1 +
+ src/cc/input.h | 1 +
+ src/cc/log.h | 1 +
+ src/cc/options.h | 1 +
+ src/cc/sig.h | 1 +
+ 5 files changed, 5 insertions(+)
+
+diff --git a/src/cc/error.h b/src/cc/error.h
+index c1d80ab..f6a3e6d 100644
+--- a/src/cc/error.h
++++ b/src/cc/error.h
+@@ -28,6 +28,7 @@
+ #include <boost/exception/get_error_info.hpp>
+ #include <boost/exception/errinfo_errno.hpp>
+ #include <boost/tuple/tuple.hpp>
++#include <iostream>
+ #include <cerrno>
+
+ namespace cc
+diff --git a/src/cc/input.h b/src/cc/input.h
+index 98c334b..523e9fe 100644
+--- a/src/cc/input.h
++++ b/src/cc/input.h
+@@ -23,6 +23,7 @@
+
+ #include <ccinternal>
+
++#include <iostream>
+ #include <istream>
+ #include <sstream>
+
+diff --git a/src/cc/log.h b/src/cc/log.h
+index 2b2c986..aaf3b32 100644
+--- a/src/cc/log.h
++++ b/src/cc/log.h
+@@ -25,6 +25,7 @@
+
+ #include <boost/iostreams/filtering_stream.hpp>
+ #include <boost/filesystem.hpp>
++#include <iostream>
+ #include <fstream>
+
+ #include <ccerror>
+diff --git a/src/cc/options.h b/src/cc/options.h
+index 6c45ce8..6a7e40c 100644
+--- a/src/cc/options.h
++++ b/src/cc/options.h
+@@ -37,6 +37,7 @@
+ #include <boost/filesystem.hpp>
+ #include <boost/foreach.hpp>
+ #include <boost/format.hpp>
++#include <iostream>
+ #include <fstream>
+
+ #include <ccerror>
+diff --git a/src/cc/sig.h b/src/cc/sig.h
+index 56de768..cca23ad 100644
+--- a/src/cc/sig.h
++++ b/src/cc/sig.h
+@@ -26,6 +26,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <iostream>
+ #include <csignal>
+ #include <cstdio>
+
+--
+2.2.1
+