summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-02-10 23:39:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-02-10 23:39:23 +0000
commit6642e1566f45862e3a7efd1b4ca8f5ead5bfc381 (patch)
treef4ac05f5d6a4019698ecace3979b93a5e95f841a /media-video
parentMake javadocs install to standard location. (diff)
downloadgentoo-2-6642e1566f45862e3a7efd1b4ca8f5ead5bfc381.tar.gz
gentoo-2-6642e1566f45862e3a7efd1b4ca8f5ead5bfc381.tar.bz2
gentoo-2-6642e1566f45862e3a7efd1b4ca8f5ead5bfc381.zip
Die if skins are wanted but not wxwindows, dont install vlc.desktop if not using wxwindows, bug #158095, remove inexistant docs from dodoc
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog7
-rw-r--r--media-video/vlc/vlc-0.8.6-r1.ebuild10
-rw-r--r--media-video/vlc/vlc-0.8.6_p18636.ebuild10
3 files changed, 20 insertions, 7 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index a3419d4e74ff..bc70afbbf1e8 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vlc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.219 2007/02/10 19:05:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.220 2007/02/10 23:39:23 aballier Exp $
+
+ 10 Feb 2007; Alexis Ballier <aballier@gentoo.org> vlc-0.8.6-r1.ebuild,
+ vlc-0.8.6_p18636.ebuild:
+ Die if skins are wanted but not wxwindows, dont install vlc.desktop if not
+ using wxwindows, bug #158095, remove inexistant docs from dodoc
10 Feb 2007; Alexis Ballier <aballier@gentoo.org> vlc-0.8.6-r1.ebuild,
vlc-0.8.6_p18636.ebuild:
diff --git a/media-video/vlc/vlc-0.8.6-r1.ebuild b/media-video/vlc/vlc-0.8.6-r1.ebuild
index 301ea566ccee..4b445472738a 100644
--- a/media-video/vlc/vlc-0.8.6-r1.ebuild
+++ b/media-video/vlc/vlc-0.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.6-r1.ebuild,v 1.12 2007/02/10 19:05:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.6-r1.ebuild,v 1.13 2007/02/10 23:39:23 aballier Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -125,6 +125,10 @@ pkg_setup() {
eerror "Trying to build with skins support but without truetype."
die "You have to use 'truetype' to use 'skins'"
fi
+ if use skins && ! use wxwindows; then
+ eerror "Trying to build with skins support but without wxwindows."
+ die "You have to use 'wxwindows' to use 'skins'"
+ fi
}
src_unpack() {
@@ -261,7 +265,7 @@ src_install() {
# First install the library, to avoid screwups during relinking.select
emake -j1 DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS MAINTAINERS HACKING THANKS TODO NEWS README \
+ dodoc AUTHORS MAINTAINERS HACKING THANKS NEWS README \
doc/fortunes.txt doc/intf-cdda.txt doc/intf-vcd.txt
if use nsplugin; then
@@ -280,5 +284,5 @@ src_install() {
newins "${S}"/share/vlc${res}x${res}.png vlc.png
done
- use wxwindows && domenu "${S}/debian/vlc.desktop"
+ use wxwindows || rm "${D}/usr/share/applications/vlc.desktop"
}
diff --git a/media-video/vlc/vlc-0.8.6_p18636.ebuild b/media-video/vlc/vlc-0.8.6_p18636.ebuild
index 75531dba7e69..88cb0eaffc74 100644
--- a/media-video/vlc/vlc-0.8.6_p18636.ebuild
+++ b/media-video/vlc/vlc-0.8.6_p18636.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.6_p18636.ebuild,v 1.6 2007/02/10 19:05:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.6_p18636.ebuild,v 1.7 2007/02/10 23:39:23 aballier Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -131,6 +131,10 @@ pkg_setup() {
eerror "Trying to build with skins support but without truetype."
die "You have to use 'truetype' to use 'skins'"
fi
+ if use skins && ! use wxwindows; then
+ eerror "Trying to build with skins support but without wxwindows."
+ die "You have to use 'wxwindows' to use 'skins'"
+ fi
}
src_unpack() {
@@ -268,7 +272,7 @@ src_install() {
# First install the library, to avoid screwups during relinking.select
emake -j1 DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS MAINTAINERS HACKING THANKS TODO NEWS README \
+ dodoc AUTHORS MAINTAINERS HACKING THANKS NEWS README \
doc/fortunes.txt doc/intf-cdda.txt doc/intf-vcd.txt
if use nsplugin; then
@@ -287,5 +291,5 @@ src_install() {
newins "${S}"/share/vlc${res}x${res}.png vlc.png
done
- use wxwindows && domenu "${S}/debian/vlc.desktop"
+ use wxwindows || rm "${D}/usr/share/applications/vlc.desktop"
}