summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-19 11:28:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-19 11:28:21 +0000
commitcfb58c1e688facc8407391b2325d6ba060ef6100 (patch)
treed8ddacde3c8889d8f1f7d5622bd41895ea63ca7a /media-video/xmps
parentadded NVIDIA license (diff)
downloadgentoo-2-cfb58c1e688facc8407391b2325d6ba060ef6100.tar.gz
gentoo-2-cfb58c1e688facc8407391b2325d6ba060ef6100.tar.bz2
gentoo-2-cfb58c1e688facc8407391b2325d6ba060ef6100.zip
repoman'd
Diffstat (limited to 'media-video/xmps')
-rw-r--r--media-video/xmps/xmps-0.2.0-r1.ebuild44
1 files changed, 21 insertions, 23 deletions
diff --git a/media-video/xmps/xmps-0.2.0-r1.ebuild b/media-video/xmps/xmps-0.2.0-r1.ebuild
index cae0c902bfea..12616bdc6d58 100644
--- a/media-video/xmps/xmps-0.2.0-r1.ebuild
+++ b/media-video/xmps/xmps-0.2.0-r1.ebuild
@@ -1,48 +1,46 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/xmps/xmps-0.2.0-r1.ebuild,v 1.4 2002/07/11 06:30:42 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xmps/xmps-0.2.0-r1.ebuild,v 1.5 2002/07/19 11:28:21 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="X Movie Player System"
-SRC_URI="http://xmps.sourceforge.net/sources/${A}"
+SRC_URI="http://xmps.sourceforge.net/sources/${P}.tar.gz"
HOMEPAGE="http://xmps.sourceforge.net"
-DEPEND=">=media-libs/smpeg-0.4.4-r1 nls? ( sys-devel/gettext )
+DEPEND="=x11-libs/gtk+-1.2*
>=dev-lang/nasm-0.98
- >=dev-libs/popt-1.5
- =x11-libs/gtk+-1.2*
+ >=dev-libs/popt-1.5
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
RDEPEND=">=media-libs/smpeg-0.4.4-r1
- =x11-libs/gtk+-1.2*
- >=dev-libs/popt-1.5
- gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
src_compile() {
- local myopts
- if [ -n "`use gnome`" ] ; then
- myopts="--enable-gnome"
- fi
- if [ -z "`use nls`" ] ; then
- myopts="$myopts --disable-nls"
- fi
- try ./configure ${myopts} --host=${CHOST} --prefix=/usr
+ local myconf
+
+ use gnome && myconf="--enable-gnome"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+
cp Makefile Makefile.orig
sed -e "s:\$(bindir)/xmps-config:\$(DESTDIR)\$(bindir)/xmps-config:" \
- Makefile.orig > Makefile
- try make
+ Makefile.orig > Makefile
+
+ make || die
}
src_install () {
- try make prefix=${D}/usr install
+ make prefix=${D}/usr install || die
dodoc AUTHORS ChangeLog COPYING NEWS README TODO
}
-
-
-