summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-10 17:04:44 +0000
committerChris White <chriswhite@gentoo.org>2004-08-10 17:04:44 +0000
commitd011811ca6befa9d9b2536d6ccd80e3f7523354b (patch)
tree722557e3969d39975a36cf4a964eac2ecd99259a /media-video/vlc/vlc-0.7.2-r1.ebuild
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-d011811ca6befa9d9b2536d6ccd80e3f7523354b.tar.gz
gentoo-2-d011811ca6befa9d9b2536d6ccd80e3f7523354b.tar.bz2
gentoo-2-d011811ca6befa9d9b2536d6ccd80e3f7523354b.zip
Fixed some live downgrading, patching, stopped the CFLAGS unsetting, saved the whales, promoted world peace, etc.
Diffstat (limited to 'media-video/vlc/vlc-0.7.2-r1.ebuild')
-rw-r--r--media-video/vlc/vlc-0.7.2-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-video/vlc/vlc-0.7.2-r1.ebuild b/media-video/vlc/vlc-0.7.2-r1.ebuild
index ce99e04efede..d278510cf072 100644
--- a/media-video/vlc/vlc-0.7.2-r1.ebuild
+++ b/media-video/vlc/vlc-0.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.7.2-r1.ebuild,v 1.1 2004/07/28 20:03:44 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.7.2-r1.ebuild,v 1.2 2004/08/10 17:04:44 chriswhite Exp $
inherit libtool gcc eutils
@@ -64,7 +64,7 @@ RDEPEND="X? ( virtual/x11 )
>=media-libs/a52dec-0.7.4
>=media-libs/libmpeg2-0.4.0
>=media-video/ffmpeg-0.4.8.20040222
- =media-plugins/live-2004.03*
+ >=media-plugins/live-2004.03.27
>=media-libs/flac-1.1.0"
DEPEND="$RDEPEND >=sys-devel/autoconf-2.5.8
@@ -87,6 +87,9 @@ src_unpack() {
epatch ${FILESDIR}/glide.patch
cd ${S}
+ # conforms vlc to recent api changes
+ epatch ${FILESDIR}/${P}-live.patch
+
}
src_compile() {
@@ -98,7 +101,7 @@ src_compile() {
--disable-qt --disable-kde --disable-gnome --disable-gtk \
--disable-libcdio --disable-libcddb --disable-vcdx \
--enable-ffmpeg --with-ffmpeg-mp3lame \
- --enable-livedotcom --with-livedotcom-tree=/usr/lib/live"
+ --enable-livedotcom --with-livedotcom-tree=/usr/lib/live --disable-skins --disable-skins2"
# qt, kde, gnome and gtk interfaces are deprecated and in a bad condition
# the same for mga video, libdv and xvid decoders
@@ -132,8 +135,6 @@ src_compile() {
# vlc uses its own ultraoptimizaed CXXFLAGS
# and forcing custom ones generally fails building
- export CXXFLAGS=""
- export CFLAGS=""
export WANT_AUTOCONF_2_5=1
export WANT_AUTOMAKE_1_6=1