summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2006-10-23 05:59:23 +0000
committerSteve Dibb <beandog@gentoo.org>2006-10-23 05:59:23 +0000
commit0a0794865dfd9e3ce96e0cd80fafec247c7b745c (patch)
tree4f627cbd8aa23732760224ec36e2dac7f5c4e7ab /media-video/tovid
parentUpdate USE flag deps error messages wrt bug 151024, remove nptl patch (diff)
downloadgentoo-2-0a0794865dfd9e3ce96e0cd80fafec247c7b745c.tar.gz
gentoo-2-0a0794865dfd9e3ce96e0cd80fafec247c7b745c.tar.bz2
gentoo-2-0a0794865dfd9e3ce96e0cd80fafec247c7b745c.zip
Fix png8 bug, wrt 151591
(Portage version: 2.1.1-r1)
Diffstat (limited to 'media-video/tovid')
-rw-r--r--media-video/tovid/ChangeLog8
-rw-r--r--media-video/tovid/files/digest-tovid-0.28-r13
-rw-r--r--media-video/tovid/files/makemenu_png8.patch38
-rw-r--r--media-video/tovid/tovid-0.28-r1.ebuild69
4 files changed, 117 insertions, 1 deletions
diff --git a/media-video/tovid/ChangeLog b/media-video/tovid/ChangeLog
index f99eb1faa164..ee9b9a8d5e6a 100644
--- a/media-video/tovid/ChangeLog
+++ b/media-video/tovid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/tovid
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.2 2006/09/11 20:05:43 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.3 2006/10/23 05:59:23 beandog Exp $
+
+*tovid-0.28-r1 (23 Oct 2006)
+
+ 23 Oct 2006; Steve Dibb <beandog@gentoo.org> +files/makemenu_png8.patch,
+ +tovid-0.28-r1.ebuild:
+ Fix png8 bug, wrt 151591
11 Sep 2006; Steve Dibb <beandog@gentoo.org> Manifest:
Fix manifest, bug # 147079
diff --git a/media-video/tovid/files/digest-tovid-0.28-r1 b/media-video/tovid/files/digest-tovid-0.28-r1
new file mode 100644
index 000000000000..28eacb6d0ea2
--- /dev/null
+++ b/media-video/tovid/files/digest-tovid-0.28-r1
@@ -0,0 +1,3 @@
+MD5 c5544382262af04e09974eced0d4495f tovid-0.28.tar.gz 295903
+RMD160 eb721c2785ea8282aebb8e50015cd450944d39b2 tovid-0.28.tar.gz 295903
+SHA256 fbd73eb3d1f0123ac88666a24a4ba14bd396c7edf5b3f802896c414ac32819f5 tovid-0.28.tar.gz 295903
diff --git a/media-video/tovid/files/makemenu_png8.patch b/media-video/tovid/files/makemenu_png8.patch
new file mode 100644
index 000000000000..838ddd95da12
--- /dev/null
+++ b/media-video/tovid/files/makemenu_png8.patch
@@ -0,0 +1,38 @@
+--- src/makemenu 2006-07-06 05:32:48.000000000 +0200
++++ src/makemenu.new 2006-10-16 15:57:14.000000000 +0200
+@@ -473,7 +473,7 @@
+ -font \"$USE_TITLE_FONT\" -weight bold -pointsize $TITLE_SIZE \
+ -fill \"$HIGHLIGHT_COLOR\" -draw \"gravity $TEXT_ALIGN $BUTTON_TEXT\" \
+ -type Palette -colors 3 \
+- png8:$FG_HIGHLIGHT"
++ $FG_HIGHLIGHT"
+ echo $SEPARATOR
+ echo "Creating the highlighted titles with the following command:"
+ echo $"$MAGICK_CMD"
+@@ -484,7 +484,7 @@
+ -font \"$USE_TITLE_FONT\" -weight bold -pointsize $TITLE_SIZE \
+ -fill \"$SELECT_COLOR\" -draw \"gravity $TEXT_ALIGN $BUTTON_TEXT\" \
+ -type Palette -colors 3 \
+- png8:$FG_SELECTION"
++ $FG_SELECTION"
+ echo $SEPARATOR
+ echo "Creating the selection titles with the following command:"
+ echo $"$MAGICK_CMD"
+@@ -500,7 +500,7 @@
+
+ # Composite highlight canvas with transparent background
+ MAGICK_CMD="composite -compose Src -gravity center \
+- $FG_HIGHLIGHT $BG_CANVAS png8:\"$OUT_PREFIX.hi.png\""
++ $FG_HIGHLIGHT $BG_CANVAS \"$OUT_PREFIX.hi.png\""
+ echo $SEPARATOR
+ echo "Compositing highlighted titles with the following command:"
+ echo $"$MAGICK_CMD"
+@@ -508,7 +508,7 @@
+
+ # Composite highlight canvas with transparent background
+ MAGICK_CMD="composite -compose Src -gravity center \
+- $FG_SELECTION $BG_CANVAS png8:\"$OUT_PREFIX.sel.png\""
++ $FG_SELECTION $BG_CANVAS \"$OUT_PREFIX.sel.png\""
+ echo $SEPARATOR
+ echo "Compositing selection titles with the following command:"
+ echo $"$MAGICK_CMD"
diff --git a/media-video/tovid/tovid-0.28-r1.ebuild b/media-video/tovid/tovid-0.28-r1.ebuild
new file mode 100644
index 000000000000..98d2ded54e85
--- /dev/null
+++ b/media-video/tovid/tovid-0.28-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/tovid-0.28-r1.ebuild,v 1.1 2006/10/23 05:59:23 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="Video conversion and DVD authoring tools"
+HOMEPAGE="http://tovid.wikia.com/"
+SRC_URI="mirror://sourceforge/tovid/${P}.tar.gz"
+
+IUSE=""
+DEPEND=""
+RDEPEND="media-video/mplayer
+ media-video/mjpegtools
+ media-video/ffmpeg
+ media-video/transcode
+ media-sound/normalize
+ media-gfx/imagemagick
+ media-sound/sox
+ media-video/dvdauthor
+ media-video/vcdimager
+ media-video/lsdvd
+ virtual/cdrtools
+ >=dev-python/wxpython-2.6
+ app-cdr/dvd+rw-tools
+ app-cdr/cdrdao"
+
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+RESTRICT="nomirror"
+SLOT="0"
+
+pkg_setup() {
+ if ! built_with_use media-video/mplayer encode; then
+ eerror "Please emerge media-video/mplayer with useflag 'encode'."
+ die "Fix USE flags and re-emerge"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Patch to fix makexml from the gui app
+ epatch "${FILESDIR}/makemenu_png8.patch" || die "epatch died"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake died"
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "List of suite components:"
+ einfo " idvid: Identifies video format, resolution, and length"
+ einfo " makemenu: Creates (S)VCD/DVD menus"
+ einfo " makeslides: Creates mpeg still slides for (S)VCD"
+ einfo " makexml: Creates XML specification for an (S)VCD or DVD navigation hierarchy"
+ einfo " makedvd: Creates the DVD structure and/or iso image"
+ einfo " postproc: Adjusts A/V sync and does shrinking of encoded video"
+ einfo " tovid: Converts video to (S)VCD or DVD mpeg format"
+ einfo " tovidgui: The tovid GUI"
+ einfo " pytovid: The new (experimental) python based tovid script"
+ einfo " todisc: Create a DVD with animated menus"
+ einfo " todiscgui: Experimental gui for todisc"
+ einfo ""
+ einfo "Please check out the tovid documentation on the web:"
+ einfo " http://tovid.wikia.com/"
+ einfo ""
+}