summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-12 07:08:13 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-12 07:08:13 +0000
commitb59e2b80c0f3e1149893eae0a84ee10dba8077be (patch)
tree490c4cb194e1b8aeef16e3dd2538383485fedcbb /media-video/subotage
parentVersion bump. (diff)
downloadgentoo-2-b59e2b80c0f3e1149893eae0a84ee10dba8077be.tar.gz
gentoo-2-b59e2b80c0f3e1149893eae0a84ee10dba8077be.tar.bz2
gentoo-2-b59e2b80c0f3e1149893eae0a84ee10dba8077be.zip
Introduce an ebuild for subotage, subtitle converted in 'pure' bash.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-video/subotage')
-rw-r--r--media-video/subotage/ChangeLog9
-rw-r--r--media-video/subotage/metadata.xml8
-rw-r--r--media-video/subotage/subotage-0.15.ebuild22
3 files changed, 39 insertions, 0 deletions
diff --git a/media-video/subotage/ChangeLog b/media-video/subotage/ChangeLog
new file mode 100644
index 000000000000..f250040cbcb4
--- /dev/null
+++ b/media-video/subotage/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-video/subotage
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subotage/ChangeLog,v 1.1 2013/05/12 07:08:13 mgorny Exp $
+
+*subotage-0.15 (12 May 2013)
+
+ 12 May 2013; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +subotage-0.15.ebuild:
+ Introduce an ebuild for subotage, subtitle converted in 'pure' bash.
diff --git a/media-video/subotage/metadata.xml b/media-video/subotage/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/media-video/subotage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/subotage/subotage-0.15.ebuild b/media-video/subotage/subotage-0.15.ebuild
new file mode 100644
index 000000000000..aad3b316aa4c
--- /dev/null
+++ b/media-video/subotage/subotage-0.15.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subotage/subotage-0.15.ebuild,v 1.1 2013/05/12 07:08:13 mgorny Exp $
+
+EAPI=5
+
+DESCRIPTION="Universal subtitle converter in bash"
+HOMEPAGE="http://sourceforge.net/projects/subotage/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_install() {
+ default # for docs
+
+ dobin subotage.sh
+}