summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-08-13 18:15:40 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-08-13 18:15:40 +0000
commit006685c9914d0961ba9723584c40bc7b2edf1006 (patch)
treedbc451a72dddc68e4acdb9641cb84ccd8922eb75 /media-video/smplayer
parentFix bug #279252; --with-python-dir prepends the prefix to the path already, ... (diff)
downloadgentoo-2-006685c9914d0961ba9723584c40bc7b2edf1006.tar.gz
gentoo-2-006685c9914d0961ba9723584c40bc7b2edf1006.tar.bz2
gentoo-2-006685c9914d0961ba9723584c40bc7b2edf1006.zip
Add patch to force Ctrl+Q as default quit shortcut, by George Kargiotakis
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/smplayer')
-rw-r--r--media-video/smplayer/ChangeLog6
-rw-r--r--media-video/smplayer/files/smplayer-0.6.8-quit.patch11
-rw-r--r--media-video/smplayer/smplayer-0.6.8.ebuild8
3 files changed, 22 insertions, 3 deletions
diff --git a/media-video/smplayer/ChangeLog b/media-video/smplayer/ChangeLog
index 4d2dd512de0d..793a9684326b 100644
--- a/media-video/smplayer/ChangeLog
+++ b/media-video/smplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/smplayer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/ChangeLog,v 1.72 2009/07/26 13:14:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/ChangeLog,v 1.73 2009/08/13 18:15:40 tampakrap Exp $
+
+ 13 Aug 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ smplayer-0.6.8.ebuild, +files/smplayer-0.6.8-quit.patch:
+ Add patch to force Ctrl+Q as default quit shortcut, by George Kargiotakis
*smplayer-0.6.8 (26 Jul 2009)
diff --git a/media-video/smplayer/files/smplayer-0.6.8-quit.patch b/media-video/smplayer/files/smplayer-0.6.8-quit.patch
new file mode 100644
index 000000000000..ae470eeede5a
--- /dev/null
+++ b/media-video/smplayer/files/smplayer-0.6.8-quit.patch
@@ -0,0 +1,11 @@
+--- smplayer-0.6.8/src/baseguiplus.cpp 2009-08-13 16:07:04.000000000 +0300
++++ smplayer-0.6.8/src/baseguiplus.cpp 2009-08-13 16:08:22.000000000 +0300
+@@ -67,8 +67,7 @@
+ tray->setToolTip( "SMPlayer" );
+ connect( tray, SIGNAL(activated(QSystemTrayIcon::ActivationReason)),
+ this, SLOT(trayIconActivated(QSystemTrayIcon::ActivationReason)));
+-
+- quitAct = new MyAction(this, "quit");
++ quitAct = new MyAction(QKeySequence("Ctrl+Q"), this, "quit");
+ connect( quitAct, SIGNAL(triggered()), this, SLOT(quit()) );
+ openMenu->addAction(quitAct);
diff --git a/media-video/smplayer/smplayer-0.6.8.ebuild b/media-video/smplayer/smplayer-0.6.8.ebuild
index c2255a4e5f19..4384c36a4c26 100644
--- a/media-video/smplayer/smplayer-0.6.8.ebuild
+++ b/media-video/smplayer/smplayer-0.6.8.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.6.8.ebuild,v 1.1 2009/07/26 13:14:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.6.8.ebuild,v 1.2 2009/08/13 18:15:40 tampakrap Exp $
+
+EAPI="2"
-EAPI=2
inherit eutils qt4
MY_PV=${PV##*_p}
@@ -40,6 +41,9 @@ for X in ${NOLONGLANGS}; do
done
src_prepare() {
+ # Force Ctrl+Q as default quit shortcut
+ epatch "${FILESDIR}/${P}-quit.patch"
+
# Upstream Makefile sucks
sed -i -e "/^PREFIX=/s:/usr/local:/usr:" \
-e "/^DOC_PATH=/s:packages/smplayer:${PF}:" \