summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-15 12:45:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-15 12:45:29 +0000
commitb7228bbb844021e6fc0378da76217b3871982a8c (patch)
tree27ce08616a30af9514a7eaacef92dd1ecb1f4855 /media-video/parole
parentAdd new media-video/parole with requirement for GTK+-3 libxfce4ui to Xfce 4.1... (diff)
downloadgentoo-2-b7228bbb844021e6fc0378da76217b3871982a8c.tar.gz
gentoo-2-b7228bbb844021e6fc0378da76217b3871982a8c.tar.bz2
gentoo-2-b7228bbb844021e6fc0378da76217b3871982a8c.zip
Version bump to version making of use the new GTK+-3 libxfce4ui from Xfce 4.12 (git)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-video/parole')
-rw-r--r--media-video/parole/ChangeLog8
-rw-r--r--media-video/parole/parole-0.6.0.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/media-video/parole/ChangeLog b/media-video/parole/ChangeLog
index 4d96be440436..3947085aa0d1 100644
--- a/media-video/parole/ChangeLog
+++ b/media-video/parole/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/parole
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.44 2014/03/11 12:54:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.45 2014/03/15 12:45:29 ssuominen Exp $
+
+*parole-0.6.0 (15 Mar 2014)
+
+ 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +parole-0.6.0.ebuild:
+ Version bump to version making of use the new GTK+-3 libxfce4ui from Xfce 4.12
+ (git)
11 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> -parole-0.5.0.ebuild,
-parole-0.5.1.ebuild:
diff --git a/media-video/parole/parole-0.6.0.ebuild b/media-video/parole/parole-0.6.0.ebuild
new file mode 100644
index 000000000000..e72724bca82e
--- /dev/null
+++ b/media-video/parole/parole-0.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.6.0.ebuild,v 1.1 2014/03/15 12:45:29 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="a simple media player based on the GStreamer framework for the Xfce4 desktop"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/parole/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="debug libnotify taglib"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.32
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfconf-4.10
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ taglib? ( >=media-libs/taglib-1.6 )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable taglib)
+ $(use_enable libnotify notify-plugin)
+ $(xfconf_use_debug)
+ --with-gstreamer=1.0
+ )
+
+ DOCS=( AUTHORS ChangeLog README THANKS TODO )
+}