summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-06 18:39:18 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-06 18:39:18 +0000
commitf776530dcac969081272f09d3a2c098220f61ac2 (patch)
tree4db84640fa27655aa6993bee8961e82dee8a3e10 /media-video/mpv/mpv-9999.ebuild
parentadd media-video/mpv dep wrt #506872 (diff)
downloadgentoo-2-f776530dcac969081272f09d3a2c098220f61ac2.tar.gz
gentoo-2-f776530dcac969081272f09d3a2c098220f61ac2.tar.bz2
gentoo-2-f776530dcac969081272f09d3a2c098220f61ac2.zip
Replace base inherit by eutils inherit. Update FDO MIME desktop database and GNOME 2 icon list cache. Fixes bug #374402 and bug #374410, proxied commit for Nikoli.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index d506b7f285b0..d994c741427d 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.41 2014/04/06 15:07:37 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.42 2014/04/06 18:39:18 tomwij Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit base waf-utils pax-utils
+inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.7.15"
@@ -158,7 +158,7 @@ src_unpack() {
}
src_prepare() {
- base_src_prepare
+ epatch_user
}
src_configure() {
@@ -232,3 +232,17 @@ src_install() {
pax-mark -m "${ED}"usr/bin/mpv
fi
}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}