summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-12 14:46:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-12 14:46:56 +0000
commit115bbdea26720859dc796c41bcc60067b0912c77 (patch)
tree26f402ee9e4845b7d6c08547b0f80cb60d27e470 /media-video/mjpegtools
parentremoved older ebuild (diff)
downloadgentoo-2-115bbdea26720859dc796c41bcc60067b0912c77.tar.gz
gentoo-2-115bbdea26720859dc796c41bcc60067b0912c77.tar.bz2
gentoo-2-115bbdea26720859dc796c41bcc60067b0912c77.zip
cleaned up ebuilds, and made them use avi USE toggle instead of avifile USE toggle
Diffstat (limited to 'media-video/mjpegtools')
-rw-r--r--media-video/mjpegtools/ChangeLog10
-rw-r--r--media-video/mjpegtools/mjpegtools-1.5.20011214.ebuild64
-rw-r--r--media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild68
-rw-r--r--media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild62
4 files changed, 100 insertions, 104 deletions
diff --git a/media-video/mjpegtools/ChangeLog b/media-video/mjpegtools/ChangeLog
index 045edcb5f893..6f2133b33204 100644
--- a/media-video/mjpegtools/ChangeLog
+++ b/media-video/mjpegtools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/mjpegtools
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/ChangeLog,v 1.1 2002/02/01 21:53:31 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/ChangeLog,v 1.2 2002/04/12 14:46:56 seemant Exp $
+
+*mjpegtools-1.5.20011611-r1 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org>
+ mjpegtools-1.5.20011611-r1.ebuild :
+
+ Changed avifile USE flag to avi USE flag instead and cleaned up ebuild
+ a little.
*mjpegtools-1.5.20011611-r1 (1 Feb 2002)
diff --git a/media-video/mjpegtools/mjpegtools-1.5.20011214.ebuild b/media-video/mjpegtools/mjpegtools-1.5.20011214.ebuild
index 3baf1a6a5715..83d527231b10 100644
--- a/media-video/mjpegtools/mjpegtools-1.5.20011214.ebuild
+++ b/media-video/mjpegtools/mjpegtools-1.5.20011214.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
# Heavily modified by Ryan Tolboom <ryan@gentoo.org>
@@ -11,24 +11,17 @@ SRC_URI="http://download.sourceforge.net/mjpeg/${A}
quicktime? ( http://download.sourceforge.net/mjpeg/quicktime4linux-1.4-patched.tar.gz )"
HOMEPAGE="http://mjpeg.sourceforge.net/"
-DEPEND="virtual/glibc
- >=media-libs/jpeg-6b
- >=sys-devel/automake-1.5b
- gtk? ( >=x11-libs/gtk+-1.2.10 )
+RDEPEND=">=media-libs/jpeg-6b
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
sdl? ( >=media-libs/libsdl-1.2.2 )
X? ( >=x11-base/xfree-4.1.0 )
+ avi? ( >=media-video/avifile-0.6.0.20011130 )"
+
+DEPEND="${RDEPEND}
quicktime? ( >=media-libs/libpng-1.0.12 )
- avifile? ( >=media-video/avifile-0.6.0.20011130 )
libmovtar? ( >=media-libs/libmovtar-0.1.2 )
mmx? ( >=media-libs/jpeg-mmx-1.1.2 )"
-RDEPEND="virtual/glibc
- >=media-libs/jpeg-6b
- gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
- sdl? ( >=media-libs/libsdl-1.2.2 )
- X? ( >=x11-base/xfree-4.1.0 )
- avifile? ( >=media-video/avifile-0.6.0.20011130 )"
-
src_unpack() {
unpack ${A}
@@ -54,38 +47,41 @@ src_compile() {
local myconf
- if [ "`use gtk`" ] ; then
- myconf="${myconf} --with-gtk-prefix=/usr"
- else
- myconf="${myconf} --with-gtk-prefix=/"
- fi
- if [ "`use X`" ] ; then
- myconf="${myconf} --with-x"
- else
- myconf="${myconf} --without-x"
- fi
- if [ "`use mmx`" ] ; then
- myconf="${myconf} --with-jpeg-mmx=/usr/include/jpeg-mmx --enable-mmx-accel"
- fi
- if [ -z "`use avifile`" ] ; then
- myconf="${myconf} --without-aviplay"
- fi
+ use gtk \
+ && myconf="${myconf} --with-gtk-prefix=/usr"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use mmx \
+ && myconf="${myconf} --with-jpeg-mmx=/usr/include/jpeg-mmx --enable-mmx-accel"
+
+ use avi \
+ || myconf="${myconf} --without-aviplay"
+
if [ "`use quicktime`" ] ; then
myconf="${myconf} --with-quicktime=${WORKDIR}/quicktime4linux-1.4-patch"
cd ${WORKDIR}/quicktime4linux-1.4-patch
- try ./configure
- try make
+ ./configure || die
+ make || die
fi
cd ${S}
- try ./configure ${myconf}
- try make
+ ./configure \
+ ${myconf} || die
+
+ emake || die
}
src_install () {
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
dodoc mjpeg_howto.txt
}
diff --git a/media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild b/media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild
index cb13b1c1eb8e..bd40244250db 100644
--- a/media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild
+++ b/media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
# Heavily modified by Ryan Tolboom <ryan@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild,v 1.1 2001/12/11 19:39:34 ryan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/mjpegtools-1.5.20011611-r1.ebuild,v 1.2 2002/04/12 14:46:56 seemant Exp $
A=${PN}-1.5-20011611.tar.gz
S=${WORKDIR}/${PN}-1.5-20011611
@@ -11,24 +11,17 @@ SRC_URI="http://download.sourceforge.net/mjpeg/${A}
quicktime? ( http://download.sourceforge.net/mjpeg/quicktime4linux-1.4-patched.tar.gz )"
HOMEPAGE="http://mjpeg.sourceforge.net/"
-DEPEND="virtual/glibc
- >=sys-devel/automake-1.5-r1
- >=media-libs/jpeg-6b
- gtk? ( >=x11-libs/gtk+-1.2.10 )
- sdl? ( >=media-libs/libsdl-1.2.2 )
+RDEPEND=">=media-libs/jpeg-6b
X? ( >=x11-base/xfree-4.1.0 )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ avi? ( >=media-video/avifile-0.6.0.20011130 )"
+
+DEPEND="${RDEPEND}
quicktime? ( >=media-libs/libpng-1.0.12 )
- avifile? ( >=media-video/avifile-0.6.0.20011130 )
libmovtar? ( >=media-libs/libmovtar-0.1.2 )
mmx? ( >=media-libs/jpeg-mmx-1.1.2 )"
-RDEPEND="virtual/glibc
- >=media-libs/jpeg-6b
- gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
- sdl? ( >=media-libs/libsdl-1.2.2 )
- X? ( >=x11-base/xfree-4.1.0 )
- avifile? ( >=media-video/avifile-0.6.0.20011130 )"
-
src_unpack() {
unpack ${A}
@@ -44,38 +37,41 @@ src_compile() {
local myconf
- if [ "`use gtk`" ] ; then
- myconf="${myconf} --with-gtk-prefix=/usr"
- else
- myconf="${myconf} --with-gtk-prefix=/"
- fi
- if [ "`use X`" ] ; then
- myconf="${myconf} --with-x"
- else
- myconf="${myconf} --without-x"
- fi
- if [ "`use mmx`" ] ; then
- myconf="${myconf} --with-jpeg-mmx=/usr/include/jpeg-mmx --enable-mmx-accel"
- fi
- if [ -z "`use avifile`" ] ; then
- myconf="${myconf} --without-aviplay"
- fi
+ use gtk \
+ && myconf="${myconf} --with-gtk-prefix=/usr"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use mmx \
+ && myconf="${myconf} --with-jpeg-mmx=/usr/include/jpeg-mmx --enable-mmx-accel"
+
+ use avi \
+ && myconf="${myconf} --without-aviplay"
+
if [ "`use quicktime`" ] ; then
myconf="${myconf} --with-quicktime=${WORKDIR}/quicktime4linux-1.4-patch"
cd ${WORKDIR}/quicktime4linux-1.4-patch
- try ./configure
- try make
+ ./configure || die
+ make || die
fi
cd ${S}
- try ./configure ${myconf}
- try make
+ ./configure \
+ ${myconf} || die
+
+ emake || die
}
src_install () {
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
dodoc mjpeg_howto.txt
}
diff --git a/media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild b/media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild
index dae8d3176c7e..cd2accf7bdb2 100644
--- a/media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild
+++ b/media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
# Heavily modified by Ryan Tolboom <ryan@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild,v 1.1 2001/12/07 18:28:42 ryan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/mjpegtools-1.5.20011611.ebuild,v 1.2 2002/04/12 14:46:56 seemant Exp $
A=${PN}-1.5-20011611.tar.gz
S=${WORKDIR}/${PN}-1.5-20011611
@@ -11,23 +11,16 @@ SRC_URI="http://download.sourceforge.net/mjpeg/${A}
quicktime? ( http://download.sourceforge.net/mjpeg/quicktime4linux-1.4-patched.tar.gz )"
HOMEPAGE="http://mjpeg.sourceforge.net/"
-DEPEND="virtual/glibc
- >=sys-devel/automake-1.5-r1
- >=media-libs/jpeg-6b
- gtk? ( >=x11-libs/gtk+-1.2.10 )
+RDEPEND=">=media-libs/jpeg-6b
+ X? ( virtual/xfree )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
sdl? ( >=media-libs/libsdl-1.2.2 )
- X? ( >=x11-base/xfree-4.1.0 )
+ avi? ( >=media-video/avifile-0.6.0.20011130 )"
+
+DEPEND="${RDEPEND}
quicktime? ( >=media-libs/libpng-1.0.12 )
- avifile? ( >=media-video/avifile-0.6.0.20011130 )
libmovtar? ( >=media-libs/libmovtar-0.1.2 )"
-RDEPEND="virtual/glibc
- >=media-libs/jpeg-6b
- gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
- sdl? ( >=media-libs/libsdl-1.2.2 )
- X? ( >=x11-base/xfree-4.1.0 )
- avifile? ( >=media-video/avifile-0.6.0.20011130 )"
-
src_unpack() {
unpack ${A}
@@ -43,35 +36,38 @@ src_compile() {
local myconf
- if [ "`use gtk`" ] ; then
- myconf="${myconf} --with-gtk-prefix=/usr"
- else
- myconf="${myconf} --with-gtk-prefix=/"
- fi
- if [ "`use X`" ] ; then
- myconf="${myconf} --with-x"
- else
- myconf="${myconf} --without-x"
- fi
- if [ -z "`use avifile`" ] ; then
- myconf="${myconf} --without-aviplay"
- fi
+ use gtk \
+ && myconf="${myconf} --with-gtk-prefix=/usr"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use avi \
+ || myconf="${myconf} --without-aviplay"
+
if [ "`use quicktime`" ] ; then
myconf="${myconf} --with-quicktime=${WORKDIR}/quicktime4linux-1.4-patch"
cd ${WORKDIR}/quicktime4linux-1.4-patch
- try ./configure
- try make
+ ./configure || die
+ make || die
fi
cd ${S}
- try ./configure ${myconf}
- try make
+ ./configure \
+ ${myconf} || die
+
+ emake || die
}
src_install () {
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
dodoc mjpeg_howto.txt
}