summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-23 21:38:06 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-23 21:38:06 +0000
commitd09536df0961f1b8907f279774bcb39925396b0d (patch)
treeb0e96c1a0e523797c32492bd951a5a0bb54a9112 /media-video/griffith
parentVersion bump. Remove old. (diff)
downloadgentoo-2-d09536df0961f1b8907f279774bcb39925396b0d.tar.gz
gentoo-2-d09536df0961f1b8907f279774bcb39925396b0d.tar.bz2
gentoo-2-d09536df0961f1b8907f279774bcb39925396b0d.zip
Initial commit of live ebuild. Moved from my overlay
(Portage version: 2.2_rc99/cvs/Linux x86_64)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog5
-rw-r--r--media-video/griffith/griffith-9999.ebuild84
2 files changed, 88 insertions, 1 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 2df99ecb29a3..e79b41db473f 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.49 2010/10/10 01:49:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.50 2010/10/23 21:38:06 hwoarang Exp $
+
+ 23 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +griffith-9999.ebuild:
+ Initial commit of live ebuild. Moved from my overlay
*griffith-0.12 (10 Oct 2010)
diff --git a/media-video/griffith/griffith-9999.ebuild b/media-video/griffith/griffith-9999.ebuild
new file mode 100644
index 000000000000..b281715ca265
--- /dev/null
+++ b/media-video/griffith/griffith-9999.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-9999.ebuild,v 1.4 2010/10/23 21:38:06 hwoarang Exp $
+
+EAPI="1"
+ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/griffith/trunk"
+
+inherit eutils python multilib subversion
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="csv doc spell"
+
+RDEPEND="dev-python/imaging
+ dev-util/glade:3
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/sqlalchemy-0.5.2
+ >=dev-python/reportlab-1.19
+ >=dev-python/sqlalchemy-0.4.6
+ csv? ( dev-python/chardet )
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+pkg_setup() {
+ ewarn "This version is _not_ compatible with databases created with previous versions"
+ ewarn "of griffith and the database upgrade is currently (16 Aug 2008) broken."
+ ewarn "Please move your ~/.griffith away before starting."
+}
+
+src_unpack() {
+ unpack ${A}
+ subversion_src_unpack
+
+ cd "${S}"
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ lib/gconsole.py || die "sed failed"
+
+ sed -i \
+ -e "s|locations\['lib'\], '..')|locations\['lib'\], '..', '..', 'share', 'griffith')|" \
+ lib/initialize.py || die "sed failed"
+
+ # this patch has to go upstream
+ epatch "${FILESDIR}"/fix_lib_path.patch
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ python_version
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}