summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-06-11 19:26:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-06-11 19:26:02 +0000
commit1f38cf38873f2a920742abb1f9f1e5ddb13fa2f1 (patch)
tree81a3d47c48905582928e274e37ce7b987f572a64 /media-video/cinelerra-cvs
parentStable on sparc (diff)
downloadgentoo-2-1f38cf38873f2a920742abb1f9f1e5ddb13fa2f1.tar.gz
gentoo-2-1f38cf38873f2a920742abb1f9f1e5ddb13fa2f1.tar.bz2
gentoo-2-1f38cf38873f2a920742abb1f9f1e5ddb13fa2f1.zip
Version bump, closing bug #181626 and bug #174159
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-video/cinelerra-cvs')
-rw-r--r--media-video/cinelerra-cvs/ChangeLog8
-rw-r--r--media-video/cinelerra-cvs/cinelerra-cvs-20070607.ebuild107
-rw-r--r--media-video/cinelerra-cvs/files/digest-cinelerra-cvs-200706073
-rw-r--r--media-video/cinelerra-cvs/files/recentffmpeg.patch29
4 files changed, 146 insertions, 1 deletions
diff --git a/media-video/cinelerra-cvs/ChangeLog b/media-video/cinelerra-cvs/ChangeLog
index 69cddd95f7e9..3a74c12b6d0f 100644
--- a/media-video/cinelerra-cvs/ChangeLog
+++ b/media-video/cinelerra-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/cinelerra-cvs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.28 2007/02/25 01:57:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.29 2007/06/11 19:26:02 aballier Exp $
+
+*cinelerra-cvs-20070607 (11 Jun 2007)
+
+ 11 Jun 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/recentffmpeg.patch, +cinelerra-cvs-20070607.ebuild:
+ Version bump, closing bug #181626 and bug #174159
25 Feb 2007; Alexis Ballier <aballier@gentoo.org>
-cinelerra-cvs-20061020.ebuild:
diff --git a/media-video/cinelerra-cvs/cinelerra-cvs-20070607.ebuild b/media-video/cinelerra-cvs/cinelerra-cvs-20070607.ebuild
new file mode 100644
index 000000000000..69bffd1568b6
--- /dev/null
+++ b/media-video/cinelerra-cvs/cinelerra-cvs-20070607.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/cinelerra-cvs-20070607.ebuild,v 1.1 2007/06/11 19:26:02 aballier Exp $
+
+WANT_AUTOMAKE=1.9
+WANT_AUTOCONF=2.5
+
+inherit toolchain-funcs eutils flag-o-matic autotools
+
+#filter-flags "-fPIC -fforce-addr"
+
+DESCRIPTION="Cinelerra - Professional Video Editor - Unofficial CVS-version"
+HOMEPAGE="http://cvs.cinelerra.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="3dnow alsa esd mmx oss static truetype ieee1394 css altivec opengl"
+RDEPEND="media-libs/libpng
+ >=media-libs/libdv-1.0.0
+ media-libs/faad2
+ media-libs/faac
+ media-libs/a52dec
+ media-libs/libsndfile
+ media-libs/tiff
+ media-video/ffmpeg
+ media-sound/lame
+ >=sci-libs/fftw-3.0.1
+ >=media-libs/x264-svn-20060302
+ ieee1394? ( media-libs/libiec61883 >=sys-libs/libraw1394-1.2.0 \
+ >=sys-libs/libavc1394-0.5.0 )
+ media-video/mjpegtools
+ alsa? ( media-libs/alsa-lib )
+ esd? ( >=media-sound/esound-0.2.34 )
+ truetype? ( >=media-libs/freetype-2.1.10 )
+ opengl? ( virtual/opengl )
+ >=media-libs/openexr-1.2.2
+ >=media-libs/libvorbis-1.1.0
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_alpha4-r1
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ x11-libs/libXvMC
+ x11-libs/libXft
+ ) virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if [[ "$(gcc-major-version)" -lt "4" ]]; then
+ eerror "You need to have gcc 4 or better"
+ eerror "Please follow : http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ eerror "And have a look at bug #128659"
+ die "You must use gcc 4 or better."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/recentffmpeg.patch"
+}
+
+src_compile() {
+ AT_M4DIR="m4" eautoreconf
+ econf \
+ `use_enable static` \
+ `use_enable alsa` \
+ `use_enable esd` \
+ `use_enable oss` \
+ `use_enable mmx` \
+ `use_enable 3dnow` \
+ --with-plugindir=/usr/$(get_libdir)/cinelerra \
+ `use_enable truetype freetype2` \
+ `use_enable ieee1394 firewire` \
+ `use_enable css` \
+ `use_enable opengl` \
+ `use_enable altivec` \
+ --with-external-ffmpeg \
+ --with-buildinfo=cust/"Gentoo - SVN r1009" \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dohtml -a png,html,texi,sdw -r doc/*
+ # workaround
+ rm -fR ${D}/usr/include
+ mv ${D}/usr/bin/mpeg3cat ${D}/usr/bin/mpeg3cat.hv
+ mv ${D}/usr/bin/mpeg3dump ${D}/usr/bin/mpeg3dump.hv
+ mv ${D}/usr/bin/mpeg3toc ${D}/usr/bin/mpeg3toc.hv
+ ln -s /usr/bin/mpeg2enc ${D}/usr/$(get_libdir)/cinelerra/mpeg2enc.plugin
+}
+
+pkg_postinst () {
+ elog "Please note that this is unofficial and somewhat experimental code."
+ elog "See cvs.cinelerra.org for a list of changes to the official cinelerra"
+ elog "release."
+}
diff --git a/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20070607 b/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20070607
new file mode 100644
index 000000000000..c910c7118b67
--- /dev/null
+++ b/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20070607
@@ -0,0 +1,3 @@
+MD5 2fe7fc904e12b2f151ca9f9abda370b3 cinelerra-cvs-20070607.tar.bz2 23791150
+RMD160 ecd77bab5f827139a4f64e75942b03aa9e7c22aa cinelerra-cvs-20070607.tar.bz2 23791150
+SHA256 728fd0ffc4f65eb13e892ca729b136e150bfee7ee11ed72d9ad389c25fa9ff6c cinelerra-cvs-20070607.tar.bz2 23791150
diff --git a/media-video/cinelerra-cvs/files/recentffmpeg.patch b/media-video/cinelerra-cvs/files/recentffmpeg.patch
new file mode 100644
index 000000000000..99f986966365
--- /dev/null
+++ b/media-video/cinelerra-cvs/files/recentffmpeg.patch
@@ -0,0 +1,29 @@
+Index: cinelerra-cvs/cinelerra/ffmpeg.h
+===================================================================
+--- cinelerra-cvs.orig/cinelerra/ffmpeg.h
++++ cinelerra-cvs/cinelerra/ffmpeg.h
+@@ -1,7 +1,9 @@
+ #ifndef FFMPEG_H
+ #define FFMPEG_H
+
++extern "C" {
+ #include <avcodec.h>
++}
+
+ #include "asset.h"
+ #include "guicast.h"
+Index: cinelerra-cvs/cinelerra/fileac3.h
+===================================================================
+--- cinelerra-cvs.orig/cinelerra/fileac3.h
++++ cinelerra-cvs/cinelerra/fileac3.h
+@@ -1,8 +1,9 @@
+ #ifndef FILEAC3_H
+ #define FILEAC3_H
+
+-
++extern "C" {
+ #include <avcodec.h>
++}
+ #include "filebase.h"
+ #include <stdio.h>
+