summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-09 22:38:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-09 22:38:54 +0000
commitb8682b37a37c7938e1d9422e7d8efd992bfb1ac9 (patch)
treef69e970f43bfbc8671cf8b058993c52122c46396 /media-video/cheese
parentDrop mask www-client/netsurf[abi_x86_32]. (diff)
downloadgentoo-2-b8682b37a37c7938e1d9422e7d8efd992bfb1ac9.tar.gz
gentoo-2-b8682b37a37c7938e1d9422e7d8efd992bfb1ac9.tar.bz2
gentoo-2-b8682b37a37c7938e1d9422e7d8efd992bfb1ac9.zip
Version bump for Gnome 3.16.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-video/cheese')
-rw-r--r--media-video/cheese/ChangeLog7
-rw-r--r--media-video/cheese/cheese-3.16.1.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/media-video/cheese/ChangeLog b/media-video/cheese/ChangeLog
index 815914be208d..caa3220169fe 100644
--- a/media-video/cheese/ChangeLog
+++ b/media-video/cheese/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cheese
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.93 2015/03/15 13:29:32 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.94 2015/06/09 22:38:54 eva Exp $
+
+*cheese-3.16.1 (09 Jun 2015)
+
+ 09 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> +cheese-3.16.1.ebuild:
+ Version bump for Gnome 3.16.
15 Mar 2015; Pacho Ramos <pacho@gentoo.org> cheese-3.14.2.ebuild:
x86 stable, bug 534012
diff --git a/media-video/cheese/cheese-3.16.1.ebuild b/media-video/cheese/cheese-3.16.1.ebuild
new file mode 100644
index 000000000000..fbb05c9aadf0
--- /dev/null
+++ b/media-video/cheese/cheese-3.16.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/cheese-3.16.1.ebuild,v 1.1 2015/06/09 22:38:54 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+
+# using clutter-gst-2.0.0 results in GLSL errors; bug #478702
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ >=media-libs/clutter-gst-2.0.6:2.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ virtual/libgudev:=
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-good:1.0
+
+ media-plugins/gst-plugins-jpeg:1.0
+ media-plugins/gst-plugins-v4l2:1.0
+ media-plugins/gst-plugins-vpx:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Clutter-related sandbox violations when USE="doc introspection" and
+ # FEATURES="-userpriv" (see bug #385917).
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ Xemake check
+}