summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 17:24:06 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 17:24:06 +0000
commit1068a030496608fbd2942fc94a57f456450d1e16 (patch)
tree6047fda9e7d6b13f49f2e999f4d98d3c446ce31a /media-video/cheese
parentNew package for Gnome 3.10 (diff)
downloadgentoo-2-1068a030496608fbd2942fc94a57f456450d1e16.tar.gz
gentoo-2-1068a030496608fbd2942fc94a57f456450d1e16.tar.bz2
gentoo-2-1068a030496608fbd2942fc94a57f456450d1e16.zip
Version bump for Gnome 3.10
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-video/cheese')
-rw-r--r--media-video/cheese/ChangeLog7
-rw-r--r--media-video/cheese/cheese-3.10.2.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/media-video/cheese/ChangeLog b/media-video/cheese/ChangeLog
index 2e4894f2ab14..a13cdb8808f6 100644
--- a/media-video/cheese/ChangeLog
+++ b/media-video/cheese/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cheese
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.76 2013/12/08 19:17:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.77 2013/12/24 17:24:06 pacho Exp $
+
+*cheese-3.10.2 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org> +cheese-3.10.2.ebuild:
+ Version bump for Gnome 3.10
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> cheese-3.8.3.ebuild:
x86 stable, bug #478252
diff --git a/media-video/cheese/cheese-3.10.2.ebuild b/media-video/cheese/cheese-3.10.2.ebuild
new file mode 100644
index 000000000000..656b52a7efb4
--- /dev/null
+++ b/media-video/cheese/cheese-3.10.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/cheese-3.10.2.ebuild,v 1.1 2013/12/24 17:24:06 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="http://projects.gnome.org/cheese/"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# using clutter-gst-2.0.0 results in GLSL errors; bug #478702
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4.4:3[introspection?]
+ >=x11-libs/cairo-1.10:=
+ >=x11-libs/pango-1.28.0
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=gnome-base/librsvg-2.32.0:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ >=media-libs/clutter-gst-2.0.6:2.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ >=virtual/udev-171:=[gudev]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-good:1.0
+
+ media-plugins/gst-plugins-jpeg:1.0
+ media-plugins/gst-plugins-v4l2:1.0
+ media-plugins/gst-plugins-vpx:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Clutter-related sandbox violations when USE="doc introspection" and
+ # FEATURES="-userpriv" (see bug #385917).
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ Xemake check
+}