summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-26 00:52:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-26 00:52:12 +0000
commitb163c442be91196806c2f35c3a34ec1c7eb83087 (patch)
treebd4cc5fd7ea870ea7fab382bcb7caa3f6de2cbb5 /media-video/avidemux
parentdont use old WANT_AUTOCONF #35111 (diff)
downloadgentoo-2-b163c442be91196806c2f35c3a34ec1c7eb83087.tar.gz
gentoo-2-b163c442be91196806c2f35c3a34ec1c7eb83087.tar.bz2
gentoo-2-b163c442be91196806c2f35c3a34ec1c7eb83087.zip
dont use old WANT_AUTOCONF #35111
Diffstat (limited to 'media-video/avidemux')
-rw-r--r--media-video/avidemux/avidemux-0.9-r1.ebuild12
-rw-r--r--media-video/avidemux/avidemux-2.0.18.ebuild27
-rw-r--r--media-video/avidemux/avidemux-2.0.20.ebuild24
3 files changed, 27 insertions, 36 deletions
diff --git a/media-video/avidemux/avidemux-0.9-r1.ebuild b/media-video/avidemux/avidemux-0.9-r1.ebuild
index 7955ee8f85ce..920d07fae891 100644
--- a/media-video/avidemux/avidemux-0.9-r1.ebuild
+++ b/media-video/avidemux/avidemux-0.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-0.9-r1.ebuild,v 1.3 2003/09/10 22:34:15 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-0.9-r1.ebuild,v 1.4 2004/01/26 00:49:35 vapier Exp $
inherit eutils
@@ -8,8 +8,8 @@ DESCRIPTION="Great Video editing/encoding tool"
HOMEPAGE="http://fixounet.free.fr/avidemux/"
SRC_URI="http://fixounet.free.fr/avidemux/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE="debug nls oggvorbis arts truetype alsa"
@@ -29,9 +29,6 @@ DEPEND="virtual/x11
truetype? ( >=media-libs/freetype-2.1.2 )
alsa? ( >=media-libs/alsa-lib-0.9.1 )"
-
-S=${WORKDIR}/${P}
-
src_compile() {
cd ${S}
@@ -47,7 +44,7 @@ src_compile() {
# Fixes a possible automake error due to clock skew
touch -r *
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf
local myconf
@@ -69,7 +66,6 @@ src_compile() {
make || die "make failed"
}
-
src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog History INSTALL README TODO
diff --git a/media-video/avidemux/avidemux-2.0.18.ebuild b/media-video/avidemux/avidemux-2.0.18.ebuild
index 214cf603cfee..1fcd8ce6b8f8 100644
--- a/media-video/avidemux/avidemux-2.0.18.ebuild
+++ b/media-video/avidemux/avidemux-2.0.18.ebuild
@@ -1,22 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.0.18.ebuild,v 1.5 2003/11/27 18:00:08 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.0.18.ebuild,v 1.6 2004/01/26 00:49:35 vapier Exp $
-IUSE="debug nls oggvorbis arts truetype alsa"
-filter-flags "-funroll-loops"
-filter-flags "-maltivec -mabi=altivec"
-inherit eutils
+inherit eutils flag-o-matic
MY_P=${P}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Great Video editing/encoding tool. New, gtk2 version"
+DESCRIPTION="Great Video editing/encoding tool"
HOMEPAGE="http://fixounet.free.fr/avidemux/"
SRC_URI="http://fixounet.free.fr/avidemux/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="x86 ~ppc"
+IUSE="debug nls oggvorbis arts truetype alsa"
DEPEND="virtual/x11
media-sound/mad
@@ -36,6 +32,7 @@ DEPEND="virtual/x11
alsa? ( >=media-libs/alsa-lib-0.9.1 )"
# media-sound/toolame is supported as well
+S=${WORKDIR}/${MY_P}
src_compile() {
# Fixes a possible automake error due to clock skew
@@ -44,15 +41,14 @@ src_compile() {
cd ${S}/avidemux/mpeg2enc; epatch ${FILESDIR}/gcc2.patch; cd ${S}
cd ${S}/avidemux/ADM_dialog; epatch ${FILESDIR}/resize_crash.patch; cd ${S}
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf
# invalid cast
use ppc \
&& sed -i -e '188s/const//g' avidemux/ADM_video/ADM_vidFont.cpp
- local myconf
- myconf="--with-gnu-ld --disable-warnings"
+ local myconf="--disable-warnings"
# --enable-profile creates profiling infos default=no
# --enable-pch enables precompiled header support
@@ -64,6 +60,9 @@ src_compile() {
use debug && myconf="${myconf} --enable-debug=full"
use nls || myconf="${myconf} --disable-nls"
+ filter-flags -funroll-loops
+ filter-flags -maltivec -mabi=altivec
+
econf ${myconf} || die "configure failed"
make || die "make failed"
@@ -75,9 +74,7 @@ src_install() {
}
pkg_postinst() {
-
- if [ -n "`use pcc`" ]
- then
+ if [ `use pcc` ] ; then
echo
einfo "OSS sound output may not work on ppc"
einfo "If your hear only static noise, try"
diff --git a/media-video/avidemux/avidemux-2.0.20.ebuild b/media-video/avidemux/avidemux-2.0.20.ebuild
index daaf2588508a..c2ec6ae4b5cd 100644
--- a/media-video/avidemux/avidemux-2.0.20.ebuild
+++ b/media-video/avidemux/avidemux-2.0.20.ebuild
@@ -1,22 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.0.20.ebuild,v 1.1 2003/12/21 11:10:33 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.0.20.ebuild,v 1.2 2004/01/26 00:49:35 vapier Exp $
-IUSE="debug nls oggvorbis arts truetype alsa"
-filter-flags "-funroll-loops"
-filter-flags "-maltivec -mabi=altivec"
-inherit eutils
+inherit eutils flag-o-matic
MY_P=${P}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Great Video editing/encoding tool. New, gtk2 version"
+DESCRIPTION="Great Video editing/encoding tool"
HOMEPAGE="http://fixounet.free.fr/avidemux/"
SRC_URI="http://fixounet.free.fr/avidemux/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~x86 ~ppc"
+IUSE="debug nls oggvorbis arts truetype alsa"
DEPEND="virtual/x11
media-sound/mad
@@ -36,12 +32,13 @@ DEPEND="virtual/x11
alsa? ( >=media-libs/alsa-lib-0.9.1 )"
# media-sound/toolame is supported as well
+S=${WORKDIR}/${MY_P}
src_compile() {
# Fixes a possible automake error due to clock skew
touch -r *
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf
# invalid cast
@@ -61,6 +58,9 @@ src_compile() {
use debug && myconf="${myconf} --enable-debug=full"
use nls || myconf="${myconf} --disable-nls"
+ filter-flags -funroll-loops
+ filter-flags -maltivec -mabi=altivec
+
econf ${myconf} || die "configure failed"
make || die "make failed"
@@ -72,9 +72,7 @@ src_install() {
}
pkg_postinst() {
-
- if [ -n "`use pcc`" ]
- then
+ if [ `use pcc` ] ; then
echo
einfo "OSS sound output may not work on ppc"
einfo "If your hear only static noise, try"