summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 14:45:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 14:45:23 +0000
commit7b0e359027895631544cd622179c6d7bdc9c5452 (patch)
tree8f3a9587b0a18aa1a9ef7cceb16040920bbb0c11 /media-tv
parentneed eutils for epatch (diff)
downloadgentoo-2-7b0e359027895631544cd622179c6d7bdc9c5452.tar.gz
gentoo-2-7b0e359027895631544cd622179c6d7bdc9c5452.tar.bz2
gentoo-2-7b0e359027895631544cd622179c6d7bdc9c5452.zip
sync with avifile
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/vcr/ChangeLog7
-rw-r--r--media-tv/vcr/files/1.09-r2-gentoo.diff146
-rw-r--r--media-tv/vcr/files/digest-vcr-1.09-r12
-rw-r--r--media-tv/vcr/files/digest-vcr-1.09-r22
-rw-r--r--media-tv/vcr/files/digest-vcr-1.101
-rw-r--r--media-tv/vcr/vcr-1.09-r1.ebuild33
-rw-r--r--media-tv/vcr/vcr-1.09-r2.ebuild46
-rw-r--r--media-tv/vcr/vcr-1.10.ebuild23
8 files changed, 30 insertions, 230 deletions
diff --git a/media-tv/vcr/ChangeLog b/media-tv/vcr/ChangeLog
index fe217b73eb84..5faa224b6f90 100644
--- a/media-tv/vcr/ChangeLog
+++ b/media-tv/vcr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/vcr
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/ChangeLog,v 1.1 2003/06/18 12:09:42 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/ChangeLog,v 1.2 2003/08/05 14:45:23 vapier Exp $
+
+*vcr-1.10 (05 Aug 2003)
+
+ 05 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumped to match up with latest avifile.
*vcr-1.09-r2 (18 Jun 2003)
diff --git a/media-tv/vcr/files/1.09-r2-gentoo.diff b/media-tv/vcr/files/1.09-r2-gentoo.diff
deleted file mode 100644
index 9a2226fbb313..000000000000
--- a/media-tv/vcr/files/1.09-r2-gentoo.diff
+++ /dev/null
@@ -1,146 +0,0 @@
-diff -urN vcr-1.09/src/capproc.cc vcr-1.09-modified/src/capproc.cc
---- vcr-1.09/src/capproc.cc 2001-11-11 08:39:22.000000000 -0600
-+++ vcr-1.09-modified/src/capproc.cc 2002-10-21 14:29:55.000000000 -0500
-@@ -5,6 +5,7 @@
- #include <avifile.h>
- #include <videoencoder.h>
- #include <iostream>
-+#include <sstream>
-
- #ifdef OLDAVIFILE
- # include <aviutil.h>
-diff -urN vcr-1.09/src/capproc.h vcr-1.09-modified/src/capproc.h
---- vcr-1.09/src/capproc.h 2001-07-27 17:05:54.000000000 -0500
-+++ vcr-1.09-modified/src/capproc.h 2002-10-21 14:44:31.000000000 -0500
-@@ -1,6 +1,6 @@
- #include <queue>
- #include <string>
--#include <strstream>
-+#include <sstream>
- #include <pthread.h>
- #include "v4lxif.h"
- #include "vcr.h"
-@@ -88,8 +88,8 @@
- int comp_drop;
- long long starttime;
-
-- std::strstream* messenger;
-- std::strstream def_mess;
-+ std::ostringstream* messenger;
-+ std::ostringstream def_mess;
-
- std::string filename;
- int segment_size;
-@@ -187,7 +187,7 @@
- {
- m_quit = 1;
- }
-- void setMessenger(std::strstream& mess)
-+ void setMessenger(std::ostringstream& mess)
- {
- messenger=&mess;
- }
-diff -urN vcr-1.09/src/main.cc vcr-1.09-modified/src/main.cc
---- vcr-1.09/src/main.cc 2001-11-11 08:38:36.000000000 -0600
-+++ vcr-1.09-modified/src/main.cc 2002-10-21 15:00:16.000000000 -0500
-@@ -16,7 +16,7 @@
- #include <sys/stat.h>
- #include <sys/ioctl.h>
- #include <fcntl.h>
--#include <iostream.h>
-+#include <iostream>
- /* Custom headerfiles */
-
- #include "vcr.h"
-@@ -134,7 +134,7 @@
- resolution_width = 0,
- resolution_height = 0;
- #ifdef OLDAVIFILE
--vector<AttributeInfo>
-+std::vector<AttributeInfo>
- #else
- avm::vector<AttributeInfo>
- #endif
-@@ -498,10 +498,9 @@
- fprintf(stderr, "\n");
- }
-
--void
--list_codecs()
-+void list_codecs()
- {
-- vector<CodecInfo>::iterator it;
-+ avm::vector<CodecInfo>::iterator it;
-
- fprintf(stderr, "Available codecs: \n\n");
-
-@@ -549,14 +548,14 @@
- return;
-
- #ifdef OLDAVIFILE
-- vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
-+ std::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
- #else
- avm::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
- #endif
-
- fprintf(stderr, "These attributes are supported for this codec:\n\n");
-
-- vector<AttributeInfo>::const_iterator it;
-+ avm::vector<AttributeInfo>::const_iterator it;
- for(it=encinfo.begin(); it!=encinfo.end(); it++)
- {
- #ifdef OLDAVIFILE
-@@ -587,9 +586,9 @@
- fprintf(stderr, "\tPossible values: ");
-
- #ifdef OLDAVIFILE
-- vector<string>::const_iterator sit;
-+ std::vector<string>::const_iterator sit;
- #else
-- vector<avm::string>::const_iterator sit;
-+ avm::vector<avm::string>::const_iterator sit;
- #endif
- for (sit=(it->options).begin(); sit!=(it->options).end(); sit++)
- fprintf(stderr, "\"%s\" ", sit->c_str());
-@@ -805,7 +804,7 @@
- int
- found_codec = -1;
-
-- vector<CodecInfo>::iterator it;
-+ avm::vector<CodecInfo>::iterator it;
-
- for (it = video_codecs.begin(); it != video_codecs.end(); it++)
- {
-@@ -1003,7 +1002,7 @@
- int
- get_codec_index(int fourcc)
- {
-- vector<CodecInfo>::iterator it;
-+ avm::vector<CodecInfo>::iterator it;
- int i = 0;
-
- for (it = video_codecs.begin(); it != video_codecs.end(); it++)
-@@ -1017,19 +1016,18 @@
- }
-
- //TODO: It ignores fourcc currently..
--short
--set_attribute(int fourcc, const char *attr, const char *val)
-+short set_attribute(int fourcc, const char *attr, const char *val)
- {
- int setval = 0;
- int retval = 0;
-
-- vector<AttributeInfo>::const_iterator it;
-+ avm::vector<AttributeInfo>::const_iterator it;
- int idx = get_codec_index(fourcc);
- if (idx < 0)
- return 0;
-
- #ifdef OLDAVIFILE
-- vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
-+ std::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
- #else
- avm::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
- #endif
diff --git a/media-tv/vcr/files/digest-vcr-1.09-r1 b/media-tv/vcr/files/digest-vcr-1.09-r1
deleted file mode 100644
index 88717d8cf0c8..000000000000
--- a/media-tv/vcr/files/digest-vcr-1.09-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 18a41f998647b8e32f07de3c9f899009 vcr-1.09.tar.gz 117377
-MD5 5b5238d60567080f7c9fbf53d023273f vcr-1.09-gentoo.diff.bz2 1678
diff --git a/media-tv/vcr/files/digest-vcr-1.09-r2 b/media-tv/vcr/files/digest-vcr-1.09-r2
deleted file mode 100644
index c75848ea1ecb..000000000000
--- a/media-tv/vcr/files/digest-vcr-1.09-r2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 18a41f998647b8e32f07de3c9f899009 vcr-1.09.tar.gz 117377
-MD5 f05957fcc83f7c890734e093eda2bd99 vcr_1.09-11.diff.gz 5169
diff --git a/media-tv/vcr/files/digest-vcr-1.10 b/media-tv/vcr/files/digest-vcr-1.10
new file mode 100644
index 000000000000..a1ba8636e731
--- /dev/null
+++ b/media-tv/vcr/files/digest-vcr-1.10
@@ -0,0 +1 @@
+MD5 1c06ac4b1693c28f19dce8d3504e983a vcr-1.10.tar.gz 179337
diff --git a/media-tv/vcr/vcr-1.09-r1.ebuild b/media-tv/vcr/vcr-1.09-r1.ebuild
deleted file mode 100644
index 067a684a43e5..000000000000
--- a/media-tv/vcr/vcr-1.09-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/vcr-1.09-r1.ebuild,v 1.1 2003/06/18 12:09:42 seemant Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="VCR - Linux Console VCR"
-SRC_URI="http://www.stack.nl/~brama/${PN}/src/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.diff.bz2"
-HOMEPAGE="http://www.stack.nl/~brama/vcr/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
-
-DEPEND="=media-video/avifile-0.7.15*"
-
-src_unpack () {
- unpack ${P}.tar.gz
- ( bzcat ${DISTDIR}/${P}-gentoo.diff.bz2 | patch -p0 ) || die
-}
-
-src_compile () {
- local myconf
- myconf="--enable-avifile-0_6"
- econf ${myconf} || die "econf died"
- emake || die "emake died"
-}
-
-src_install () {
-
- einstall || die "einstall died"
- dodoc AUTHORS COPYING ChangeLog NEWS README
-}
diff --git a/media-tv/vcr/vcr-1.09-r2.ebuild b/media-tv/vcr/vcr-1.09-r2.ebuild
deleted file mode 100644
index 3b44cf21dfd0..000000000000
--- a/media-tv/vcr/vcr-1.09-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/vcr-1.09-r2.ebuild,v 1.1 2003/06/18 12:09:42 seemant Exp $
-
-IUSE=""
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="VCR - Linux Console VCR"
-SRC_URI="http://www.stack.nl/~brama/${PN}/src/${P}.tar.gz"
-HOMEPAGE="http://www.stack.nl/~brama/vcr/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
-
-DEPEND="=media-video/avifile-0.7.15*"
-
-src_unpack () {
-
- unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/1.09-r2-gentoo.diff || die "patch failed"
-
-}
-
-src_compile () {
-
- local myconf
- myconf="--enable-avifile-0_6"
-
- export CXX="g++"
-
- econf ${myconf} || die "econf died"
-
- make || die "emake died"
-
-}
-
-src_install () {
-
- einstall || die "einstall died"
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
-
-}
diff --git a/media-tv/vcr/vcr-1.10.ebuild b/media-tv/vcr/vcr-1.10.ebuild
new file mode 100644
index 000000000000..2f6f464cd915
--- /dev/null
+++ b/media-tv/vcr/vcr-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vcr/vcr-1.10.ebuild,v 1.1 2003/08/05 14:45:23 vapier Exp $
+
+DESCRIPTION="VCR - Linux Console VCR"
+HOMEPAGE="http://www.stack.nl/~brama/vcr/"
+SRC_URI="http://www.stack.nl/~brama/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=media-video/avifile-0.7.37*"
+
+src_compile() {
+ econf || die "econf died"
+ make || die "emake died"
+}
+
+src_install () {
+ make install DESTDIR=${D} || die "einstall died"
+ dodoc AUTHORS ChangeLog NEWS README
+}