summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-11-17 13:35:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-11-17 13:35:27 +0000
commit7f925ee0b624f8d692026a6689e8c6ef676fc7a1 (patch)
treef449db84eeef9cb0228546f01a7b2c1d1965817d /media-tv/tvtime
parentStable on ppc wrt bug 198845 (diff)
downloadgentoo-2-7f925ee0b624f8d692026a6689e8c6ef676fc7a1.tar.gz
gentoo-2-7f925ee0b624f8d692026a6689e8c6ef676fc7a1.tar.bz2
gentoo-2-7f925ee0b624f8d692026a6689e8c6ef676fc7a1.zip
Link to -lsupc++ rather than -lstdc++, this way the dependency over libstdc++.so is dropped.
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-tv/tvtime')
-rw-r--r--media-tv/tvtime/ChangeLog9
-rw-r--r--media-tv/tvtime/files/digest-tvtime-1.0.2-r23
-rw-r--r--media-tv/tvtime/files/tvtime-1.0.2-libsupc++.patch16
-rw-r--r--media-tv/tvtime/tvtime-1.0.2-r2.ebuild83
4 files changed, 110 insertions, 1 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index fe60b73d4f66..8129e4d3b610 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/tvtime
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.41 2007/10/06 20:11:09 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.42 2007/11/17 13:35:26 flameeyes Exp $
+
+*tvtime-1.0.2-r2 (17 Nov 2007)
+
+ 17 Nov 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/tvtime-1.0.2-libsupc++.patch, +tvtime-1.0.2-r2.ebuild:
+ Link to -lsupc++ rather than -lstdc++, this way the dependency over
+ libstdc++.so is dropped.
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
tvtime-1.0.2-r1.ebuild:
diff --git a/media-tv/tvtime/files/digest-tvtime-1.0.2-r2 b/media-tv/tvtime/files/digest-tvtime-1.0.2-r2
new file mode 100644
index 000000000000..84daa7261293
--- /dev/null
+++ b/media-tv/tvtime/files/digest-tvtime-1.0.2-r2
@@ -0,0 +1,3 @@
+MD5 4b3d03afe61be239b08b5e522cd8afed tvtime-1.0.2.tar.gz 1645742
+RMD160 e7d9621054edba5833f4ea002be8979983fbf3dc tvtime-1.0.2.tar.gz 1645742
+SHA256 aef2a4bab084df252428d66cabec61b4c63fab32cdfc0cc6599d82efd77f0523 tvtime-1.0.2.tar.gz 1645742
diff --git a/media-tv/tvtime/files/tvtime-1.0.2-libsupc++.patch b/media-tv/tvtime/files/tvtime-1.0.2-libsupc++.patch
new file mode 100644
index 000000000000..cc76d2decc62
--- /dev/null
+++ b/media-tv/tvtime/files/tvtime-1.0.2-libsupc++.patch
@@ -0,0 +1,16 @@
+Link to libsupc++ instead of bringing in libstdc++ just because tomsocomp
+is written in C++. It does not use STL so it needs not the whole standard
+library.
+Index: tvtime-1.0.2/src/Makefile.am
+===================================================================
+--- tvtime-1.0.2.orig/src/Makefile.am
++++ tvtime-1.0.2/src/Makefile.am
+@@ -77,7 +77,7 @@ tvtime_CFLAGS = $(TTF_CFLAGS) $(PNG_CFLA
+ $(PLUGIN_CFLAGS) $(X11_CFLAGS) $(XML2_FLAG) \
+ $(FONT_CFLAGS) $(AM_CFLAGS)
+ tvtime_LDFLAGS = $(TTF_LIBS) $(ZLIB_LIBS) $(PNG_LIBS) \
+- $(X11_LIBS) $(XML2_LIBS) -lm -lstdc++
++ $(X11_LIBS) $(XML2_LIBS) -lm -lsupc++
+
+ tvtime_command_SOURCES = utils.h utils.c tvtimeconf.h tvtimeconf.c \
+ tvtime-command.c
diff --git a/media-tv/tvtime/tvtime-1.0.2-r2.ebuild b/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..2ba708145c55
--- /dev/null
+++ b/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2-r2.ebuild,v 1.1 2007/11/17 13:35:26 flameeyes Exp $
+
+WANT_AUTOMAKE=1.7
+WANT_AUTOCONF=2.5
+
+inherit eutils autotools
+
+DESCRIPTION="High quality television application for use with video capture cards"
+HOMEPAGE="http://tvtime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND="x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXtst
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ >=media-libs/freetype-2
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/libpng-1.2
+ >=dev-libs/libxml2-2.5.11
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/tvtime-1.0.2-gcc41.patch
+
+ # use 'tvtime' for the application icon see bug #66293
+ sed -i -e "s/tvtime.png/tvtime/" docs/net-tvtime.desktop
+
+ # patch to adapt to PIC or __PIC__ for pic support
+ epatch "${FILESDIR}"/${PN}-pic.patch #74227
+
+ epatch "${FILESDIR}/${P}-xinerama.patch"
+
+ # Remove linux headers and patch to build with 2.6.18 headers
+ rm -f "${S}"/src/{videodev.h,videodev2.h}
+ epatch "${FILESDIR}/${P}+linux-headers-2.6.18.patch"
+
+ epatch "${FILESDIR}/${P}-libsupc++.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ $(use_with xinerama) || die "econf failed"
+ emake || die "compile problem"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dohtml docs/html/*
+ dodoc ChangeLog AUTHORS NEWS README
+}
+
+pkg_postinst() {
+ elog "A default setup for ${PN} has been saved as"
+ elog "/etc/tvtime/tvtime.xml. You may need to modify it"
+ elog "for your needs."
+ elog
+ elog "Detailed information on ${PN} setup can be"
+ elog "found at ${HOMEPAGE}help.html"
+ echo
+}