summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-30 22:46:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-30 22:46:24 +0000
commit4ea8c68c0d11a3138a90d85fb04cb83ca634e5fe (patch)
tree76282cfdefbb00ce419a301fd257b93d3a96d7e7 /media-tv/tvtime
parentppc stable wrt bug #159430 (diff)
downloadgentoo-2-4ea8c68c0d11a3138a90d85fb04cb83ca634e5fe.tar.gz
gentoo-2-4ea8c68c0d11a3138a90d85fb04cb83ca634e5fe.tar.bz2
gentoo-2-4ea8c68c0d11a3138a90d85fb04cb83ca634e5fe.zip
Add patch to build with linux-headers-2.6.18 and later. Closes bug #159510 reported by Balint Dobai-Pataky.
(Portage version: 2.1.2_rc4-r2)
Diffstat (limited to 'media-tv/tvtime')
-rw-r--r--media-tv/tvtime/ChangeLog9
-rw-r--r--media-tv/tvtime/files/digest-tvtime-1.0.2-r13
-rw-r--r--media-tv/tvtime/files/tvtime-1.0.2+linux-headers-2.6.18.patch15
-rw-r--r--media-tv/tvtime/tvtime-1.0.2-r1.ebuild82
4 files changed, 108 insertions, 1 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index fd5695f162be..4d7123ef894c 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/tvtime
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.35 2006/10/28 11:40:33 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.36 2006/12/30 22:46:24 flameeyes Exp $
+
+*tvtime-1.0.2-r1 (30 Dec 2006)
+
+ 30 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/tvtime-1.0.2+linux-headers-2.6.18.patch, +tvtime-1.0.2-r1.ebuild:
+ Add patch to build with linux-headers-2.6.18 and later. Closes bug #159510
+ reported by Balint Dobai-Pataky.
28 Oct 2006; Matthias Schwarzott <zzam@gentoo.org> tvtime-1.0.2.ebuild:
Added WANT_AUTOMAKE and WANT_AUTOCONF due to Bug #153082.
diff --git a/media-tv/tvtime/files/digest-tvtime-1.0.2-r1 b/media-tv/tvtime/files/digest-tvtime-1.0.2-r1
new file mode 100644
index 000000000000..84daa7261293
--- /dev/null
+++ b/media-tv/tvtime/files/digest-tvtime-1.0.2-r1
@@ -0,0 +1,3 @@
+MD5 4b3d03afe61be239b08b5e522cd8afed tvtime-1.0.2.tar.gz 1645742
+RMD160 e7d9621054edba5833f4ea002be8979983fbf3dc tvtime-1.0.2.tar.gz 1645742
+SHA256 aef2a4bab084df252428d66cabec61b4c63fab32cdfc0cc6599d82efd77f0523 tvtime-1.0.2.tar.gz 1645742
diff --git a/media-tv/tvtime/files/tvtime-1.0.2+linux-headers-2.6.18.patch b/media-tv/tvtime/files/tvtime-1.0.2+linux-headers-2.6.18.patch
new file mode 100644
index 000000000000..b1cfd49f1ba9
--- /dev/null
+++ b/media-tv/tvtime/files/tvtime-1.0.2+linux-headers-2.6.18.patch
@@ -0,0 +1,15 @@
+Index: tvtime-1.0.2/src/videoinput.c
+===================================================================
+--- tvtime-1.0.2.orig/src/videoinput.c
++++ tvtime-1.0.2/src/videoinput.c
+@@ -35,8 +35,8 @@
+ #ifdef HAVE_CONFIG_H
+ # include "config.h"
+ #endif
+-#include "videodev.h"
+-#include "videodev2.h"
++#include <linux/videodev.h>
++#include <linux/videodev2.h>
+ #include "videoinput.h"
+ #include "mixer.h"
+
diff --git a/media-tv/tvtime/tvtime-1.0.2-r1.ebuild b/media-tv/tvtime/tvtime-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..3a858d77773e
--- /dev/null
+++ b/media-tv/tvtime/tvtime-1.0.2-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2-r1.ebuild,v 1.1 2006/12/30 22:46:24 flameeyes Exp $
+
+WANT_AUTOMAKE=1.7
+WANT_AUTOCONF=2.5
+
+inherit eutils autotools
+
+DESCRIPTION="High quality television application for use with video capture cards"
+HOMEPAGE="http://tvtime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND="|| ( ( x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXtst
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ <virtual/x11-7 )
+ >=media-libs/freetype-2
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/libpng-1.2
+ >=dev-libs/libxml2-2.5.11
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/tvtime-1.0.2-gcc41.patch
+
+ # use 'tvtime' for the application icon see bug #66293
+ sed -i -e "s/tvtime.png/tvtime/" docs/net-tvtime.desktop
+
+ # patch to adapt to PIC or __PIC__ for pic support
+ epatch "${FILESDIR}"/${PN}-pic.patch #74227
+
+ epatch "${FILESDIR}/${P}-xinerama.patch"
+
+ # Remove linux headers and patch to build with 2.6.18 headers
+ rm -f "${S}"/src/{videodev.h,videodev2.h}
+ epatch "${FILESDIR}/${P}+linux-headers-2.6.18.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ $(use_with xinerama) || die "econf failed"
+ emake || die "compile problem"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dohtml docs/html/*
+ dodoc ChangeLog AUTHORS NEWS README
+}
+
+pkg_postinst() {
+ einfo "A default setup for ${PN} has been saved as"
+ einfo "/etc/tvtime/tvtime.xml. You may need to modify it"
+ einfo "for your needs."
+ einfo
+ einfo "Detailed information on ${PN} setup can be"
+ einfo "found at ${HOMEPAGE}help.html"
+ echo
+}