summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-06-13 13:15:05 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-06-13 13:15:05 +0000
commit59c8d3930ab228e2664b0cebef48dfa25839b8c6 (patch)
tree481c36bf2316fccaf9f0c2152141c4885224b0a4 /media-tv/tvmovie2vdr
parentFix changelog (diff)
downloadgentoo-2-59c8d3930ab228e2664b0cebef48dfa25839b8c6.tar.gz
gentoo-2-59c8d3930ab228e2664b0cebef48dfa25839b8c6.tar.bz2
gentoo-2-59c8d3930ab228e2664b0cebef48dfa25839b8c6.zip
Version bumped. Watch out changed filenames, tvm2vdr instead of tvm2vdr.pl.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-tv/tvmovie2vdr')
-rw-r--r--media-tv/tvmovie2vdr/ChangeLog8
-rw-r--r--media-tv/tvmovie2vdr/files/digest-tvmovie2vdr-0.5.133
-rw-r--r--media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild110
3 files changed, 120 insertions, 1 deletions
diff --git a/media-tv/tvmovie2vdr/ChangeLog b/media-tv/tvmovie2vdr/ChangeLog
index c01aa5e03a75..d61ce1b3dd88 100644
--- a/media-tv/tvmovie2vdr/ChangeLog
+++ b/media-tv/tvmovie2vdr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/tvmovie2vdr
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvmovie2vdr/ChangeLog,v 1.2 2007/05/31 10:49:28 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvmovie2vdr/ChangeLog,v 1.3 2007/06/13 13:15:05 zzam Exp $
+
+*tvmovie2vdr-0.5.13 (13 Jun 2007)
+
+ 13 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +tvmovie2vdr-0.5.13.ebuild:
+ Version bumped. Watch out changed filenames, tvm2vdr instead of tvm2vdr.pl.
31 May 2007; Matthias Schwarzott <zzam@gentoo.org>
tvmovie2vdr-0.5.12.ebuild:
diff --git a/media-tv/tvmovie2vdr/files/digest-tvmovie2vdr-0.5.13 b/media-tv/tvmovie2vdr/files/digest-tvmovie2vdr-0.5.13
new file mode 100644
index 000000000000..0b925bff007e
--- /dev/null
+++ b/media-tv/tvmovie2vdr/files/digest-tvmovie2vdr-0.5.13
@@ -0,0 +1,3 @@
+MD5 bb0d1be732fa4f892d0f3d9e66de4bf6 tvmovie2vdr-0.5.13.tar.gz 214954
+RMD160 3a502920ca8a36f3c9c6376238f4d8dde3cbe732 tvmovie2vdr-0.5.13.tar.gz 214954
+SHA256 9490ec19f0543052dbc6f67cf2492cec05fbbdef399540ddab33ffc0afc5ab15 tvmovie2vdr-0.5.13.tar.gz 214954
diff --git a/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild b/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild
new file mode 100644
index 000000000000..e61981c36408
--- /dev/null
+++ b/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild,v 1.1 2007/06/13 13:15:05 zzam Exp $
+
+inherit eutils
+
+VDR_CONF_DIR="/etc/vdr"
+VDR_VIDEO_DIR="/var/vdr/video"
+
+CONF_DIR="/etc/vdr/tvmovie2vdr"
+VAR_DIR="/var/vdr/tvmovie2vdr"
+SHARE_DIR="/usr/share/${PN}"
+
+DESCRIPTION="load the program guide from tvmovie and others to vdr"
+HOMEPAGE="http://steckrue.be/tvm2vdr/"
+SRC_URI="http://steckrue.be/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.0
+ >=dev-perl/DateManip-5.42a-r1
+ >=dev-perl/Compress-Zlib-1.22
+ >=dev-perl/Archive-Zip-1.14
+ >=dev-perl/Text-Iconv-1.4
+ >=dev-perl/libwww-perl-5.69-r2
+ >=dev-perl/HTML-Parser-3.34-r1
+ >=dev-perl/HTML-Scrubber-0.08
+ >=dev-perl/HTML-TableContentParser-0.13
+ >=dev-perl/XML-Simple-DTDReader-0.03
+ >=media-gfx/imagemagick-6.2.2.3
+ dev-perl/DateManip
+ dev-perl/XML-Simple-DTDReader"
+
+src_compile() {
+ # change default downloadpath in config
+ sed -i config/config.pl_dist \
+ -e "s:channelsfile = .*;:channelsfile = \"${VDR_CONF_DIR}/channels.conf\";:" \
+ -e "s:epgfile = .*;:epgfile = \"${VDR_VIDEO_DIR}/epg.data\";:" \
+ -e "s:downloadprefix = .*;:downloadprefix = \"${VAR_DIR}/downloadfiles/\";:" \
+ -e "s:updateprefix = .*;:updateprefix = \"${VAR_DIR}/downloadupdatefiles/\";:" \
+ -e "s:infosaturl=.*;:infosaturl=\"${VAR_DIR}/infosatepg\";:" \
+ -e 's:imagepath = .*;:imagepath = "/var/vdr/epgimages";:'
+
+ # set correct pathes to conf and include files
+ sed -i tvm2vdr tvinfomerk2vdr clearoldtimer \
+ -e 's:push (@INC, "./config");:push (@INC, "'${CONF_DIR}'");:' \
+ -e 's:push (@INC, "./inc");:push (@INC, "'${SHARE_DIR}/inc'");:' \
+ -e "s:contrib/:${SHARE_DIR}/contrib/:"
+}
+
+src_install() {
+ # config files
+ insinto "${CONF_DIR}"
+ local c
+ for c in channels.pl channels_vps_wanted.pl channels_wanted.pl config.pl; do
+ newins "config/${c}_dist" "${c}"
+ done
+
+ # include files - helpers for different providers
+ insinto "${SHARE_DIR}/inc"
+ doins inc/*
+
+ exeinto "${SHARE_DIR}/contrib"
+ doexe ./contrib/*
+ doexe clearoldtimer getinfosat tvm2vdr.sh
+
+ # install main binaries
+ dobin tvinfomerk2vdr
+ dobin tvm2vdr
+
+ # dirs to keep downloaded data in
+ keepdir "${VAR_DIR}/downloadfiles"
+ keepdir "${VAR_DIR}/downloadupdatefiles"
+ keepdir "/var/vdr/epgimages"
+ chown -R vdr:vdr "${D}/${VAR_DIR}" "${D}/var/vdr/epgimages"
+
+ # install documentation
+ dodoc HISTORY README tvm2vdr.sh
+}
+
+pkg_postinst() {
+ # cleanup old cruft
+ [ -L "${ROOT}/etc/vdr/tvmovie2vdr/files" ] \
+ && rm -f "${ROOT}/etc/vdr/tvmovie2vdr/files"
+
+ [ -L "${ROOT}/var/vdr/tvmovie2vdr/tvmovie2vdr" ] \
+ && rm -f "${ROOT}/var/vdr/tvmovie2vdr/tvmovie2vdr"
+
+
+ eerror "The executable name of tvmovie2vdr changed!"
+ eerror "Old name was tvm2vdr.pl, new is: tvm2vdr"
+ eerror "Please change name in your cron-job!"
+ eerror
+
+ elog "You have to configure the following files:"
+ elog "\t${CONF_DIR}/config.pl"
+ elog "\t${CONF_DIR}/channels_wanted.pl"
+ elog
+ elog "It's a good idea to add the following to /etc/crontab:"
+ elog "\t3 5 * * * vdr /usr/bin/tvinfomerk2vdr"
+ elog "\t7 5 * * * vdr /usr/bin/tvm2vdr"
+ elog
+ elog "To delete old pictures you should run the following command with the tvmovie2vdr run:"
+ elog "\tfind /var/vdr/epgimages/ -type f -mtime +10 -exec rm {} \;"
+ elog "or see tvm2vdr.sh in /usr/share/tvmovie2vdr/contrib"
+ elog
+}