summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-03-02 21:45:59 +0000
committerSteve Dibb <beandog@gentoo.org>2009-03-02 21:45:59 +0000
commit5ad49113f46e91a05685d1ea6975c0b0f2538b74 (patch)
tree6d8dc506323b2d1da426402f4c84ced1d70447b9 /media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
parentAdd some "die" commands. (diff)
downloadgentoo-2-5ad49113f46e91a05685d1ea6975c0b0f2538b74.tar.gz
gentoo-2-5ad49113f46e91a05685d1ea6975c0b0f2538b74.tar.bz2
gentoo-2-5ad49113f46e91a05685d1ea6975c0b0f2538b74.zip
Move SRC_URI to tarball instead of SVN
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild')
-rw-r--r--media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild b/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
index dd9f60e6521e..d173ea1db7d6 100644
--- a/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild,v 1.1 2009/02/22 03:55:42 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild,v 1.2 2009/03/02 21:45:59 beandog Exp $
EAPI=2
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python confutils
@@ -9,6 +9,8 @@ DESCRIPTION="Homebrew PVR project"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
+SRC_URI="mirrors://gentoo/${P}.tar.bz2"
+
IUSE_VIDEO_CARDS="video_cards_nvidia"
IUSE="aac alsa altivec autostart debug directv dvb dvd fftw ieee1394 jack lcd \
lirc mmx opengl perl python xvmc ${IUSE_VIDEO_CARDS}"
@@ -52,8 +54,6 @@ DEPEND="${RDEPEND}
PDEPEND="=x11-themes/mythtv-themes-${MY_PV}*"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
MYTHTV_GROUPS="video,audio,tty,uucp"
pkg_setup() {
@@ -69,7 +69,10 @@ pkg_setup() {
usermod -a -G ${MYTHTV_GROUPS} mythtv
}
-src_prepare() {
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
# upstream wants the revision number in their version.cpp
# since the subversion.eclass strips out the .svn directory
# svnversion in MythTV's build doesn't work