summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-01 12:14:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-01 12:14:46 +0000
commite7f58de90c4743f09e1be94576659e6507dba56b (patch)
treec657f42cec3f1590a9a3e334393eeb52d0c7ca31 /media-sound
parentRemove old version of luadbi. (diff)
downloadgentoo-2-e7f58de90c4743f09e1be94576659e6507dba56b.tar.gz
gentoo-2-e7f58de90c4743f09e1be94576659e6507dba56b.tar.bz2
gentoo-2-e7f58de90c4743f09e1be94576659e6507dba56b.zip
version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lame/ChangeLog7
-rw-r--r--media-sound/lame/lame-3.99.5.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index a4f25312f2d1..9ba41f9d309e 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.145 2012/02/04 16:52:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.146 2012/03/01 12:14:46 aballier Exp $
+
+*lame-3.99.5 (01 Mar 2012)
+
+ 01 Mar 2012; Alexis Ballier <aballier@gentoo.org> +lame-3.99.5.ebuild:
+ version bump
*lame-3.99.4 (04 Feb 2012)
diff --git a/media-sound/lame/lame-3.99.5.ebuild b/media-sound/lame/lame-3.99.5.ebuild
new file mode 100644
index 000000000000..9321e55a332f
--- /dev/null
+++ b/media-sound/lame/lame-3.99.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.5.ebuild,v 1.1 2012/03/01 12:14:46 aballier Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug mmx mp3rtp sndfile static-libs"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7
+ sndfile? ( >=media-libs/libsndfile-1.0.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.96-ccc.patch \
+ "${FILESDIR}"/${PN}-3.98-gtk-path.patch
+
+ mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm
+
+ sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
+
+ use mmx || sed -i -e '/AC_PATH_PROG/s:nasm:dIsAbLe&:' configure.in #361879
+
+ AT_M4DIR=${S} eautoreconf
+ epunt_cxx #74498
+}
+
+src_configure() {
+ local myconf
+ use mmx && myconf+="--enable-nasm" #361879
+ use sndfile && myconf+=" --with-fileio=sndfile"
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug debug norm) \
+ --disable-mp3x \
+ $(use_enable mp3rtp) \
+ --enable-dynamic-frontends \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkghtmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dobin misc/mlame
+
+ dodoc API ChangeLog HACKING README STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}