summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-02 17:52:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-02 17:52:21 +0000
commite2e6ddb66ea7cc11bc317e19810d9b9ffd183e0b (patch)
treead2bc6f3c63ce4e5e81270deda7e49495adb5275 /media-sound
parentFix USE typo noticed by Marco Ziebell. (diff)
downloadgentoo-2-e2e6ddb66ea7cc11bc317e19810d9b9ffd183e0b.tar.gz
gentoo-2-e2e6ddb66ea7cc11bc317e19810d9b9ffd183e0b.tar.bz2
gentoo-2-e2e6ddb66ea7cc11bc317e19810d9b9ffd183e0b.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.12.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index cc9aa8ff1b53..452fd735238a 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.82 2014/08/10 21:10:31 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.83 2014/11/02 17:52:21 aballier Exp $
+
+*qjackctl-0.3.12 (02 Nov 2014)
+
+ 02 Nov 2014; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.3.12.ebuild:
+ version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> qjackctl-0.3.10.ebuild,
qjackctl-0.3.11.ebuild:
diff --git a/media-sound/qjackctl/qjackctl-0.3.12.ebuild b/media-sound/qjackctl/qjackctl-0.3.12.ebuild
new file mode 100644
index 000000000000..c430c72fb36c
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.12.ebuild,v 1.1 2014/11/02 17:52:21 aballier Exp $
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa dbus debug portaudio"
+
+RDEPEND="
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:4 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
+
+PATCHES=( "${FILESDIR}/${PN}-0.3.9-gcc47.patch" )
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio)
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+ lupdate ${PN}.pro || die "lupdate failed"
+}