summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-24 06:12:52 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-24 06:12:52 +0000
commite235ed3168484ee595f65711f9fd905ab40fa551 (patch)
tree92ebdd17c4ffc581815f3bd8bbf1de1a775f7de2 /media-sound
parentStable on mips, per #175465. (diff)
downloadgentoo-2-e235ed3168484ee595f65711f9fd905ab40fa551.tar.gz
gentoo-2-e235ed3168484ee595f65711f9fd905ab40fa551.tar.bz2
gentoo-2-e235ed3168484ee595f65711f9fd905ab40fa551.zip
old
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lame/files/digest-lame-3.96.13
-rw-r--r--media-sound/lame/files/lame-3.96.1-largefile.patch15
-rw-r--r--media-sound/lame/lame-3.96.1.ebuild76
3 files changed, 0 insertions, 94 deletions
diff --git a/media-sound/lame/files/digest-lame-3.96.1 b/media-sound/lame/files/digest-lame-3.96.1
deleted file mode 100644
index 12dd61729f63..000000000000
--- a/media-sound/lame/files/digest-lame-3.96.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e1206c46a5e276feca11a7149e2fc6ac lame-3.96.1.tar.gz 1255629
-RMD160 14eee3328706141d5546f33592aaabfb681b4e9d lame-3.96.1.tar.gz 1255629
-SHA256 f4f093e371c999a2a079607b74582a8ef5c1c3c9b322e3e997a47c1ea2afe2a5 lame-3.96.1.tar.gz 1255629
diff --git a/media-sound/lame/files/lame-3.96.1-largefile.patch b/media-sound/lame/files/lame-3.96.1-largefile.patch
deleted file mode 100644
index 117bdb5429be..000000000000
--- a/media-sound/lame/files/lame-3.96.1-largefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: lame-3.96.1/config.h.in
-===================================================================
---- lame-3.96.1.orig/config.h.in
-+++ lame-3.96.1/config.h.in
-@@ -328,3 +328,10 @@
-
- /* Define to `unsigned' if <sys/types.h> does not define. */
- #undef size_t
-+
-+/* Number of bits in a file offset, on hosts where this is settable. */
-+#undef _FILE_OFFSET_BITS
-+
-+/* Define for large files, on AIX-style hosts. */
-+#undef _LARGE_FILES
-+
diff --git a/media-sound/lame/lame-3.96.1.ebuild b/media-sound/lame/lame-3.96.1.ebuild
deleted file mode 100644
index a5407b81fb1c..000000000000
--- a/media-sound/lame/lame-3.96.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.96.1.ebuild,v 1.18 2007/02/17 21:57:45 grobian Exp $
-
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="LAME Ain't an MP3 Encoder"
-HOMEPAGE="http://lame.sourceforge.net"
-SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
-IUSE="gtk debug"
-
-RDEPEND=">=sys-libs/ncurses-5.2
- gtk? ( =x11-libs/gtk+-1.2* )"
-DEPEND="${RDEPEND}
- sys-devel/autoconf"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # The frontened tries to link staticly, but we prefer shared libs
- epatch "${FILESDIR}"/${P}-shared-frontend.patch
-
- # If ccc (alpha compiler) is installed on the system, the default
- # configure is broken, fix it to respect CC. This is only
- # directly broken for ARCH=alpha but would affect anybody with a
- # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
- epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
- autoconf || die
- epunt_cxx # embedded bug #74498
-}
-
-src_compile() {
- # take out -fomit-frame-pointer from CFLAGS if k6-2
- is-flag "-march=k6-3" && filter-flags "-fomit-frame-pointer"
- is-flag "-march=k6-2" && filter-flags "-fomit-frame-pointer"
- is-flag "-march=k6" && filter-flags "-fomit-frame-pointer"
-
- [ "`gcc-fullversion`" == "3.3.2" ] && replace-flags -march=2.0 -march=1.0
-
- local myconf=""
- if use gtk; then
- myconf="${myconf} --enable-mp3x"
- fi
-
- # as of 3.95.1 changed from "yes" to "norm" ("alot" is also accepted)
- use debug \
- && myconf="${myconf} --enable-debug=norm" \
- || myconf="${myconf} --enable-debug=no"
-
- # The user sets compiler optimizations... But if you'd like
- # lame to choose it's own... uncomment one of these (experiMENTAL)
- # myconf="${myconf} --enable-expopt=full \
- # myconf="${myconf} --enable-expopt=norm \
-
- econf \
- --enable-shared \
- --enable-mp3rtp \
- ${myconf} || die
-
- # Parallel make isn't happy
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
-
- dodoc API ChangeLog HACKING PRESETS.draft README* STYLEGUIDE TODO USAGE
- dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
-
- dobin "${S}"/misc/mlame || die
-}