summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-06 14:52:18 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-06 14:52:18 +0000
commitbf5a5142793ab86e3a41312f77df22c0a2bbf029 (patch)
treefaa0abce81c089a7f96d130eca5e0145047d0cf7 /media-sound
parentOnly install qconfig.pri if one of QCONFIG_{ADD,REMOVE} is non-empty (bug #21... (diff)
downloadgentoo-2-bf5a5142793ab86e3a41312f77df22c0a2bbf029.tar.gz
gentoo-2-bf5a5142793ab86e3a41312f77df22c0a2bbf029.tar.bz2
gentoo-2-bf5a5142793ab86e3a41312f77df22c0a2bbf029.zip
Version bump, thanks to Robert Buchholz.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vorbis-tools/ChangeLog8
-rw-r--r--media-sound/vorbis-tools/files/vorbis-tools-1.2.0-with-args.patch14
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.2.0.ebuild42
3 files changed, 63 insertions, 1 deletions
diff --git a/media-sound/vorbis-tools/ChangeLog b/media-sound/vorbis-tools/ChangeLog
index 78910d8faaa4..5b2cd21f5153 100644
--- a/media-sound/vorbis-tools/ChangeLog
+++ b/media-sound/vorbis-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/vorbis-tools
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/ChangeLog,v 1.64 2008/03/02 18:12:18 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/ChangeLog,v 1.65 2008/03/06 14:52:18 drac Exp $
+
+*vorbis-tools-1.2.0 (06 Mar 2008)
+
+ 06 Mar 2008; Samuli Suominen <drac@gentoo.org>
+ +files/vorbis-tools-1.2.0-with-args.patch, +vorbis-tools-1.2.0.ebuild:
+ Version bump, thanks to Robert Buchholz.
02 Mar 2008; Ryan Hill <dirtyepic@gentoo.org>
vorbis-tools-1.1.1-r5.ebuild:
diff --git a/media-sound/vorbis-tools/files/vorbis-tools-1.2.0-with-args.patch b/media-sound/vorbis-tools/files/vorbis-tools-1.2.0-with-args.patch
new file mode 100644
index 000000000000..e6149204b351
--- /dev/null
+++ b/media-sound/vorbis-tools/files/vorbis-tools-1.2.0-with-args.patch
@@ -0,0 +1,14 @@
+diff -ur vorbis-tools-1.2.0.orig/configure.ac vorbis-tools-1.2.0/configure.ac
+--- vorbis-tools-1.2.0.orig/configure.ac 2008-03-03 07:37:31.000000000 +0200
++++ vorbis-tools-1.2.0/configure.ac 2008-03-06 16:31:31.000000000 +0200
+@@ -98,8 +98,8 @@
+ AC_ARG_ENABLE(ogginfo,[ --disable-ogginfo Skip building ogginfo], build_ogginfo="$enableval", build_ogginfo="yes")
+ AC_ARG_ENABLE(vcut, [ --disable-vcut Skip building vcut], build_vcut="$enableval", build_vcut="no")
+ AC_ARG_ENABLE(vorbiscomment, [ --disable-vorbiscomment Skip building vorbiscomment], build_vorbiscomment="$enableval", build_vorbiscomment="yes")
+-AC_ARG_WITH(flac, [ --without-flac Do not compile FLAC support], build_flac=no, build_flac="yes")
+-AC_ARG_WITH(speex, [ --without-speex Do not compile Speex support], build_speex=no, build_speex="yes")
++AC_ARG_WITH(flac, [ --without-flac Do not compile FLAC support], build_flac="$enableval", build_flac="yes")
++AC_ARG_WITH(speex, [ --without-speex Do not compile Speex support], build_speex="$enableval", build_speex="yes")
+
+ dnl --------------------------------------------------
+ dnl Check for generally needed libraries
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.2.0.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.2.0.ebuild
new file mode 100644
index 000000000000..1d1e835f814c
--- /dev/null
+++ b/media-sound/vorbis-tools/vorbis-tools-1.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/vorbis-tools-1.2.0.ebuild,v 1.1 2008/03/06 14:52:18 drac Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="tools for using the Ogg Vorbis sound file format"
+HOMEPAGE="http://www.vorbis.com"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="flac nls +ogg123 speex"
+
+RDEPEND=">=media-libs/libvorbis-1.1
+ flac? ( media-libs/flac )
+ ogg123? ( media-libs/libao net-misc/curl )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-with-args.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF} --enable-vcut \
+ $(use_enable flac) $(use_enable ogg123) \
+ $(use_with nls) $(use_with speex)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS README
+ prepalldocs
+}