summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-25 09:49:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-25 09:49:54 +0000
commit97fcbcb61b5d7d80649fc7d040d35f2f08d05e38 (patch)
treedb8add7ef9af6593314ac703871a7e128c38cac7 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-97fcbcb61b5d7d80649fc7d040d35f2f08d05e38.tar.gz
gentoo-2-97fcbcb61b5d7d80649fc7d040d35f2f08d05e38.tar.bz2
gentoo-2-97fcbcb61b5d7d80649fc7d040d35f2f08d05e38.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pragha/ChangeLog7
-rw-r--r--media-sound/pragha/pragha-1.1.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/pragha/ChangeLog b/media-sound/pragha/ChangeLog
index f2760a9ae602..7626e14c96e0 100644
--- a/media-sound/pragha/ChangeLog
+++ b/media-sound/pragha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/pragha
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/ChangeLog,v 1.25 2013/01/15 19:23:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/ChangeLog,v 1.26 2013/02/25 09:49:54 ssuominen Exp $
+
+*pragha-1.1.2 (25 Feb 2013)
+
+ 25 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> +pragha-1.1.2.ebuild:
+ Version bump.
15 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> pragha-1.1.1.ebuild:
Fix compability with dev-libs/libcdio-paranoia.
diff --git a/media-sound/pragha/pragha-1.1.2.ebuild b/media-sound/pragha/pragha-1.1.2.ebuild
new file mode 100644
index 000000000000..8c724b329b82
--- /dev/null
+++ b/media-sound/pragha/pragha-1.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/pragha-1.1.2.ebuild,v 1.1 2013/02/25 09:49:54 ssuominen Exp $
+
+EAPI=5
+inherit flag-o-matic xfconf
+
+DESCRIPTION="A lightweight music player (with support for the Xfce desktop environment)"
+HOMEPAGE="http://pragha.wikispaces.com/ http://github.com/matiasdelellis/pragha"
+SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm +playlist"
+
+COMMON_DEPEND="dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.28
+ >=dev-libs/keybinder-0.2.2:0
+ dev-libs/libcdio-paranoia
+ media-libs/gst-plugins-base:0.10
+ >=media-libs/libcddb-1.3.2
+ >=media-libs/taglib-1.7.1
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.10
+ playlist? ( >=dev-libs/totem-pl-parser-2.26 )
+ glyr? ( >=media-libs/glyr-1.0.0 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:0.10"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(use_enable playlist totem-plparser)
+ )
+}
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-g -ggdb -O0::' configure || die
+ xfconf_src_prepare
+}
+
+src_configure() {
+ # This version should be fixed for libcdio-paranoia, but the ./configure
+ # check never adds this required -D flag
+ # http://github.com/matiasdelellis/pragha/issues/46
+ append-cppflags -DHAVE_PARANOIA_NEW_INCLUDES
+ xfconf_src_configure
+}