summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-07-28 05:08:11 +0000
committerBen de Groot <yngwin@gentoo.org>2015-07-28 05:08:11 +0000
commit81f23f3a3d7cfcaedeee400d25675cdc1cacb46b (patch)
tree9e0e024e10935950e14b09d522f8648a03dbafc6 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-81f23f3a3d7cfcaedeee400d25675cdc1cacb46b.tar.gz
gentoo-2-81f23f3a3d7cfcaedeee400d25675cdc1cacb46b.tar.bz2
gentoo-2-81f23f3a3d7cfcaedeee400d25675cdc1cacb46b.zip
Reassign to proaudio project. Normalize description, alphabetize deps. Simplify examples installation, and prevent compressing them.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/chuck/ChangeLog7
-rw-r--r--media-sound/chuck/chuck-1.3.5.1.ebuild31
-rw-r--r--media-sound/chuck/metadata.xml20
3 files changed, 34 insertions, 24 deletions
diff --git a/media-sound/chuck/ChangeLog b/media-sound/chuck/ChangeLog
index 9ca65a914159..2610d1b777db 100644
--- a/media-sound/chuck/ChangeLog
+++ b/media-sound/chuck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/chuck
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/ChangeLog,v 1.23 2015/07/27 16:41:24 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/ChangeLog,v 1.24 2015/07/28 05:08:11 yngwin Exp $
+
+ 28 Jul 2015; Ben de Groot <yngwin@gentoo.org> chuck-1.3.5.1.ebuild,
+ metadata.xml:
+ Reassign to proaudio project. Normalize description, alphabetize deps.
+ Simplify examples installation, and prevent compressing them.
*chuck-1.3.5.1 (27 Jul 2015)
diff --git a/media-sound/chuck/chuck-1.3.5.1.ebuild b/media-sound/chuck/chuck-1.3.5.1.ebuild
index e3f1385e44c1..0410ae85a84b 100644
--- a/media-sound/chuck/chuck-1.3.5.1.ebuild
+++ b/media-sound/chuck/chuck-1.3.5.1.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/chuck-1.3.5.1.ebuild,v 1.1 2015/07/27 16:41:24 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/chuck-1.3.5.1.ebuild,v 1.2 2015/07/28 05:08:11 yngwin Exp $
EAPI=5
inherit toolchain-funcs flag-o-matic eutils
-DESCRIPTION="Strongly-timed, Concurrent, and On-the-fly
-Audio Programming Language"
-HOMEPAGE="http://chuck.cs.princeton.edu/release/"
+DESCRIPTION="Strongly-timed, concurrent, and on-the-fly audio programming language"
+HOMEPAGE="http://chuck.cs.princeton.edu/"
SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="+alsa jack examples"
+REQUIRED_USE="|| ( alsa jack )"
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- alsa? ( media-libs/alsa-lib )
+RDEPEND="app-eselect/eselect-chuck
media-libs/libsndfile
- app-eselect/eselect-chuck"
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )"
DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
-REQUIRED_USE="|| ( alsa jack )"
-
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.2.1.1-hid-smc.patch \
"${FILESDIR}"/${PN}-1.3.5.1-makefile.patch
@@ -59,18 +57,15 @@ src_install() {
docinto doc
dodoc doc/*
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins $(find examples -type f)
- for dir in $(find examples/* -type d); do
- insinto /usr/share/doc/${PF}/"${dir}"
- doins "${dir}"/*
- done
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
}
pkg_postinst() {
- elog "Chuck now can use many audio engines, so you can specify audio engine"
- elog "with chuck-{jack,alsa}"
+ elog "Chuck now can use multiple audio engines, so you can specify"
+ elog "the preferred audio engine with chuck-{jack,alsa}"
elog "Or you can use 'eselect chuck' to set the audio engine"
einfo "Calling eselect chuck update..."
diff --git a/media-sound/chuck/metadata.xml b/media-sound/chuck/metadata.xml
index 5f4cf591a435..aaa6999a44df 100644
--- a/media-sound/chuck/metadata.xml
+++ b/media-sound/chuck/metadata.xml
@@ -1,9 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
-<longdescription>ChucK is a new (and developing) audio programming language for
-real-time synthesis, composition, and performance</longdescription>
+ <maintainer>
+ <email>proaudio@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ ChucK is a programming language for real-time sound synthesis and music
+ creation. It is open-source and freely available on MacOS X, Windows, and
+ Linux. ChucK presents a unique time-based, concurrent programming model
+ that is precise and expressive (we call this strongly-timed), dynamic
+ control rates, and the ability to add and modify code on-the-fly. In
+ addition, ChucK supports MIDI, OpenSoundControl, HID device, and
+ multi-channel audio. It is fun and easy to learn, and offers composers,
+ researchers, and performers a powerful programming tool for building and
+ experimenting with complex audio synthesis/analysis programs, and real-time
+ interactive music.
+ </longdescription>
</pkgmetadata>