summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2005-07-17 12:22:54 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2005-07-17 12:22:54 +0000
commit77e242e3d8b8ecb4de211a736b72c6948ce69587 (patch)
tree8dd0da869d4615e5ba8af82a35b526ab04b8a570 /media-sound
parent* cleanups and ~amd64 keyword added (diff)
downloadgentoo-2-77e242e3d8b8ecb4de211a736b72c6948ce69587.tar.gz
gentoo-2-77e242e3d8b8ecb4de211a736b72c6948ce69587.tar.bz2
gentoo-2-77e242e3d8b8ecb4de211a736b72c6948ce69587.zip
Version bump to 0.3.3.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/linuxsampler/ChangeLog11
-rw-r--r--media-sound/linuxsampler/Manifest12
-rw-r--r--media-sound/linuxsampler/files/digest-linuxsampler-0.3.31
-rw-r--r--media-sound/linuxsampler/linuxsampler-0.3.3.ebuild30
4 files changed, 43 insertions, 11 deletions
diff --git a/media-sound/linuxsampler/ChangeLog b/media-sound/linuxsampler/ChangeLog
index 31dae7a37425..6b7883446656 100644
--- a/media-sound/linuxsampler/ChangeLog
+++ b/media-sound/linuxsampler/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/linuxsampler
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.4 2005/07/12 21:58:09 fvdpol Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.5 2005/07/17 12:22:54 fvdpol Exp $
+
+*linuxsampler-0.3.3 (17 Jul 2005)
+
+ 17 Jul 2005; Frank van de Pol <fvdpol@gentoo.org>
+ +linuxsampler-0.3.3.ebuild:
+ Version bump to 0.3.3. It solves one
+ usability issue regarding small fragments / high sampling rates of audio
+ drivers, fixes some compile time errors with GCC 4.0 and a general efficiency
+ bug.
12 Jul 2005; Frank van de Pol <fvdpol@gentoo.org> linuxsampler-0.3.2.ebuild:
unmasked for amd64
diff --git a/media-sound/linuxsampler/Manifest b/media-sound/linuxsampler/Manifest
index 6213432c8ea7..34196fe61e71 100644
--- a/media-sound/linuxsampler/Manifest
+++ b/media-sound/linuxsampler/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 5162c2e2445cb2f8d34710d7dae20061 linuxsampler-0.3.1.ebuild 868
+MD5 69e743275227983fa5e34a84cf2bdb59 linuxsampler-0.3.3.ebuild 847
MD5 69e743275227983fa5e34a84cf2bdb59 linuxsampler-0.3.2.ebuild 847
MD5 084b3955965b1d9fae3cb96ae403c5c4 ChangeLog 677
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 82837a2c0c98e7edc0c15f8d2ba502c3 files/digest-linuxsampler-0.3.1 71
MD5 36b57a6a6d9ff8583dc3af371354dedb files/digest-linuxsampler-0.3.2 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC1D2Lvpz1081QvMkRAo9QAKCD55T5No3k34nDPbHrHu8z7Urw5QCfQYXR
-z3bnTsF7cFTIwurqWc1uYlM=
-=BCk4
------END PGP SIGNATURE-----
+MD5 f19df7afadd03508e29a934891935c17 files/digest-linuxsampler-0.3.3 71
diff --git a/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3 b/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3
new file mode 100644
index 000000000000..2752679518fe
--- /dev/null
+++ b/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3
@@ -0,0 +1 @@
+MD5 8c7d4c97dd731774279006699ee1b10b linuxsampler-0.3.3.tar.bz2 450888
diff --git a/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild b/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild
new file mode 100644
index 000000000000..4562fdc86752
--- /dev/null
+++ b/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild,v 1.1 2005/07/17 12:22:54 fvdpol Exp $
+
+inherit eutils
+
+DESCRIPTION="LinuxSampler is a software audio sampler engine with professional grade features."
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jack"
+RDEPEND="
+ >=media-libs/liblscp-0.2.9
+ >=media-libs/libgig-2.0.1
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf || die "./configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog INSTALL README
+}