summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2009-09-08 00:29:54 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2009-09-08 00:29:54 +0000
commit66c62f22e4da840cd9dc430448decd021bdb6239 (patch)
treeda122a507383ca57112848c9fb0550ea7b2f4d85 /media-sound
parentVersion bumped. Fixed dependency. (diff)
downloadgentoo-2-66c62f22e4da840cd9dc430448decd021bdb6239.tar.gz
gentoo-2-66c62f22e4da840cd9dc430448decd021bdb6239.tar.bz2
gentoo-2-66c62f22e4da840cd9dc430448decd021bdb6239.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xwax/ChangeLog7
-rw-r--r--media-sound/xwax/xwax-0.6.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/media-sound/xwax/ChangeLog b/media-sound/xwax/ChangeLog
index 5e41f0083396..224714761a36 100644
--- a/media-sound/xwax/ChangeLog
+++ b/media-sound/xwax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/xwax
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.6 2009/07/07 04:00:25 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.7 2009/09/08 00:29:54 nixphoeni Exp $
+
+*xwax-0.6 (08 Sep 2009)
+
+ 08 Sep 2009; Joe Sapp <nixphoeni@gentoo.org> +xwax-0.6.ebuild:
+ Version bump
*xwax-0.5 (07 Jul 2009)
diff --git a/media-sound/xwax/xwax-0.6.ebuild b/media-sound/xwax/xwax-0.6.ebuild
new file mode 100644
index 000000000000..ea94e23f3168
--- /dev/null
+++ b/media-sound/xwax/xwax-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-0.6.ebuild,v 1.1 2009/09/08 00:29:54 nixphoeni Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Digital vinyl emulation software"
+HOMEPAGE="http://www.xwax.co.uk/"
+SRC_URI="http://www.xwax.co.uk/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa jack"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-ttf
+ media-fonts/ttf-bitstream-vera
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Remove the forced optimization from 'CFLAGS' and the 'LDFLAGS' line
+ # from Makefile
+ sed -i -e 's:^CFLAGS.*:CFLAGS += -MMD:' \
+ -e 's:^LDFLAGS:#LDFLAGS:' \
+ Makefile || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable alsa) \
+ $(use_enable jack)
+}
+
+src_install() {
+ dobin xwax xwax_import xwax_scan || die
+ dodoc README CHANGES || die
+}