summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-08-08 12:59:03 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-08-08 12:59:03 +0000
commit52be2522077ea21607585abd7a73a777063bee2d (patch)
treef073b00b8f3439a6324b2b270914af97847ace4b /media-sound
parentRaise dependency on mysql for bug #101717. (diff)
downloadgentoo-2-52be2522077ea21607585abd7a73a777063bee2d.tar.gz
gentoo-2-52be2522077ea21607585abd7a73a777063bee2d.tar.bz2
gentoo-2-52be2522077ea21607585abd7a73a777063bee2d.zip
Remove old ebuilds.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/amarok-1.3_beta1.ebuild78
-rw-r--r--media-sound/amarok/amarok-1.3_beta2.ebuild88
-rw-r--r--media-sound/amarok/files/digest-amarok-1.3_beta11
-rw-r--r--media-sound/amarok/files/digest-amarok-1.3_beta21
4 files changed, 0 insertions, 168 deletions
diff --git a/media-sound/amarok/amarok-1.3_beta1.ebuild b/media-sound/amarok/amarok-1.3_beta1.ebuild
deleted file mode 100644
index d8a58b71488b..000000000000
--- a/media-sound/amarok/amarok-1.3_beta1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3_beta1.ebuild,v 1.4 2005/07/31 12:33:50 flameeyes Exp $
-
-inherit kde eutils
-
-MY_P=${P/_/-}
-
-DESCRIPTION="amaroK - the audio player for KDE."
-HOMEPAGE="http://amarok.kde.org/"
-SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="arts flac gstreamer kde mp3 mysql noamazon opengl postgres xine xmms visualization vorbis"
-# kde: enables compilation of the konqueror sidebar plugin
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
- arts? ( kde-base/arts
- || ( ( kde-base/kdemultimedia-arts kde-base/akode )
- kde-base/kdemultimedia ) )
- xine? ( >=media-libs/xine-lib-1_rc4 )
- gstreamer? ( >=media-libs/gstreamer-0.8.8 )
- >=media-libs/tunepimp-0.3.0
- >=media-libs/taglib-1.3.1
- mysql? ( >=dev-db/mysql-4 )
- postgres? ( dev-db/postgresql )
- opengl? ( virtual/opengl )
- xmms? ( >=media-sound/xmms-1.2 )
- visualization? ( media-libs/libsdl
- >=media-plugins/libvisual-plugins-0.2 )"
-
-RDEPEND="${DEPEND}
- gstreamer? ( mp3? ( >=media-plugins/gst-plugins-mad-0.8.6 )
- vorbis? ( >=media-plugins/gst-plugins-ogg-0.8.6
- >=media-plugins/gst-plugins-vorbis-0.8.6 )
- flac? ( >=media-plugins/gst-plugins-flac-0.8.6 ) )"
-
-DEPEND="${DEPEND}
- >=dev-util/pkgconfig-0.9.0"
-
-need-kde 3.3
-
-pkg_setup() {
- if use arts && ! use xine && ! use gstreamer; then
- ewarn "aRts support is deprecated, if you have problems please consider"
- ewarn "enabling support for Xine or GStreamer"
- ewarn "(emerge amarok again with USE=\"xine\" or USE=\"gstreamer\")."
- ebeep 2
- fi
-
- if ! use arts && ! use xine && ! use gstreamer; then
- eerror "amaroK needs either aRts (deprecated), Xine or GStreamer to work,"
- eerror "please try again with USE=\"arts\", USE=\"xine\" or USE=\"gstreamer\"."
- die
- fi
-
- # check whether kdelibs was compiled with arts support
- kde_pkg_setup
-}
-
-src_compile() {
- # amarok does not respect kde coding standards, and makes a lot of
- # assuptions regarding its installation directory. For this reason,
- # it must be installed in the KDE install directory.
- PREFIX="${KDEDIR}"
-
- local myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer)
- $(use_enable mysql) $(use_enable postgres postgresql)
- $(use_with opengl) $(use_with xmms)
- $(use_with visualization libvisual)
- $(use_enable !noamazon amazon)"
-
- kde_src_compile
-}
diff --git a/media-sound/amarok/amarok-1.3_beta2.ebuild b/media-sound/amarok/amarok-1.3_beta2.ebuild
deleted file mode 100644
index 19084724dc20..000000000000
--- a/media-sound/amarok/amarok-1.3_beta2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3_beta2.ebuild,v 1.4 2005/07/31 12:33:50 flameeyes Exp $
-
-inherit kde eutils
-
-MY_P=${P/_/-}
-
-DESCRIPTION="amaroK - the audio player for KDE."
-HOMEPAGE="http://amarok.kde.org/"
-SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="arts flac gstreamer kde mp3 mysql noamazon opengl postgres xine xmms visualization vorbis"
-# kde: enables compilation of the konqueror sidebar plugin
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
- arts? ( kde-base/arts
- || ( ( kde-base/kdemultimedia-arts kde-base/akode )
- kde-base/kdemultimedia ) )
- xine? ( >=media-libs/xine-lib-1_rc4 )
- gstreamer? ( >=media-libs/gstreamer-0.8.8
- >=media-libs/gst-plugins-0.8.6 )
- >=media-libs/tunepimp-0.3.0
- >=media-libs/taglib-1.3.1
- mysql? ( >=dev-db/mysql-4 )
- postgres? ( dev-db/postgresql )
- opengl? ( virtual/opengl )
- xmms? ( >=media-sound/xmms-1.2 )
- visualization? ( media-libs/libsdl
- >=media-plugins/libvisual-plugins-0.2 )"
-
-RDEPEND="${DEPEND}
- gstreamer? ( mp3? ( >=media-plugins/gst-plugins-mad-0.8.6 )
- vorbis? ( >=media-plugins/gst-plugins-ogg-0.8.6
- >=media-plugins/gst-plugins-vorbis-0.8.6 )
- flac? ( >=media-plugins/gst-plugins-flac-0.8.6 ) )"
-
-DEPEND="${DEPEND}
- >=dev-util/pkgconfig-0.9.0"
-
-need-kde 3.3
-
-pkg_setup() {
- if use arts && ! use xine && ! use gstreamer; then
- ewarn "aRts support is deprecated, if you have problems please consider"
- ewarn "enabling support for Xine or GStreamer"
- ewarn "(emerge amarok again with USE=\"xine\" or USE=\"gstreamer\")."
- ebeep 2
- fi
-
- if ! use arts && ! use xine && ! use gstreamer; then
- eerror "amaroK needs either aRts (deprecated), Xine or GStreamer to work,"
- eerror "please try again with USE=\"arts\", USE=\"xine\" or USE=\"gstreamer\"."
- die
- fi
-
- # check whether kdelibs was compiled with arts support
- kde_pkg_setup
-}
-
-src_compile() {
- # amarok does not respect kde coding standards, and makes a lot of
- # assuptions regarding its installation directory. For this reason,
- # it must be installed in the KDE install directory.
- PREFIX="${KDEDIR}"
-
- local myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer)
- $(use_enable mysql) $(use_enable postgres postgresql)
- $(use_with opengl) $(use_with xmms)
- $(use_with visualization libvisual)
- $(use_enable !noamazon amazon)"
-
- kde_src_compile
-}
-
-src_install() {
- kde_src_install
-
- # move the desktop file in /usr/share
- dodir /usr/share/applications/kde
- mv ${D}${KDEDIR}/share/applications/kde/amarok.desktop \
- ${D}/usr/share/applications/kde/amarok.desktop || die
-}
diff --git a/media-sound/amarok/files/digest-amarok-1.3_beta1 b/media-sound/amarok/files/digest-amarok-1.3_beta1
deleted file mode 100644
index 99f1329dcf0b..000000000000
--- a/media-sound/amarok/files/digest-amarok-1.3_beta1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d270fd69f58d3f4ba1c0d7ff4c520f5a amarok-1.3-beta1.tar.bz2 6208007
diff --git a/media-sound/amarok/files/digest-amarok-1.3_beta2 b/media-sound/amarok/files/digest-amarok-1.3_beta2
deleted file mode 100644
index 76667944e45b..000000000000
--- a/media-sound/amarok/files/digest-amarok-1.3_beta2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ca7b22074dab6107c61b3b92dadbe26e amarok-1.3-beta2.tar.bz2 6636211