summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-01 15:09:18 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-01 15:09:18 +0000
commit41b7fd70c493e318fae400b6144de9c0372662ff (patch)
tree24c73dfba8ef29adb016e4703d73593ff38093b1 /media-sound
parentChange to new syntax of eselect-emacs. (diff)
downloadgentoo-2-41b7fd70c493e318fae400b6144de9c0372662ff.tar.gz
gentoo-2-41b7fd70c493e318fae400b6144de9c0372662ff.tar.bz2
gentoo-2-41b7fd70c493e318fae400b6144de9c0372662ff.zip
punt
(Portage version: 2.1.4.1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/muse/ChangeLog7
-rw-r--r--media-sound/muse/files/muse-0.9.1-include.patch21
-rw-r--r--media-sound/muse/files/muse-0.9.1-miscfixes.patch61
-rw-r--r--media-sound/muse/muse-0.9.1.ebuild57
4 files changed, 6 insertions, 140 deletions
diff --git a/media-sound/muse/ChangeLog b/media-sound/muse/ChangeLog
index a6acbb259a0f..48b1caf59a15 100644
--- a/media-sound/muse/ChangeLog
+++ b/media-sound/muse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/muse
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/ChangeLog,v 1.22 2008/02/01 10:38:54 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/ChangeLog,v 1.23 2008/02/01 15:09:17 drac Exp $
+
+ 01 Feb 2008; Samuli Suominen <drac@gentoo.org>
+ -files/muse-0.9.1-include.patch, -files/muse-0.9.1-miscfixes.patch,
+ -muse-0.9.1.ebuild:
+ Remove last GTK+-1.2 version reverting sparc back to ~sparc wrt #205452.
01 Feb 2008; Samuli Suominen <drac@gentoo.org> muse-0.9.2.ebuild:
amd64 stable wrt #205452
diff --git a/media-sound/muse/files/muse-0.9.1-include.patch b/media-sound/muse/files/muse-0.9.1-include.patch
deleted file mode 100644
index ec76f4c2ffd4..000000000000
--- a/media-sound/muse/files/muse-0.9.1-include.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/inchannels.cpp.orig 2005-01-08 18:19:33.805672152 +0100
-+++ src/inchannels.cpp 2005-01-08 18:24:42.329769360 +0100
-@@ -30,6 +30,7 @@
- #include <sys/types.h>
- #include <sys/wait.h>
- #include <signal.h>
-+#include <errno.h>
-
- /* mixing and audioprocessing algorithms*/
- #include <audioproc.h>
-
---- src/pipe.cpp.orig 2005-01-08 18:50:27.093929512 +0100
-+++ src/pipe.cpp 2005-01-08 18:50:48.758635976 +0100
-@@ -31,7 +31,7 @@
- #include <pipe.h>
- #include <jutils.h>
- #include <config.h>
--
-+#include <math.h>
-
- #define MIN(a,b) (a<=b) ? a : b;
diff --git a/media-sound/muse/files/muse-0.9.1-miscfixes.patch b/media-sound/muse/files/muse-0.9.1-miscfixes.patch
deleted file mode 100644
index b08677de7380..000000000000
--- a/media-sound/muse/files/muse-0.9.1-miscfixes.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -u MuSE-0.9.1/src/pipe.cpp MuSE-0.9.1-fixed/src/pipe.cpp
---- MuSE-0.9.1/src/pipe.cpp 2005-01-20 15:07:37.659868128 +0100
-+++ MuSE-0.9.1-fixed/src/pipe.cpp 2005-01-20 15:03:48.514703488 +0100
-@@ -225,9 +225,9 @@
- (data, start,
- blk / read_copy_cb->src_samplesize);
-
-- (char*)start += blk;
-+ start = (int*)( (char*)start + blk );
- len -= blk;
-- (char*)data += blk;
-+ data = (int*)( (char*)data + blk );
- worklen -= blk;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -238,8 +238,8 @@
- (data, start,
- len / read_copy_cb->src_samplesize);
-
-- (char*)data += len;
-- (char*)start += len;
-+ data = (int*)( (char*)data + len );
-+ start = (int*)( (char*)start + len );
- worklen -= len;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -304,9 +304,9 @@
- (end, data,
- blk / write_copy_cb->dst_samplesize);
-
-- (char*)end += blk;
-+ end = (int*)( (char*)end + blk );
- len -= blk;
-- (char*)data += blk;
-+ data = (int*)( (char*)data + blk );
- worklen -= blk;
- if ((start!=buffer)
- && (end==bufferEnd))
-@@ -318,8 +318,8 @@
- (end, data,
- len / write_copy_cb->dst_samplesize);
-
-- (char*)data += len;
-- (char*)end += len;
-+ data = (int*)( (char*)data + len );
-+ end = (int*)( (char*)end + len );
- worklen -= len;
-
- if ((start!=buffer)
-diff -u MuSE-0.9.1/src/radiosched.cpp MuSE-0.9.1-fixed/src/radiosched.cpp
---- MuSE-0.9.1/src/radiosched.cpp 2004-12-15 19:18:06.000000000 +0100
-+++ MuSE-0.9.1-fixed/src/radiosched.cpp 2005-01-20 15:04:28.541618472 +0100
-@@ -762,7 +762,7 @@
- parse_xml_sched_file( sched_rec_callb callb, void *udata, sched_rec *sr )
- {
- gchar *buf=NULL;
-- guint len;
-+ gsize len;
- xml_user_data calldata = {callb, udata, sr};
-
- g_file_get_contents(sched_file_path(), &buf, &len, NULL);
diff --git a/media-sound/muse/muse-0.9.1.ebuild b/media-sound/muse/muse-0.9.1.ebuild
deleted file mode 100644
index 97abfad1bf26..000000000000
--- a/media-sound/muse/muse-0.9.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/muse-0.9.1.ebuild,v 1.6 2007/07/11 19:30:24 mr_bones_ Exp $
-
-inherit eutils
-
-MY_P=${PN/muse/MuSE}-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
-SRC_URI="ftp://ftp.dyne.org/muse/releases/${MY_P}.tar.gz"
-HOMEPAGE="http://muse.dyne.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc sparc x86 amd64"
-IUSE="ncurses gtk debug"
-
-DEPEND="media-sound/lame
- media-libs/libvorbis
- sys-libs/zlib
- sys-apps/sed
- ncurses? ( sys-libs/ncurses )
- gtk? ( =x11-libs/gtk+-1*
- >=dev-libs/glib-1 )"
-RESTRICT="mirror"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-include.patch
- epatch ${FILESDIR}/${P}-miscfixes.patch
-}
-
-src_compile() {
- econf \
- $(use_enable debug) \
- $(use_with gtk x) \
- $(use_with ncurses rubik) \
- || die "econf failed"
-
- emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS} -fpermissive" \
- || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- rm -rf ${D}/usr/doc
- dodoc AUTHORS ChangeLog NEWS README TODO KNOWN-BUGS USAGE
-}
-
-pkg_postinst() {
- elog
- elog "You may want to have a look at /usr/share/doc/${PF}/README.gz"
- elog "for more info."
- elog
-}