summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-11-27 06:38:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-11-27 06:38:24 +0000
commit11e1d865659653115b65516114116084150fc849 (patch)
tree4c70dbf6ee3af2e803269e2f49b836052cdcc1dc /media-sound
parenttreecleaner update jpeg-mmx (diff)
downloadgentoo-2-11e1d865659653115b65516114116084150fc849.tar.gz
gentoo-2-11e1d865659653115b65516114116084150fc849.tar.bz2
gentoo-2-11e1d865659653115b65516114116084150fc849.zip
~x86 keyword, patch to build without jack
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/traverso/ChangeLog6
-rw-r--r--media-sound/traverso/files/traverso-0.30.1-nojack.patch54
-rw-r--r--media-sound/traverso/traverso-0.30.1.ebuild5
3 files changed, 62 insertions, 3 deletions
diff --git a/media-sound/traverso/ChangeLog b/media-sound/traverso/ChangeLog
index 8774496bd8f3..c66223cf063a 100644
--- a/media-sound/traverso/ChangeLog
+++ b/media-sound/traverso/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/traverso
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/ChangeLog,v 1.2 2006/11/25 19:36:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/ChangeLog,v 1.3 2006/11/27 06:38:24 aballier Exp $
+
+ 27 Nov 2006; Alexis Ballier <aballier@gentoo.org>
+ +files/traverso-0.30.1-nojack.patch, traverso-0.30.1.ebuild:
+ ~x86 keyword, patch to build without jack
25 Nov 2006; Alexis Ballier <aballier@gentoo.org> traverso-0.30.1.ebuild:
Fix compile issues with qt-4.1
diff --git a/media-sound/traverso/files/traverso-0.30.1-nojack.patch b/media-sound/traverso/files/traverso-0.30.1-nojack.patch
new file mode 100644
index 000000000000..315d0ace9cea
--- /dev/null
+++ b/media-sound/traverso/files/traverso-0.30.1-nojack.patch
@@ -0,0 +1,54 @@
+--- traverso-0.30.1/src/engine/engine.pro.old 2006-11-27 07:16:26.000000000 +0100
++++ traverso-0.30.1/src/engine/engine.pro 2006-11-27 07:18:39.000000000 +0100
+@@ -19,8 +19,6 @@
+ AudioBus.h \
+ AudioDeviceThread.h \
+ Client.h \
+- AlsaDriver.h \
+- JackDriver.h \
+ AudioChannel.h \
+ Driver.h \
+ memops.h \
+@@ -33,13 +31,16 @@
+ AudioBus.cpp \
+ AudioDeviceThread.cpp \
+ Client.cpp \
+- AlsaDriver.cpp \
+- JackDriver.cpp \
+ Driver.cpp \
+ AudioChannel.cpp \
+ memops.cpp \
+ AudioPlugin.cpp
+
++contains(DEFINES, ALSA_SUPPORT):SOURCES += AlsaDriver.cpp
++contains(DEFINES, ALSA_SUPPORT):HEADERS += AlsaDriver.h
++contains(DEFINES, JACK_SUPPORT):SOURCES += JackDriver.cpp
++contains(DEFINES, JACK_SUPPORT):HEADERS += JackDriver.h
++
+ unix {
+ contains(DEFINES, SSE_OPTIMIZATIONS):SOURCES += sse_functions.s
+ }
+--- traverso-0.30.1/src/engine/AudioDevice.cpp.old 2006-11-27 07:10:12.000000000 +0100
++++ traverso-0.30.1/src/engine/AudioDevice.cpp 2006-11-27 07:11:15.000000000 +0100
+@@ -27,7 +27,10 @@
+ #include "AlsaDriver.h"
+ #endif
+
++#if defined (JACK_SUPPORT)
+ #include "JackDriver.h"
++#endif
++
+ #include "Driver.h"
+ #include "Client.h"
+ #include "AudioChannel.h"
+@@ -398,8 +401,10 @@
+
+ trav_time_t AudioDevice::get_cpu_time( )
+ {
++#if defined (JACK_SUPPORT)
+ if (driver && m_driverType == "Jack")
+ return ((JackDriver*)driver)->get_cpu_load();
++#endif
+
+ trav_time_t currentTime = get_microseconds();
+ float totaltime = 0;
diff --git a/media-sound/traverso/traverso-0.30.1.ebuild b/media-sound/traverso/traverso-0.30.1.ebuild
index ca7f606db685..6cafefca5d5e 100644
--- a/media-sound/traverso/traverso-0.30.1.ebuild
+++ b/media-sound/traverso/traverso-0.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/traverso-0.30.1.ebuild,v 1.2 2006/11/25 19:36:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/traverso-0.30.1.ebuild,v 1.3 2006/11/27 06:38:24 aballier Exp $
inherit eutils qt4 toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://vt.shuis.tudelft.nl/~remon/traverso/${P}.tar.gz"
IUSE="alsa jack sse"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
RDEPEND="$(qt4_min_version 4)
alsa? ( media-libs/alsa-lib )
@@ -25,6 +25,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-nojack.patch"
use jack || sed -ie "s:^\(DEFINES\ +=\ JACK_SUPPORT.*\):#\1:" src/base.pri
use alsa || sed -ie "s:^\(DEFINES\ +=\ ALSA_SUPPORT.*\):#\1:" src/base.pri
use sse || sed -ie "s:^\(.*DEFINES\ +=\ SSE_OPTIMIZATIONS.*\):#\1:" src/base.pri