summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-18 20:05:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-18 20:05:16 +0000
commit0fb1e82a75c7af3bba86cc850a4912834608fdd0 (patch)
tree4c12d7de12b41ee8b70529281a116d3ab60e94c9 /media-sound
parentInitial import (diff)
downloadgentoo-2-0fb1e82a75c7af3bba86cc850a4912834608fdd0.tar.gz
gentoo-2-0fb1e82a75c7af3bba86cc850a4912834608fdd0.tar.bz2
gentoo-2-0fb1e82a75c7af3bba86cc850a4912834608fdd0.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pragha/ChangeLog7
-rw-r--r--media-sound/pragha/pragha-1.1.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/media-sound/pragha/ChangeLog b/media-sound/pragha/ChangeLog
index 5f71a76c5de2..85282a98b982 100644
--- a/media-sound/pragha/ChangeLog
+++ b/media-sound/pragha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/pragha
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/ChangeLog,v 1.15 2012/06/18 19:57:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/ChangeLog,v 1.16 2012/06/18 20:05:16 ssuominen Exp $
+
+*pragha-1.1.0 (18 Jun 2012)
+
+ 18 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +pragha-1.1.0.ebuild:
+ Version bump.
18 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -pragha-1.0.1.ebuild:
old
diff --git a/media-sound/pragha/pragha-1.1.0.ebuild b/media-sound/pragha/pragha-1.1.0.ebuild
new file mode 100644
index 000000000000..73f9177fa878
--- /dev/null
+++ b/media-sound/pragha/pragha-1.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/pragha-1.1.0.ebuild,v 1.1 2012/06/18 20:05:16 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A lightweight music player (with support for the Xfce desktop environment)"
+HOMEPAGE="http://pragha.wikispaces.com/ http://github.com/matiasdelellis/pragha"
+SRC_URI="mirror://github/matiasdelellis/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm +playlist"
+
+COMMON_DEPEND="dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.26
+ >=dev-libs/keybinder-0.2.2
+ >=dev-libs/libcdio-0.78
+ media-libs/gst-plugins-base:0.10
+ >=media-libs/libcddb-1.3.2
+ >=media-libs/taglib-1.7.1
+ >=x11-libs/gtk+-2.22:2
+ x11-libs/libX11
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.8
+ playlist? ( >=dev-libs/totem-pl-parser-2.26 )
+ glyr? ( >=media-libs/glyr-0.9.9 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:0.10"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(use_enable playlist totem-plparser)
+ )
+}
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-g -ggdb -O0::' configure || die
+ xfconf_src_prepare
+}