summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-13 07:31:01 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-13 07:31:01 +0000
commit090bb1db1d9a9e638669e46db12ec35fba9de184 (patch)
tree302daefe45b1187e1c45195cd91be932d552df62 /media-sound
parentBump. Should fix inability to connect (bug #389941, thanks to gw.kenta@gmail.... (diff)
downloadgentoo-2-090bb1db1d9a9e638669e46db12ec35fba9de184.tar.gz
gentoo-2-090bb1db1d9a9e638669e46db12ec35fba9de184.tar.bz2
gentoo-2-090bb1db1d9a9e638669e46db12ec35fba9de184.zip
Version bump (fixes bug #296023).
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/musescore/ChangeLog10
-rw-r--r--media-sound/musescore/files/musescore-1.1-sline.patch11
-rw-r--r--media-sound/musescore/musescore-1.1.ebuild60
3 files changed, 79 insertions, 2 deletions
diff --git a/media-sound/musescore/ChangeLog b/media-sound/musescore/ChangeLog
index 0c0c9f48f1b6..6913fa003475 100644
--- a/media-sound/musescore/ChangeLog
+++ b/media-sound/musescore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/musescore
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/musescore/ChangeLog,v 1.22 2009/07/22 17:35:31 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musescore/ChangeLog,v 1.23 2011/11/13 07:31:01 radhermit Exp $
+
+*musescore-1.1 (13 Nov 2011)
+
+ 13 Nov 2011; Tim Harder <radhermit@gentoo.org> +musescore-1.1.ebuild,
+ +files/musescore-1.1-sline.patch:
+ Version bump (fixes bug #296023).
22 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
musescore-0.9.4.ebuild:
diff --git a/media-sound/musescore/files/musescore-1.1-sline.patch b/media-sound/musescore/files/musescore-1.1-sline.patch
new file mode 100644
index 000000000000..15345803b63f
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.1-sline.patch
@@ -0,0 +1,11 @@
+--- mscore-1.1/mscore/mscore/exportxml.cpp.orig
++++ mscore-1.1/mscore/mscore/exportxml.cpp
+@@ -2363,7 +2363,7 @@
+ el->userOff().y());
+ */
+ if (el->type() == HAIRPIN || el->type() == OTTAVA || el->type() == TEXTLINE) {
+- SLine* sl = static_cast<const SLine*>(el);
++ SLine* sl = static_cast<SLine*>(el);
+ // printf("slin segsz=%d", sl->lineSegments().size());
+ if (sl->lineSegments().size() > 0) {
+ LineSegment* seg = sl->lineSegments().at(0);
diff --git a/media-sound/musescore/musescore-1.1.ebuild b/media-sound/musescore/musescore-1.1.ebuild
new file mode 100644
index 000000000000..b44e04a87a5c
--- /dev/null
+++ b/media-sound/musescore/musescore-1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/musescore/musescore-1.1.ebuild,v 1.1 2011/11/13 07:31:01 radhermit Exp $
+
+EAPI=4
+inherit cmake-utils eutils font
+
+MY_P="mscore-${PV}"
+
+DESCRIPTION="WYSIWYG Music Score Typesetter"
+HOMEPAGE="http://mscore.sourceforge.net"
+SRC_URI="mirror://sourceforge/mscore/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ >=media-libs/libsndfile-1.0.19
+ media-libs/portaudio
+ media-sound/fluidsynth
+ media-sound/jack-audio-connection-kit
+ sys-libs/zlib
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-qt3support:4
+ x11-libs/qt-script:4
+ x11-libs/qt-svg:4
+ x11-libs/qtscriptgenerator"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-context
+ app-doc/doxygen
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/mscore"
+VARTEXFONTS="${T}/fonts"
+FONT_SUFFIX="ttf"
+FONT_S="${S}/mscore/fonts"
+
+src_prepare() {
+ # Fix invalid conversion error
+ epatch "${FILESDIR}"/${P}-sline.patch
+
+ # Don't build redundant qtscriptgenerator libs
+ sed -i -e '/^set(BUILD_SCRIPTGEN/s/TRUE/FALSE/' CMakeLists.txt || die
+}
+
+src_compile() {
+ cmake-utils_src_make lupdate
+ cmake-utils_src_make lrelease
+ cmake-utils_src_make
+}
+
+src_install() {
+ cmake-utils_src_install
+ font_src_install
+ dodoc ChangeLog NEWS README
+ doman packaging/mscore.1
+}