summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-13 18:15:58 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-13 18:15:58 +0000
commit062a367038126e0afe5b092cd3731eb0d2c21a32 (patch)
tree8b1443492980b4a2a599b2cced17a61d4776a62c /media-sound
parentRevision bump adapts use flag changes made in KDE 4.13.1, bug #508350. (diff)
downloadgentoo-2-062a367038126e0afe5b092cd3731eb0d2c21a32.tar.gz
gentoo-2-062a367038126e0afe5b092cd3731eb0d2c21a32.tar.bz2
gentoo-2-062a367038126e0afe5b092cd3731eb0d2c21a32.zip
Revision bump introduces USE flag nepomuk, bug #508350.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-2.8.0-r2.ebuild140
-rw-r--r--media-sound/amarok/metadata.xml1
3 files changed, 148 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index b2a083c269e5..c1d116484f51 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.468 2014/03/14 14:47:58 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.469 2014/05/13 18:15:58 johu Exp $
+
+*amarok-2.8.0-r2 (13 May 2014)
+
+ 13 May 2014; Johannes Huber <johu@gentoo.org> +amarok-2.8.0-r2.ebuild,
+ metadata.xml:
+ Revision bump introduces USE flag nepomuk, bug #508350.
*amarok-2.8.0-r1 (14 Mar 2014)
diff --git a/media-sound/amarok/amarok-2.8.0-r2.ebuild b/media-sound/amarok/amarok-2.8.0-r2.ebuild
new file mode 100644
index 000000000000..d2d287cde0b7
--- /dev/null
+++ b/media-sound/amarok/amarok-2.8.0-r2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.8.0-r2.ebuild,v 1.1 2014/05/13 18:15:58 johu Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it ja
+lt lv nb nl pa pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin sr@latin
+sv tr uk zh_CN zh_TW"
+KDE_REQUIRED="never"
+KDE_HANDBOOK="optional"
+KDE_MINIMAL="4.13.1"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit flag-o-matic kde4-base pax-utils
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} != *9999* ]]; then
+ if [[ $PV == *[6-9][0-9]* ]]; then
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+ else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ fi
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp nepomuk ofa opengl test +utils"
+
+if [[ ${KDE_BUILD_TYPE} == live ]]; then
+ RESTRICT="test"
+fi
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ app-crypt/qca:2
+ $(add_kdebase_dep kdelibs 'nepomuk?,opengl?' 4.8.4)
+ $(add_kdebase_dep kdebase-kioslaves)
+ >=media-libs/taglib-1.7[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtdbus-4.8:4
+ >=dev-qt/qtscript-4.8:4
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ $(add_kdebase_dep audiocd-kio)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-1.0.3 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ >=dev-qt/qtcore-4.8.4:4[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ nepomuk? ( >=kde-base/nepomuk-core-4.9.0 )
+ ofa? ( >=media-libs/libofa-0.9.0 )
+ opengl? ( virtual/opengl )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ virtual/pkgconfig
+ test? ( dev-cpp/gmock )
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ $(add_kdebase_dep phonon-kde)
+"
+
+PATCHES=( "${FILESDIR}/${P}-gmock-1.7.patch" )
+
+src_prepare() {
+ if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ mv doc/en_US doc/en || die
+ sed -e "s/en_US/en/" -i doc/CMakeLists.txt || die
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ -DWITH_SPECTRUM_ANALYZER=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_with ofa LibOFA)
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ # bug 481592
+ pax-mark m "${ED}"/usr/bin/amarok
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}
diff --git a/media-sound/amarok/metadata.xml b/media-sound/amarok/metadata.xml
index c964fd8c4bac..e4da6b0d2ef6 100644
--- a/media-sound/amarok/metadata.xml
+++ b/media-sound/amarok/metadata.xml
@@ -18,6 +18,7 @@
<flag name="mp3tunes">Enable mp3tunes integration</flag>
<flag name="mtp">Enable support for libMTP (Plays4Sure) devices access through libmtp
</flag>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
<flag name="ofa">Use <pkg>media-libs/libofa</pkg> to compute MusicDNS acoustic
fingerprints (used by MusicBrainz)
</flag>