summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-01-18 08:05:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-01-18 08:05:25 +0000
commit2c1a1433aee418e223917d9f473a204b65fa8aa7 (patch)
tree9d8a31b26a92edab1d715bcdc92df4868ff6624e /media-sound/xmms2
parentversion bump (bug #452314) (diff)
downloadgentoo-2-2c1a1433aee418e223917d9f473a204b65fa8aa7.tar.gz
gentoo-2-2c1a1433aee418e223917d9f473a204b65fa8aa7.tar.bz2
gentoo-2-2c1a1433aee418e223917d9f473a204b65fa8aa7.zip
Pulled real patches to fix against libav-9 noticed by Alexis Ballier (bug #443256 by Diego Elio Pettenò).
(Portage version: 2.2.0_alpha153_p6/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'media-sound/xmms2')
-rw-r--r--media-sound/xmms2/ChangeLog8
-rw-r--r--media-sound/xmms2/files/xmms2-0.8-ffmpeg-0.11.patch18
-rw-r--r--media-sound/xmms2/files/xmms2-0.8-libav-9-p2.patch50
-rw-r--r--media-sound/xmms2/files/xmms2-0.8-libav-9.patch35
-rw-r--r--media-sound/xmms2/xmms2-0.8-r1.ebuild4
5 files changed, 95 insertions, 20 deletions
diff --git a/media-sound/xmms2/ChangeLog b/media-sound/xmms2/ChangeLog
index a514493f0abd..41c2bb75a03d 100644
--- a/media-sound/xmms2/ChangeLog
+++ b/media-sound/xmms2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/xmms2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.32 2013/01/16 12:35:31 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.33 2013/01/18 08:05:25 slyfox Exp $
+
+ 18 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/xmms2-0.8-ffmpeg-0.11.patch, +files/xmms2-0.8-libav-9-p2.patch,
+ files/xmms2-0.8-libav-9.patch, xmms2-0.8-r1.ebuild:
+ Pulled real patches to fix against libav-9 noticed by Alexis Ballier (bug
+ #443256 by Diego Elio Pettenò).
16 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org>
+files/xmms2-0.8-libav-9.patch, xmms2-0.8-r1.ebuild:
diff --git a/media-sound/xmms2/files/xmms2-0.8-ffmpeg-0.11.patch b/media-sound/xmms2/files/xmms2-0.8-ffmpeg-0.11.patch
new file mode 100644
index 000000000000..bac2fba7e9fd
--- /dev/null
+++ b/media-sound/xmms2/files/xmms2-0.8-ffmpeg-0.11.patch
@@ -0,0 +1,18 @@
+commit 8743e0c3a4f06053d89b74e40a362ba4949ed53c
+Author: Juho Vähä-Herttua <juhovh@iki.fi>
+Date: Fri Jun 8 09:30:47 2012 +0300
+
+ OTHER: Quick fix to make XMMS2 compile on ffmpeg 0.11
+
+diff --git a/src/plugins/avcodec/avcodec_compat.h b/src/plugins/avcodec/avcodec_compat.h
+index df87b27..f1b1af7 100644
+--- a/src/plugins/avcodec/avcodec_compat.h
++++ b/src/plugins/avcodec/avcodec_compat.h
+@@ -65,3 +65,7 @@ typedef struct AVPacket {
+ # define AVMEDIA_TYPE_AUDIO CODEC_TYPE_AUDIO
+ #endif
+
++/* Calling avcodec_init is not necessary after 53.04 (ffmpeg 0.9) */
++#if LIBAVCODEC_VERSION_INT >= 0x350400
++# define avcodec_init()
++#endif
diff --git a/media-sound/xmms2/files/xmms2-0.8-libav-9-p2.patch b/media-sound/xmms2/files/xmms2-0.8-libav-9-p2.patch
new file mode 100644
index 000000000000..db55bc8a6933
--- /dev/null
+++ b/media-sound/xmms2/files/xmms2-0.8-libav-9-p2.patch
@@ -0,0 +1,50 @@
+commit 4781c507be338fe151e08af7d13267a24cbd7572
+Author: Juho Vähä-Herttua <juhovh@iki.fi>
+Date: Fri Jun 8 09:47:03 2012 +0300
+
+ OTHER: Fix some deprecated warnings in libavcodec
+
+diff --git a/src/plugins/avcodec/avcodec.c b/src/plugins/avcodec/avcodec.c
+index 242e333..c846d64 100644
+--- a/src/plugins/avcodec/avcodec.c
++++ b/src/plugins/avcodec/avcodec.c
+@@ -208,7 +208,7 @@ xmms_avcodec_init (xmms_xform_t *xform)
+ }
+ }
+
+- data->codecctx = avcodec_alloc_context ();
++ data->codecctx = avcodec_alloc_context3 (codec);
+ data->codecctx->sample_rate = data->samplerate;
+ data->codecctx->channels = data->channels;
+ data->codecctx->bit_rate = data->bitrate;
+@@ -219,7 +219,7 @@ xmms_avcodec_init (xmms_xform_t *xform)
+ data->codecctx->codec_id = codec->id;
+ data->codecctx->codec_type = codec->type;
+
+- if (avcodec_open (data->codecctx, codec) < 0) {
++ if (avcodec_open2 (data->codecctx, codec, NULL) < 0) {
+ XMMS_DBG ("Opening decoder '%s' failed", codec->name);
+ goto err;
+ } else {
+diff --git a/src/plugins/avcodec/avcodec_compat.h b/src/plugins/avcodec/avcodec_compat.h
+index f1b1af7..bc770f2 100644
+--- a/src/plugins/avcodec/avcodec_compat.h
++++ b/src/plugins/avcodec/avcodec_compat.h
+@@ -69,3 +69,17 @@ typedef struct AVPacket {
+ #if LIBAVCODEC_VERSION_INT >= 0x350400
+ # define avcodec_init()
+ #endif
++
++/* Map avcodec_alloc_context3 into the deprecated version
++ * avcodec_alloc_context in versions earlier than 53.04 (ffmpeg 0.9) */
++#if LIBAVCODEC_VERSION_INT < 0x350400
++# define avcodec_alloc_context3(codec) \
++ avcodec_alloc_context()
++#endif
++
++/* Map avcodec_open2 into the deprecated version
++ * avcodec_open in versions earlier than 53.04 (ffmpeg 0.9) */
++#if LIBAVCODEC_VERSION_INT < 0x350400
++# define avcodec_open2(avctx, codec, options) \
++ avcodec_open(avctx, codec)
++#endif
diff --git a/media-sound/xmms2/files/xmms2-0.8-libav-9.patch b/media-sound/xmms2/files/xmms2-0.8-libav-9.patch
index 608fc66cf96a..9c13ec41e025 100644
--- a/media-sound/xmms2/files/xmms2-0.8-libav-9.patch
+++ b/media-sound/xmms2/files/xmms2-0.8-libav-9.patch
@@ -1,21 +1,20 @@
-commit a1fe1f45c19c67ed80c05d8276b88d1296f984d2
-Author: Raphaël Bois <virtualdust@gmail.com>
-Date: Sun Nov 25 17:55:12 2012 +0100
+commit d61dbc522f4024debb1f99de758de9e5cc7c0936
+Author: Diego Biurrun <diego@biurrun.de>
+Date: Sun Nov 25 17:33:02 2012 +0100
- OTHER: Add Diego Biurrun in AUTHORS file
+ OTHER: Support for newer libavcodec versions
+
+ Add missing #include
-diff --git a/AUTHORS b/AUTHORS
-index 9d05e1a..3b84fce 100644
---- a/AUTHORS
-+++ b/AUTHORS
-@@ -37,6 +37,10 @@ E: xkr47@outerspace.dyndns.org
- W: http://xkr47.outerspace.dyndns.org/
- D: curl_http updated to xforms, icymetaint plugin (extracted from curl)
+diff --git a/src/plugins/avcodec/avcodec.c b/src/plugins/avcodec/avcodec.c
+index c846d64..114d7df 100644
+--- a/src/plugins/avcodec/avcodec.c
++++ b/src/plugins/avcodec/avcodec.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <glib.h>
++#include <libavutil/mem.h>
+
+ #include "avcodec_compat.h"
-+N: Diego Biurrun
-+E: diego@biurrun.de
-+D: Support for libav 9 in avcodec plugin
-+
- N: Magnus Bjernstad
- E: bjernstad@gmail.com
- D: PythonAPI fixes.
diff --git a/media-sound/xmms2/xmms2-0.8-r1.ebuild b/media-sound/xmms2/xmms2-0.8-r1.ebuild
index 1232635df6dd..8cac9b681311 100644
--- a/media-sound/xmms2/xmms2-0.8-r1.ebuild
+++ b/media-sound/xmms2/xmms2-0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r1.ebuild,v 1.12 2013/01/16 12:35:31 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r1.ebuild,v 1.13 2013/01/18 08:05:25 slyfox Exp $
EAPI=3
@@ -107,6 +107,8 @@ src_prepare() {
cd .waf* || die
epatch "${FILESDIR}/${PN}"-0.8DrO_o-waflib-fix-perl.patch
cd "${S}"
+ epatch "${FILESDIR}/${P}"-ffmpeg-0.11.patch #443256
+ epatch "${FILESDIR}/${P}"-libav-9-p2.patch #443256
epatch "${FILESDIR}/${P}"-libav-9.patch #443256
if has_version dev-libs/libcdio-paranoia; then