summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-09-03 14:55:17 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-09-03 14:55:17 +0000
commit83ab7a0f61742fafd434f8c53e9e29153c4040f8 (patch)
treee6e9783de0a0427b663b1c3ae2498dd94341eacc /media-sound/xfmpc
parentVersion bump, bug fixes. http://releases.xfce.org/feeds/project/xfce4-notes-p... (diff)
downloadgentoo-2-83ab7a0f61742fafd434f8c53e9e29153c4040f8.tar.gz
gentoo-2-83ab7a0f61742fafd434f8c53e9e29153c4040f8.tar.bz2
gentoo-2-83ab7a0f61742fafd434f8c53e9e29153c4040f8.zip
Version bump, misc bug fixes including a new man page. http://releases.xfce.org/feeds/project/xfmpc
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/xfmpc')
-rw-r--r--media-sound/xfmpc/ChangeLog8
-rw-r--r--media-sound/xfmpc/xfmpc-0.2.0.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/media-sound/xfmpc/ChangeLog b/media-sound/xfmpc/ChangeLog
index 80d73420d11d..c282d2927f9f 100644
--- a/media-sound/xfmpc/ChangeLog
+++ b/media-sound/xfmpc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/xfmpc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xfmpc/ChangeLog,v 1.10 2009/05/20 18:05:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xfmpc/ChangeLog,v 1.11 2009/09/03 14:55:17 darkside Exp $
+
+*xfmpc-0.2.0 (03 Sep 2009)
+
+ 03 Sep 2009; Jeremy Olexa <darkside@gentoo.org> +xfmpc-0.2.0.ebuild:
+ Version bump, misc bug fixes including a new man page.
+ http://releases.xfce.org/feeds/project/xfmpc
20 May 2009; Raúl Porcel <armin76@gentoo.org> xfmpc-0.1.0.ebuild:
sparc stable
diff --git a/media-sound/xfmpc/xfmpc-0.2.0.ebuild b/media-sound/xfmpc/xfmpc-0.2.0.ebuild
new file mode 100644
index 000000000000..1400ff0a9bcd
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xfmpc/xfmpc-0.2.0.ebuild,v 1.1 2009/09/03 14:55:17 darkside Exp $
+
+EAPI=2
+inherit fdo-mime
+
+DESCRIPTION="a GTK+ based MPD client focusing on low footprint."
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfmpc"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=media-libs/libmpd-0.15
+ >=x11-libs/gtk+-2.12:2
+ x11-themes/hicolor-icon-theme
+ >=xfce-base/libxfcegui4-4.4
+ >=xfce-base/libxfce4util-4.4"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog IDEAS NEWS README THANKS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}