summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-31 21:12:17 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-31 21:12:17 +0000
commit98d2fee8bd832561ea40bce5c69eb7933b22f2bc (patch)
tree62e7518b9564b0ce8841bea9055d518389f5859e /media-sound/vorbis-tools
parentalpha/sparc stable wrt #236057 (diff)
downloadgentoo-2-98d2fee8bd832561ea40bce5c69eb7933b22f2bc.tar.gz
gentoo-2-98d2fee8bd832561ea40bce5c69eb7933b22f2bc.tar.bz2
gentoo-2-98d2fee8bd832561ea40bce5c69eb7933b22f2bc.zip
Fix bug 236236, upstream ticket 1316.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-sound/vorbis-tools')
-rw-r--r--media-sound/vorbis-tools/ChangeLog9
-rw-r--r--media-sound/vorbis-tools/files/vorbis-tools-1.2.0-oggenc-resample-call-fix.patch30
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.2.0-r2.ebuild52
3 files changed, 90 insertions, 1 deletions
diff --git a/media-sound/vorbis-tools/ChangeLog b/media-sound/vorbis-tools/ChangeLog
index ae5cb8a7a75b..8d1ee5050410 100644
--- a/media-sound/vorbis-tools/ChangeLog
+++ b/media-sound/vorbis-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/vorbis-tools
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/ChangeLog,v 1.82 2008/05/26 16:57:30 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/ChangeLog,v 1.83 2008/08/31 21:12:16 loki_val Exp $
+
+*vorbis-tools-1.2.0-r2 (31 Aug 2008)
+
+ 31 Aug 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/vorbis-tools-1.2.0-oggenc-resample-call-fix.patch,
+ +vorbis-tools-1.2.0-r2.ebuild:
+ Fix bug 236236, upstream ticket 1316.
26 May 2008; Samuli Suominen <drac@gentoo.org>
-files/vorbis-tools-1.1.1-curl-7.16.0.patch,
diff --git a/media-sound/vorbis-tools/files/vorbis-tools-1.2.0-oggenc-resample-call-fix.patch b/media-sound/vorbis-tools/files/vorbis-tools-1.2.0-oggenc-resample-call-fix.patch
new file mode 100644
index 000000000000..c7fa21188c1e
--- /dev/null
+++ b/media-sound/vorbis-tools/files/vorbis-tools-1.2.0-oggenc-resample-call-fix.patch
@@ -0,0 +1,30 @@
+Index: oggenc/oggenc.c
+===================================================================
+--- oggenc/oggenc.c (revision 14552)
++++ oggenc/oggenc.c (working copy)
+@@ -147,6 +151,7 @@
+ char *artist=NULL, *album=NULL, *title=NULL, *track=NULL;
+ char *date=NULL, *genre=NULL;
+ input_format *format;
++ int resampled = 0;
+
+ /* Set various encoding defaults */
+
+@@ -324,6 +329,8 @@
+
+ if(opt.resamplefreq && opt.resamplefreq != enc_opts.rate) {
+ int fromrate = enc_opts.rate;
++
++ resampled = 1;
+ enc_opts.resamplefreq = opt.resamplefreq;
+ if(setup_resample(&enc_opts)) {
+ errors++;
+@@ -369,7 +376,7 @@
+ clear_scaler(&enc_opts);
+ if(opt.downmix)
+ clear_downmix(&enc_opts);
+- if(opt.resamplefreq && opt.resamplefreq != enc_opts.rate)
++ if(resampled)
+ clear_resample(&enc_opts);
+ clear_all:
+
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.2.0-r2.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..0b2ea52f7735
--- /dev/null
+++ b/media-sound/vorbis-tools/vorbis-tools-1.2.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/vorbis-tools-1.2.0-r2.ebuild,v 1.1 2008/08/31 21:12:16 loki_val Exp $
+
+EAPI=1
+
+inherit base autotools eutils
+
+DESCRIPTION="tools for using the Ogg Vorbis sound file format"
+HOMEPAGE="http://www.vorbis.com"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="flac nls +ogg123 speex"
+
+RDEPEND=">=media-libs/libvorbis-1.1
+ flac? ( media-libs/flac )
+ ogg123? ( media-libs/libao net-misc/curl )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-with-args.patch"
+ "${FILESDIR}"/${P}-sec.patch
+ "${FILESDIR}"/${P}-oggenc-resample-call-fix.patch )
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf --enable-vcut \
+ $(use_enable nls) \
+ $(use_enable ogg123) \
+ $(use_with flac) \
+ $(use_with speex)
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake docdir=/usr/share/doc/${PF} DESTDIR="${D}" \
+ install || die "emake install failed."
+
+ dodoc AUTHORS CHANGES README
+ prepalldocs
+}